Bug 446627 - evdev lacks EmulateWheel option
evdev lacks EmulateWheel option
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
https://bugs.freedesktop.org/show_bug...
: FutureFeature
: 446577 454598 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 09:23 EDT by Dag
Modified: 2008-10-13 20:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 04:00:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my xorg.conf with emulatewheel not working (1.03 KB, text/plain)
2008-05-22 09:20 EDT, Dag
no flags Details
my xorg.0.log with emulatewheel not working (30.70 KB, text/plain)
2008-05-22 09:22 EDT, Dag
no flags Details
my xorg.0.log without any xorg.conf (35.37 KB, text/plain)
2008-05-22 09:35 EDT, Dag
no flags Details

  None (edit)
Description Dag 2008-05-15 09:23:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
When enabling the emulatewheel option for a mouse (pointer) device it doesn't have any effect.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1.add the emulatewheel options to your mouse device section (a code which is known to work in Fedora7 and Fedora8)
2.restart Xorg or reboot
3.there is no wheel emulation at all, just the normal behaviour of the buttons

Actual Results:
there was no emulated wheel at all: when maintaining the button down and moving the mouse, you only get the normal action associated with the button and a moving cursor.

Expected Results:
when clicking on the button and moving the mouse at the same time, the cursor should be blocked and the pages should scroll, just as if it was a mouse's wheel action.

Additional info:
it seems that Xorg just ignores the mousewheel options.
There is a bug report on the subject specifically for an IBM trackpoint:
https://bugzilla.redhat.com/show_bug.cgi?id=446577

here are the lines I add to xorg.conf:
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "PS/2"
        Option      "Emulate3Buttons" "no"
        Option      "ZAxisMapping" "4 5"
        Option      "EmulateWheel" "true"
        Option      "EmulateWheelButton" "2"
        Option      "EmulateInertia" "50"
EndSection
Comment 1 Matěj Cepl 2008-05-16 17:26:47 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Dag 2008-05-22 09:20:04 EDT
Created attachment 306372 [details]
my xorg.conf with emulatewheel not working
Comment 3 Dag 2008-05-22 09:22:48 EDT
Created attachment 306374 [details]
my xorg.0.log with emulatewheel not working
Comment 4 Dag 2008-05-22 09:35:48 EDT
Created attachment 306375 [details]
my xorg.0.log without any xorg.conf
Comment 5 Adam Sloboda 2008-05-27 12:02:22 EDT
Hi,

I had the same problem when I backported xorg 7.3 to Debian etch (also some 
keycodes were broken -- Up arrow).  evdev input device is interfering in some 
way so I purged it and now it works with the old configuration (haven't noticed 
any problems yet).

Regards,
Adam
Comment 6 Dag 2008-07-09 05:11:44 EDT
Hi I update this bug report and closes it because it's not an xorg-x11-drv-mouse
but an xorg-x11-drv-evdev bug which is lacking emulatewheel option.

a simple workaround is to add in your xorg.conf :
Section "ServerFlags"
        Option "NoAutoAddDevices"
EndSection

then add an input section with the driver "mouse":
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "explorerPS/2"
        Option      "Buttons"   "5"
        Option      "EmulateInertia" "50"
        Option          "Emulate3Buttons" "on"
        Option          "Emulate3Timeout" "50"
        Option          "EmulateWheel" "on"
        Option          "EmulateWheelTimeout" "200"
        Option          "EmulateWheelButton" "2"
        Option          "XAxisMapping"  "6 7"
        Option          "YAxisMapping"  "4 5"
        Option          "ZAxisMapping" "4 5"
EndSection

and add this input device to your serverlayout section.
Then add any of your devices because it won't be autodetected anymore.

I reported that in this bug report:
https://bugzilla.redhat.com/show_bug.cgi?id=454598
Comment 7 Peter Hutterer 2008-07-14 03:46:53 EDT
*** Bug 454598 has been marked as a duplicate of this bug. ***
Comment 8 Peter Hutterer 2008-07-14 04:00:11 EDT
Renaming this bug and marking the other one as duplicate, so the history is
easier to track down.

Resolving as UPSTREAM, it is a feature request for evdev.
https://bugs.freedesktop.org/show_bug.cgi?id=4147
Comment 9 Peter Hutterer 2008-07-14 21:47:13 EDT
*** Bug 446577 has been marked as a duplicate of this bug. ***
Comment 10 bperkins 2008-10-13 20:39:09 EDT
For what it's worth.  I was able to get wheel emulation to work by downloading the latest evdev from freedesktop.org (I had to engage in a bit of ugliness to get it to compile, probably some stuff is broken) and just copiing the .so file over the installed one. 

I may or may not have needed some hal settings described here:
http://mvogt.wordpress.com/2008/08/15/xorg-evdev-and-emulatewheel/
Comment 11 Peter Hutterer 2008-10-13 20:59:30 EDT
FYI I pushed evdev yesterday to what will be F11. See
http://koji.fedoraproject.org/koji/buildinfo?buildID=66117

Once evdev 2.1 is out, it'll become available in F9 and F10 too.

Note You need to log in before you can comment on or make changes to this bug.