Bug 446590 - Installation from live CD fails after resizing NTFS partition
Installation from live CD fails after resizing NTFS partition
Status: CLOSED DUPLICATE of bug 439633
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 05:02 EDT by Dominic Dunlop
Modified: 2008-05-15 11:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 10:50:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda diagnostic (800.40 KB, text/plain)
2008-05-15 05:02 EDT, Dominic Dunlop
no flags Details

  None (edit)
Description Dominic Dunlop 2008-05-15 05:02:55 EDT
[Regret cannot check existing bugs: your pages make JavaScript peg the CPU in both Safari and FireFox 
on my Mac.]

Description of problem:
Failure after resizing NTFS partition

Version-Release number of selected component (if applicable):
Not known: unable to persuade anaconda to cough up this info.

How reproducible:
Have not tried.

Steps to Reproduce:
1. System running Windows XP SP2 from 80GB SCSI RAID. Files occupying perhaps 30GB of single 
whole-disk partition. File system previously defragged from Windows.
2. Selected resize to 35GB and install default layout in free space.
3. anaconda signalled error after compacting (diagnostic attached)
4. Windows partition had been shrunk: Windows booted from it after automatic disk check
  
Actual results:


Expected results:


Additional info:
Comment 1 Dominic Dunlop 2008-05-15 05:02:55 EDT
Created attachment 305456 [details]
anaconda diagnostic
Comment 2 Chris Lumens 2008-05-15 10:50:03 EDT
Yet another case of us getting screwed because the device node isn't created for us.

You can most likely work around this by running anaconda again and using the
exact same partitioning setup.  It looks like your Windows partition was resized
so you shouldn't need to step through that again.

*** This bug has been marked as a duplicate of 439633 ***
Comment 3 Dominic Dunlop 2008-05-15 11:16:09 EDT
> You can most likely work around this by running anaconda again and using the
> exact same partitioning setup.

Afraid not: Windows sees the partition as smaller, but Linux does not. Being loth to diddle with fdisk as 
the message from resizentfs suggests, I shall see a man with PartitionMagic about the issue tomorrow...

> It looks like your Windows partition was resized
> so you shouldn't need to step through that again.

Right. That (almost) worked.

Note You need to log in before you can comment on or make changes to this bug.