Bug 446615 - Screen flicker with ATI X800 and GNOME desktop
Screen flicker with ATI X800 and GNOME desktop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10Beta/F10BetaBlocker
  Show dependency treegraph
 
Reported: 2008-05-15 07:53 EDT by Joachim Frieben
Modified: 2008-09-09 16:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 16:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf created by anaconda plus 1400x1050 mode selection (652 bytes, text/plain)
2008-05-15 07:55 EDT, Joachim Frieben
no flags Details
Xorg.0.log for xorg.conf attached above (239.21 KB, text/plain)
2008-05-15 07:56 EDT, Joachim Frieben
no flags Details
Xorg.0.log w/o xorg.conf (242.45 KB, application/octet-stream)
2008-05-15 09:42 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2008-05-15 07:53:51 EDT
Description of problem:
After upgrading to current "rawhide", screen flicker occurs whenever
some GNOME application is launched but not in the case of plain X
applications. The issue appears to be due to repeated probing (xrandr?)
as corresponding sections in Xorg.0.log indicate which are appended
continuously as the flicker occurs.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.8.0-14.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Log in to GNOME.
2. Launch gnome-terminal, gedit, etc.
  
Actual results:
Screen flickers when application window appears.

Expected results:
No flicker.

Additional info:
- I'm not aware of this happening before upgrading to post-F9 "rawhide".
- Launching xterm, etc. does not trigger this behaviour.
- After merely logging in to GNOME, it takes about 20 seconds during
  which the screen keeps flickering until the GNOME desktop eventually
  appears. In $HOME/.xsession-errors, the following warnign appears:
  ** (nautilus:5003): WARNING **: Unable to add monitor: Not supported
- gnome-session-2.22.1.1-1.fc9
  gnome-settings-daemon-2.22.1-1.2008.03.26.8.fc9
  haven't been updated because otherwise nautilus won't come up at all
  or cannot be updated because of broken dependencies respectively.
Comment 1 Joachim Frieben 2008-05-15 07:55:15 EDT
Created attachment 305479 [details]
xorg.conf created by anaconda plus 1400x1050 mode selection
Comment 2 Joachim Frieben 2008-05-15 07:56:14 EDT
Created attachment 305480 [details]
Xorg.0.log for xorg.conf attached above
Comment 3 Joachim Frieben 2008-05-15 09:42:57 EDT
Created attachment 305488 [details]
Xorg.0.log w/o xorg.conf

Running w/o xorg.conf doesn't make a difference.
Comment 4 Matěj Cepl 2008-05-16 17:53:51 EDT

*** This bug has been marked as a duplicate of 438734 ***
Comment 5 Joachim Frieben 2008-06-05 18:36:08 EDT
After reverting the system to a fully updated F9, the issue is gone. At
login, the screen flickers a couple of times. After that, everything
behaves as expected. Driver is still xorg-x11-drv-ati-6.8.0-14.fc9.x86_64.
Comment 6 Joachim Frieben 2008-08-29 04:45:40 EDT
Reopening since bug 438734 is an F9 bug whereas the present one is a post-F9 bug.
Comment 7 Ola Thoresen 2008-08-30 14:46:29 EDT
Same issue with intel_drv from RawHide (updated today)

xorg-x11-drv-i810-2.4.2-1.fc10.i386
Comment 8 Ola Thoresen 2008-09-04 16:24:56 EDT
Seems to have been resolved for me with todays rawhide.

xorg-x11-drv-i810-2.4.2-3.fc10.i386

Note You need to log in before you can comment on or make changes to this bug.