Bug 438734 - (background-blink) Occasional whole screen flickering
Occasional whole screen flickering
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2008-03-24 15:10 EDT by Adam Huffman
Modified: 2009-07-14 13:34 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.2.1-20.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 13:34:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
X log (23.66 KB, text/plain)
2008-03-24 15:10 EDT, Adam Huffman
no flags Details
Trailing section of Xorg.0.log which is appended repeatedly (5.32 KB, text/plain)
2008-05-18 05:29 EDT, Joachim Frieben
no flags Details
Xorg.0.log for HP A4576A attached to ATI Radeon X800 SE (R430) (302.93 KB, text/plain)
2008-05-28 08:33 EDT, Joachim Frieben
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 13326 None None None Never

  None (edit)
Description Adam Huffman 2008-03-24 15:10:32 EDT
Description of problem:
For the last month or so, running rawhide on a Vaio SZ3 laptop I see occasional
flickering of the whole screen in X.  At moments when the system is very highly
loaded, it is apparent that all screen elements are being redrawn, slowly.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

lspci output:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML
Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3
(rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
07:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8036 PCI-E Fast
Ethernet Controller (rev 15)
09:04.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
09:04.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394
Host Controller
09:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader
Comment 1 Adam Huffman 2008-03-24 15:10:32 EDT
Created attachment 298918 [details]
X log
Comment 2 Adam Huffman 2008-03-24 16:09:40 EDT
There is a related problem in which the X screen goes black (not completely
blank, as the LCD is still active).  May be worth a separate bugzilla report.
Comment 3 Jon Stanley 2008-03-24 17:38:47 EDT
I've seen this too, I know that there is bug 435747 regarding the backlight
going off, particularly after suspend/resume, but I've not tried to suspend my
laptop since installing rawhide on it yesterday :)
Comment 4 Bill Nottingham 2008-04-08 01:31:34 EDT
You can probably work around this by adding:

Option "FramebufferCompression" "False"

to your 'Device' section in your xorg.conf.

See https://bugs.freedesktop.org/show_bug.cgi?id=13326
Comment 5 Bill Nottingham 2008-04-08 17:27:52 EDT
Should be fixed in xorg-x11-drv-i810-2.2.1-20.fc9 by forcing
FramebufferCompression off by default.
Comment 6 Adam Huffman 2008-04-09 19:53:17 EDT
Re-opening this bug because I've installed the mentioned version, having removed
the explicit mention of FramebufferCompression in xorg.conf and there is still
occasional flickering, at least on my hardware.
Comment 7 Piotr Krawiec 2008-04-22 05:22:55 EDT
I can confirm screen flickering after resume from suspend, maybe framebuffer
compression resets to on? My "Device" section is as follows:

Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"
	Option "AccelMethod" "exa"
	Option "MigrationHeuristic" "greedy"
	Option "ExaNoComposite" "false"

Intel driver is xorg-x11-drv-i810-2.2.1-20.fc9
Comment 8 Adam Huffman 2008-04-23 18:34:39 EDT
An update - I've just installed xorg-x11-drv-i810-2.2.1-21.fc9.x86_64 and the Xv
problem mentioned in other bugs is solved but the whole screen flickering
returns if I use compiz instead of metacity.
Comment 9 Bug Zapper 2008-05-14 02:48:59 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 10 Matěj Cepl 2008-05-16 17:53:51 EDT
*** Bug 446615 has been marked as a duplicate of this bug. ***
Comment 11 Joachim Frieben 2008-05-18 05:29:31 EDT
Created attachment 305838 [details]
Trailing section of Xorg.0.log which is appended repeatedly

(In reply to comment #10)
> *** Bug 446615 has been marked as a duplicate of this bug. ***

Bug 446615 is about an ATI Radeon X800 card using the "radeon" driver,
not the "intel" one. In my case, the attached text block is appended
to Xorg.0.log over and over again. It suffices to launch some GNOME
application to trigger the flicker [a plain X application does not do
this]. Accordingly, the number of copies in Xorg.0.log quickly reaches
a three digit figure in a short period of time. I really wonder how
bug 446615 would be a duplicate of the present one. The symptoms are
fairly different. I would rather suspect a RANDR (applet) malfunction.
Comment 12 Joachim Frieben 2008-05-28 08:33:04 EDT
Created attachment 306927 [details]
Xorg.0.log for HP A4576A attached to ATI Radeon X800 SE (R430)

No improvement for the latest koji build xorg-x11-drv-ati-6.8.0-17.fc9.
Xorg.0.log shows a trailing section about registering and removing a
"DVI-0:ddc2" device. Said section is repeated over and over again,
and only the first one has been kept in the attachment which otherwise
contains the full Xorg log.

In fact, no display is connected to the DVI output, only an analog CRT
model HP A4576A to VGA-0. Executing 'xrandr -q' returns:

Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 1920 x 1200
VGA-0 connected 1400x1050+0+0 (normal left inverted right x axis y axis)
364mm x 291mm
   1400x1050	  85.0*+  74.8	  70.0	  60.0
   1920x1200	  60.0
   1920x1080	  59.9
   1600x1200	  85.0	  75.0	  75.0	  70.0	  65.0	  60.0	  60.0
   1680x1050	  84.9	  74.9	  69.9	  60.0	  59.9	
   1600x1024	  60.2
   1400x1050@75   75.0
   1280x1024	  85.0	  85.0	  73.7	  75.0	  60.0	  60.0
   1440x900	  59.9
   1280x960	  85.0	  60.0
   1360x768	  59.8	  60.0
   1152x864	 100.0	  85.1	  85.0	  75.0	  75.0	  70.0	  60.0
   1024x768	  85.0	  85.0	  75.1	  75.0	  70.1	  60.0
   832x624	  74.6	
   800x600	  85.0	  85.1	  72.2	  75.0	  60.3	  56.2
   640x480	  85.0	  85.0	  75.0	  72.8	  75.0	  60.0	  59.9
   720x400	  85.0	  70.1	
   640x400	  85.1	
   640x350	  85.1	
None disconnected (normal left inverted right x axis y axis)
DVI-0 disconnected (normal left inverted right x axis y axis)

So, which component should this bug get assigned to? Certainly not
xorg-x11-drv-i810, as this is a more general issue.
Comment 13 Adam Huffman 2008-09-16 16:35:37 EDT
An update - the flickering starts happening again if I switch to compiz with xorg-x11-drv-i810-2.4.2-8.fc10.x86_64 on Rawhide.
Comment 14 Edouard Bourguignon 2008-11-19 07:19:09 EST
Same problem here on F10 rawhide:
xorg-x11-drv-i810-2.5.0-3.fc10.i386 (Dell Latitude D610 w/ intel gma915)
Comment 15 Ilya Ryabinkin 2009-02-09 09:01:26 EST
I confirm the bug.
Fedora 10 fully updated. Same hardware: Dell Latitude D610, intel gma915
Comment 16 kkjensen 2009-02-09 10:15:54 EST
I also can confirm the bug on an Acer Aspire 3610 with intel gma915.

F10 fully updated.

intel driver has the blinking and some issues with scaling the video for an attached projector.

the i810 driver (which I used to use) doesn't work at all...leaves me at a blank black screen with a single blinking cursor in the top left with no fallback to runmode 3 like what used to happen when the wrong driver was chosen.

Just an idea:  If driver wierdness (although different in each case) is present with both drivers, is it perhaps something in the kernel?  Complete disregard to this noob comment is expected.
Comment 17 Bug Zapper 2009-06-09 19:50:31 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 18 Bug Zapper 2009-07-14 13:34:46 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.