This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 446621 - Installer shows and silently does not install unavailable groups
Installer shows and silently does not install unavailable groups
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
ppc64 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jeremy Katz
:
: 450538 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-05-15 08:54 EDT by Kari Hautio
Modified: 2014-03-16 23:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 15:51:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
install.log (31.80 KB, text/plain)
2008-05-16 02:34 EDT, Kari Hautio
no flags Details
anaconda-ks.cfg (1.36 KB, application/octet-stream)
2008-05-16 02:35 EDT, Kari Hautio
no flags Details
run of yum groupinstall XFCE (69.39 KB, application/octet-stream)
2008-05-16 02:36 EDT, Kari Hautio
no flags Details

  None (edit)
Description Kari Hautio 2008-05-15 08:54:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Description of problem:
Installed Fedora 9 on PS3 and selected lightweight window manager (XFCE).

Graphical login results in empty (nothing but background) desktop.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Install Fedora 9 on PS3, unselect Gnome and select XFCE
2. Try to start graphical session

Actual Results:
Session is started with only mouse cursor on default background (no window manager, nor windows)

A second X server is spawned and greeter activates (on other VC, which becames the active one)

Expected Results:
Normal session startup

Additional info:
Comment 1 Kevin Fenzi 2008-05-15 11:04:10 EDT
Can you attach your ~/.xsession-errors file?

Also, if you do a 'yum groupinstall XFCE' in a console what is the output? 
Comment 2 Kari Hautio 2008-05-16 02:34:58 EDT
Created attachment 305635 [details]
install.log
Comment 3 Kari Hautio 2008-05-16 02:35:28 EDT
Created attachment 305637 [details]
anaconda-ks.cfg
Comment 4 Kari Hautio 2008-05-16 02:36:12 EDT
Created attachment 305638 [details]
run of yum groupinstall XFCE
Comment 5 Kari Hautio 2008-05-16 02:41:04 EDT
no .xsession-errors files found

yum groupinstall XFCE solves the problem.

Attached anaconda config and log.

It seems that for some reason installer fails to pull XFCE packages in even
though xfce-desktop is specfied.
Comment 6 Kevin Fenzi 2008-05-16 10:53:38 EDT
Yeah, it looks like it didn't install them. ;( 

What was your install method and media? 
Comment 7 Kevin Fenzi 2008-05-16 19:55:36 EDT
It looks like this bug is due to the a conditional package in the Xfce group:
      <packagereq type="conditional"
requires="im-chooser">imsettings-xfce</packagereq>

im-chooser is available on the media, so anaconda decides it can offer the
entire Xfce group, when none of the other Xfce packages are on the media. 
:(

Comment 8 Kari Hautio 2008-05-19 03:14:15 EDT
Installed using the release PPC DVD image, media test executed.
Comment 9 Kevin Fenzi 2008-05-19 11:04:44 EDT
Yeah, that confirms the bug described in comment #7. 

I have added this to the common issues page, so hopefully others running into it
will see the workaround. 

Moving forward we should make sure this does not happen for F10. 
(Not much we can do for F9 as the media is already shipped). 
Comment 10 Kevin Fenzi 2008-05-19 16:09:17 EDT
I am moving this bug over to anaconda to get fixed for the next release. 
Also changing the Summary to be a bit more descriptive and adding it to the F10
blocker bug. 

Thanks again for reporting this!
Comment 11 Bill Nottingham 2008-06-09 10:32:23 EDT
*** Bug 450538 has been marked as a duplicate of this bug. ***
Comment 12 Michal Schmidt 2008-08-21 04:02:52 EDT
Surely this bug should block F10Blocker, not the other way around. Changing it.
Comment 13 Chris Lumens 2008-08-26 15:51:14 EDT
The problem here is that the conditional as listed in comps was backwards, but this is fixed in F10 Alpha.  Please try the alpha and verify that it's fixed.  If not, feel free to reassign it back to us and we'll look at what we can do.

Note You need to log in before you can comment on or make changes to this bug.