Bug 446703 - totem-pl-parser
totem-pl-parser
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: GConf (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 447040 447041 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 14:22 EDT by Frank Murphy
Modified: 2008-05-22 04:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 04:30:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Yum Update (snipped) (1.28 KB, text/plain)
2008-05-15 14:22 EDT, Frank Murphy
no flags Details
Yum Update (Full) (4.12 KB, text/plain)
2008-05-15 15:08 EDT, Frank Murphy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 533494 None None None Never

  None (edit)
Description Frank Murphy 2008-05-15 14:22:02 EDT
Description of problem: yum-update dependency errors


Version-Release number of selected component (if applicable):
totem-pl-parser-2.22.2-1.fc9.i386

How reproducible:
F9Release to Rawhide

Steps to Reproduce:
1. Yum Update
2.
3.
  
Actual results:
Error: Missing Dependency(s)

Expected results:
update to rawhide

Additional info:  Manual removal of totem-pl-parser-2.22.2-1.fc9.i386 + depends,
and then yum install clears that problem
Comment 1 Frank Murphy 2008-05-15 14:22:02 EDT
Created attachment 305515 [details]
Yum Update (snipped)
Comment 2 Bastien Nocera 2008-05-15 14:58:21 EDT
Please attach the full "yum update" log, I don't see what would need a newer
version of totem-pl-parser that could be causing problems. FWIW, I've updated my
main desktop from F8 to F9 using yum and didn't encounter any problems.
Comment 3 Frank Murphy 2008-05-15 15:08:35 EDT
Created attachment 305524 [details]
Yum Update (Full)

This is F9 to F10 Rawhide,
unfortunatly had already done the manual swap.
Comment 4 Bastien Nocera 2008-05-15 15:29:15 EDT
F9 to F10 won't work because totem and rhythmbox currently don't build (it was
xulrunner changes, then evolution-data-server changes, and now it's GConf problems).

See bug 446690

I'll leave this open and close it when totem and rhythmbox could finally be
rebuilt. FYI, when updating to a rawhide, it's pretty normal that some things
don't install. Install yum-utils and pass --skip-broken to yum in the meanwhile.
Comment 5 Bastien Nocera 2008-05-17 08:05:54 EDT
*** Bug 447040 has been marked as a duplicate of this bug. ***
Comment 6 Bastien Nocera 2008-05-17 08:06:18 EDT
*** Bug 447041 has been marked as a duplicate of this bug. ***
Comment 7 Bastien Nocera 2008-05-17 13:13:02 EDT
The inability to build is due to the gconf-based elements not working, because
D-Bus can't be initialised:
process 10987: D-Bus library appears to be incorrectly set up; failed to read
machine uuid: Failed to open "/var/lib/dbus/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.
GConf Error: Failed to contact configuration server; some possible causes are
that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks
due to a system crash. See http://www.gnome.org/projects/gconf/ for information.
(Details -  1: Failed to get connection to session: dbus-launch failed to
autolaunch D-Bus session: Autolaunch error: X11 initialization failed.

There's no machine-id in the buildroots, and no X11.
Comment 8 Ray Strode [halfline] 2008-05-17 22:54:58 EDT
hmm, that should have been fixed in gconf-2.22.0-6 which has:

+        /* if the bus isn't running and we don't want to start gconfd then
+         * we don't want to autolaunch the bus either, so bail early.
+         */
+        if (g_getenv ("DBUS_SESSION_BUS_ADDRESS") == NULL && !start_if_not_found) {
+                if (failure_log)
+                    g_string_append_printf (failure_log,
+                                            _("Not running within active
session"));
+                return NULL;
+        }
+
Comment 9 Bastien Nocera 2008-05-18 08:11:00 EDT
Does that snippet mean that gconf won't get autostarted at all if there's no
session dbus daemon?

The build was using:
DEBUG util.py:250:   GConf2                  i386       2.22.0-7.fc10    build 
           1.6 M

The full logs at:
http://koji.fedoraproject.org/koji/buildinfo?buildID=49443
Comment 10 Ray Strode [halfline] 2008-05-18 18:08:29 EDT
yes, which causes other problems that I'm going to be addressing but shouldn't
cause problems for build time schema install, since --makefile-install-rule
implies --direct (and no gconfd).
Comment 11 Ray Strode [halfline] 2008-05-18 18:09:52 EDT
oh i see, your problem isn't related to schema installation.
Comment 12 Ray Strode [halfline] 2008-05-21 14:51:30 EDT
okay gconf is fixed and totem is built now.
Comment 13 Bastien Nocera 2008-05-22 04:30:40 EDT
Thanks Ray!

Note You need to log in before you can comment on or make changes to this bug.