Bug 446726 - Monitor driven at unusable settings by Matrox G450
Monitor driven at unusable settings by Matrox G450
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Desktop, Regression
: 472773 479601 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 15:20 EDT by Braden McDaniel
Modified: 2010-02-27 20:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-27 20:16:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (716 bytes, text/plain)
2008-06-01 03:09 EDT, Braden McDaniel
no flags Details
Log from session with the monitor connected directly to the DVI port (35.25 KB, text/plain)
2008-06-01 03:11 EDT, Braden McDaniel
no flags Details

  None (edit)
Description Braden McDaniel 2008-05-15 15:20:12 EDT
Description of problem:
When starting X or running system-config-display, I get a black screen with a message from my 
monitor stating that an attempt is being made to run it at an unusable refresh rate.

The video card is a Matrox G450 low-profile. This card has a DVI connector on the bracket and 
includes a special adapter cable that splits the DVI connection into two VGA connectors. The monitor, 
an NEC 2470WNX, is attached to one of the VGA connectors.

Version-Release number of selected component (if applicable):
1.0.51-9.fc9
Comment 1 Braden McDaniel 2008-05-15 15:20:47 EDT
I've tried moving xorg.conf out of the way; that didn't change anything.
Comment 2 Braden McDaniel 2008-05-16 09:22:43 EDT
If I run system-config-display with "--set-vsync=60 --forceui", I do
successfully get the UI. However, it seems system-config-display doesn't put
anything in xorg.conf to reflect the vsync=60 setting. As a result, X still
isn't usable when it runs.
Comment 3 Braden McDaniel 2008-05-17 17:00:12 EDT
If I plug the monitor directly into the DVI port, system-config-display will run successfully without any 
arguments. However, it comes up at 800x600 and reports the monitor as unknown; 800x600 and 
640x480 are the only available pixel dimensions.

In spite of this, X still tries to run the monitor at an unusable refresh rate and I get the same black screen 
with the error message from the monitor.
Comment 4 Matěj Cepl 2008-05-28 12:57:05 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Braden McDaniel 2008-06-01 03:09:49 EDT
Created attachment 307302 [details]
xorg.conf
Comment 6 Braden McDaniel 2008-06-01 03:11:20 EDT
Created attachment 307303 [details]
Log from session with the monitor connected directly to the DVI port
Comment 7 Braden McDaniel 2008-06-01 03:14:57 EDT
conf & log attached.

I have also observed similar behavior when connecting the card to an NEC 
MultiSync FP950, an analog CRT monitor.

Behavior when running with no xorg.conf is already described above.
Comment 8 Braden McDaniel 2008-06-02 17:25:48 EDT
mouse?

Pardon my naivete, but why do you think this has something to do with the mouse driver?
Comment 9 Braden McDaniel 2008-06-10 14:19:40 EDT
Setting component to xorg-x11-drv-mga; assuming setting to xorg-x11-drv-mouse
was an error.
Comment 10 Bug Zapper 2009-06-09 20:52:19 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Braden McDaniel 2009-06-17 11:28:39 EDT
Still a problem in Fedora 11.
Comment 12 Matěj Cepl 2009-11-05 13:19:40 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 13 Vedran Miletić 2009-11-28 04:09:47 EST
*** Bug 479601 has been marked as a duplicate of this bug. ***
Comment 14 Vedran Miletić 2009-11-28 04:15:40 EST
*** Bug 472773 has been marked as a duplicate of this bug. ***
Comment 15 Matěj Cepl 2010-02-26 07:20:27 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 16 Matěj Cepl 2010-02-26 07:29:35 EST
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Notice, that this is an automatically filed comment for all bugs with hanging NEEDINFO for longer time; it is possible by quirks of bugzilla, that some bugs are in this state even though you have attached the required information; please, make a comment to this bug ... that we should see correctly; I am sorry for the bothering you in such case.]
Comment 17 Braden McDaniel 2010-02-27 20:16:34 EST
This appears to have been fixed.

Note You need to log in before you can comment on or make changes to this bug.