Bug 479601 - Booting F10 Live CD, monitor shows "Out of Range" when starting X
Booting F10 Live CD, monitor shows "Out of Range" when starting X
Status: CLOSED DUPLICATE of bug 446726
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
10
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-11 18:13 EST by Chuck
Modified: 2009-11-28 04:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-28 04:09:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (31.19 KB, text/plain)
2009-01-11 18:14 EST, Chuck
no flags Details
Xorg.0.log from F8 system (43.58 KB, text/plain)
2009-01-12 08:29 EST, Chuck
no flags Details
xorg.conf.new (3.63 KB, application/octet-stream)
2009-02-06 18:48 EST, Chuck
no flags Details
xorg.conf.new (3.63 KB, text/plain)
2009-02-06 18:49 EST, Chuck
no flags Details
Xorg.0.log.new (31.24 KB, text/plain)
2009-02-06 18:50 EST, Chuck
no flags Details
xorg.conf.vesa (3.63 KB, text/plain)
2009-02-06 18:51 EST, Chuck
no flags Details
Xorg.0.log.vesa (35.29 KB, text/plain)
2009-02-06 18:51 EST, Chuck
no flags Details

  None (edit)
Description Chuck 2009-01-11 18:13:28 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.19) Gecko/20081216 Fedora/2.0.0.19-1.fc8 Firefox/2.0.0.19

Preparing to upgrade my F8 system to F10. Downloaded and created Live CD. CD has been verified and also used successfully to build F10 system on other hardware with ATI video adapter.

When I boot CD on current system with Matrox Graphics, Inc. MGA G400/G450 (rev 85) things seem to go fine until X is started. At that time the monitor shows "Out of Range" box.

Pressing ESC during system load shows no obvious problems except:
1. When stating udev the monitor will go completely blank for a short time. It will come back with the OK but previous text is gone.
2. Last text on monitor before problem is starting CUPS with OK.

Reproducible: Always

Steps to Reproduce:
1. Boot F10 Live CD

Actual Results:  
Monitor shows "Out of Range" box. Still activity on CD. If left running monitor will occasionally go to blank and then "Out of Range" box reappears after a couple of seconds. Ctrl-Alt-Backspace will not always interrupt X server.

Expected Results:  
Expected results would be to continue to show desktop.

Have located other similar bugs listed here or Fedora Forum that mentioned Matrox video adapters but not under F10. Most were unresolved but did try any suggestions without success.

I did boot with "linux 3" to bring up system and logged in as root. System seems to be fine until I run startx. 

Since no /etc/X11/xorg.conf exists I built one from the file as it exists on current F8 system. Same results except I was able to break in easier with Ctrl-Alt-Backspace.
Comment 1 Chuck 2009-01-11 18:14:50 EST
Created attachment 328684 [details]
Xorg.0.log
Comment 2 Chuck 2009-01-12 08:29:32 EST
Created attachment 328731 [details]
Xorg.0.log from F8 system

For comparison, Xorg.0.log from current F8 system
Comment 3 Chuck 2009-02-06 17:49:45 EST
Maybe I made the priority on this too low, since nothing seems to be happening. Please upgrade to High Priority.

Is this problem similar to Bug 477102 before they switched out the Matrox video card?

Can you verify that F10 will operate correctly with the Matrox video card if build from standard distribution?
Comment 4 Chuck 2009-02-06 18:48:26 EST
Created attachment 331172 [details]
xorg.conf.new
Comment 5 Chuck 2009-02-06 18:49:53 EST
Created attachment 331173 [details]
xorg.conf.new
Comment 6 Chuck 2009-02-06 18:50:46 EST
Created attachment 331174 [details]
Xorg.0.log.new
Comment 7 Chuck 2009-02-06 18:51:15 EST
Created attachment 331175 [details]
xorg.conf.vesa
Comment 8 Chuck 2009-02-06 18:51:47 EST
Created attachment 331176 [details]
Xorg.0.log.vesa
Comment 9 Chuck 2009-02-06 19:00:58 EST
Tried some variations with no success:

A) Build new xorg.conf
  1) Booted F10 Live CD to level 3 (text mode
  2) Ran "X -configure" to build xorg.conf.new
  3) Start X with "X -config /root/xorg.conf.new"
  4) Same problem, monitor shows "out of range"
  5) Stopped X with CTRL-ALT-BACKSPACE
  6) Saved xorg.conf.new and Xorg.0.log.new (Attached)

B) Use VESA driver
  1) Edit xorg.conf.new to xorg.conf.vesa to load vesa driver in place of mga driver
  2) Start X with "X -config /root/x.org.conf.vesa"
  3) Monitor went to full gray screen
  4) Stopped X with CTRL-ALT-BACKSPACE
Comment 10 Chuck 2009-02-06 19:04:34 EST
Last comment ended premature. Append the following:

B) Use VESA driver
  1) Edit xorg.conf.new to xorg.conf.vesa to load vesa driver in place of mga
driver
  2) Start X with "X -config /root/x.org.conf.vesa"
  3) Monitor went to full gray screen
  4) Stopped X with CTRL-ALT-BACKSPACE
  5) Saved xorg.conf.vesa and Xorg.0.log.new (Attached)

Suggestions?
Comment 11 Bug Zapper 2009-11-18 04:27:41 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Vedran Miletić 2009-11-28 04:09:47 EST

*** This bug has been marked as a duplicate of bug 446726 ***

Note You need to log in before you can comment on or make changes to this bug.