Bug 446737 - Zim segfaults after initial notebook creation
Zim segfaults after initial notebook creation
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
9
noarch Linux
low Severity low
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
:
: 451028 451445 (view as bug list)
Depends On: 445962
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-15 15:50 EDT by Brian Johnson
Modified: 2008-09-11 12:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 12:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Johnson 2008-05-15 15:50:17 EDT
Description of problem: Installed and ran Zim. Created new notebook and started
it up. Quit it, and tried to restart, get 'Segmentation fault'.


Version-Release number of selected component (if applicable): Zim-0.23-2.fc9.noarch


How reproducible: Seems to be everytime


Steps to Reproduce:
1. Install, run 'zim'. Create new Notebook.
2. Bring up text editor. Add something (or not), quit.
3. run 'zim' again.
  
Actual results:
[scorponok]</home/mbjohn>% zim
Segmentation fault

Expected results: Text editor should come up and let me type cool things :)


Additional info: It fails on both my desktop and laptop, both running F9. 'rm
-rf ~/.config/zim' fixes the problem on both machines (well, it runs zim and
allows you to recreate a new notebook, but segfaults after quitting again)
Comment 1 Frederic Descamps 2008-05-16 03:03:01 EDT
Additional Info :

Removing the notebooks.list and restarting Zim works until the next quit and start. 

$ lsb_release -a
LSB Version:	:core-3.1-amd64:core-3.1-noarch:graphics-3.1-amd64:graphics-3.1-noarch
Distributor ID:	Fedora
Description:	Fedora release 9 (Sulphur)
Release:	9
Codename:	Sulphur
Comment 2 Chris Weyl 2008-05-22 11:50:54 EDT
I'm going to build and push Zim 0.25 as soon as bug 445962 is resolved;
hopefully it will address this issue...
Comment 3 Paul Bredbury 2008-06-05 10:12:12 EDT
I experienced this bug, which is fixed in Zim 0.25 - grab it from:

ftp://brebs.me.uk/fedora/9/

With the Zim 0.23 currently in Fedora, Zim is basically unusable for new users
it seems :(
Comment 4 Jean-François Martin 2008-06-12 04:08:57 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=445962 has been fixed now.
Can you build a package for Zim 0.25, please?
Comment 5 Chris Weyl 2008-08-07 02:17:36 EDT
*** Bug 451028 has been marked as a duplicate of this bug. ***
Comment 6 Chris Weyl 2008-08-07 02:19:06 EDT
*** Bug 451445 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-08-07 02:20:53 EDT
Zim-0.25-2.fc9 has been submitted as an update for Fedora 9
Comment 8 Chris Weyl 2008-08-07 02:23:57 EDT
Ok, so.

I just submitted an update to 0.25, latest upstream.  I'd been holding off as one test fails, but upstream assures me that this is "OK in normal use", and indeed, 0.25 works for me.

Nonetheless, please test and report issues :)  Update instructions should be appearing here magically, as soon as the updates system actually executes the push.
Comment 9 Fedora Update System 2008-08-12 14:27:07 EDT
Zim-0.25-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Zim'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7232
Comment 10 Fedora Update System 2008-09-11 12:58:59 EDT
Zim-0.25-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.