This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 446846 - No way to preupgrade a headless system!
No way to preupgrade a headless system!
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 459330 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 09:14 EDT by Rick Richardson
Modified: 2008-11-26 01:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 01:12:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rick Richardson 2008-05-16 09:14:54 EDT
No way to preupgrade a headless system!.

System reboots and still asks you questions on the main screen!  But the main
screen doesn't exist because it is headless!
Comment 1 Will Woods 2008-05-16 10:40:07 EDT
Add 'vnc' commands to the boot commandline. See
http://fedoraproject.org/wiki/Anaconda/Options#vnc for details.

This is on the roadmap for preupgrade 1.1:
https://fedorahosted.org/preupgrade/ticket/21
Comment 2 Will Woods 2008-10-21 16:44:48 EDT
*** Bug 459330 has been marked as a duplicate of this bug. ***
Comment 3 Răzvan Sandu 2008-10-24 09:57:22 EDT
Hello,

No, no, no ! ;-)
Using VNC is not a solution in all cases: please don't assume that the machine from which we are connecting:

- is a Linux machine;
- has VNC installed;
- has VNC connections allowed through firewall;
- runs X.

What we really need is a way to complete the upgrade via ssh, command-line mode:
please see my original bug #459330.


Regards,
Răzvan
Comment 4 Will Woods 2008-10-24 10:48:57 EDT
1) There are VNC clients available for pretty much every OS there is. And they don't require X. So that objection is nonsensical.

2) We make every possible effort to ensure that the upgrade runs automatically. Under *most* circumstances, the upgrade should be able to complete without needing the VNC connection at all, as you request in bug 459330. 

But this *cannot* be *guaranteed*. If something goes wrong, you *will* need some way to connect to the machine to fix it, and VNC is the *only* available option in this case.

In short: VNC is not *required* to complete a remote/headless upgrade, but it *is* the only way to check progress or fix errors.
Comment 5 Will Woods 2008-10-24 10:51:11 EDT
*** Bug 459330 has been marked as a duplicate of this bug. ***
Comment 6 Răzvan Sandu 2008-10-31 15:17:28 EDT
Hello again,

Thanks *a lot* for your work, which I *truly* appreciate !

However, I think I don't understand all technical aspects:

To run preupgrade *locally* , I will enter in a terminal (opened inside an X session) and type "preupgrade". Then a *graphical* utility fires up, download packages and prepares the system for the upgrade. That allows me to use the system as as workstation while packages are downloaded.

Then comes the reboot and the *graphical* process continues until the upgrade is completed (sometimes requiring re-dowloading of corrupted packages, etc., so I will need both fully functional network access *and* acces to system's *graphical* console).


Now please suppose we are trying to acquire the same functionality from a geographically distant location, via ssh (say putty, installed on a Windows box). Worse, the Linux machine we are trying to upgrade is to small to run X and/or a VNC server - it runs in default runlevel 3 and stays there.

Is there any posibility to perform the upgrade using command-line tools *only* ?

(To be honest, I've upgraded a few machines via ssh by simply:

- installing the next version's fedora-release RPM package manually
- run yum upgrade

but I suspect this is not a clean way of doing things, since packages in different releases do not overlap exactly. Anaconda woud do better...).

Thanks again,
Răzvan
Comment 7 Will Woods 2008-11-09 19:33:56 EST
Yes, you can run preupgrade remotely and with command-line tools only:

1) ssh in
2) install 'preupgrade' (0.9.9 or later)
3) run preupgrade-cli --vnc=[password]
4) reboot remote machine
5) (optional) connect a VNC client to the remote machine (port 5901)
6) wait for system to finish and reboot

And that's it. The VNC server only runs while the upgrade is in progress; it allows you to remotely monitor the progress of the upgrade. Under normal circumstances the upgrade should complete without requiring you to connect to the VNC server at all.
Comment 8 Fedora Update System 2008-11-11 21:58:36 EST
preupgrade-0.9.9-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8576
Comment 9 Fedora Update System 2008-11-11 21:59:52 EST
preupgrade-0.9.9-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8545
Comment 10 Răzvan Sandu 2008-11-19 04:06:01 EST
Hello,


Regarding comment #7 :

Thank you for your recipe-like response, which is much needed in a *visible* place in the documentation !

Still one more question for clarification:

On a *stock* Fedora machine (with unmodified configuration), the VNC system works out of the box ? Are there any adaptations necessary, such as VNC server manual (pre)configuration, setting VNC passwords or opening ports on the *local* default firewall  (system-config-firewall) ?

If yes, how can we syncronize these packages and document all process, to make things as automatic as possible for non-technical users or low-level maintenance personnel ?


Regards,
Răzvan
Comment 11 Fedora Update System 2008-11-21 18:49:14 EST
preupgrade-1.0.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.0.0-1.fc10
Comment 12 Fedora Update System 2008-11-26 01:12:28 EST
preupgrade-1.0.0-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-11-26 01:13:43 EST
preupgrade-1.0.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-11-26 01:22:12 EST
preupgrade-1.0.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.