Bug 459330 - No way of completing upgrade via preupgrade remotely (via ssh)
No way of completing upgrade via preupgrade remotely (via ssh)
Status: CLOSED DUPLICATE of bug 446846
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-16 12:09 EDT by Răzvan Sandu
Modified: 2008-10-24 10:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 10:51:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-08-16 12:09:13 EDT
Description of problem:

This was originally reoprted as bug #444979 and splitted:

Preupgrade should consider the case in which the upgrade is done *remotely*,
via ssh (really, this is the *main* reason for which one attempts to upgrade a
system via yum and not via bootable media).

So preupgrade will need a way to complete the upgrade *without human
intervention after reboot*. The scenario is:

- the administrator logs remotely, as root, to the (functional) system to be
upgraded via "ssh -X system.example.com"
- the administrator invokes preupgrade
- the system reboots
- the upgrade should be completed without user intervention


  
Actual results:
There is no way to perform upgrades via preupgrade *remotely*, via ssh, without local user intervention (console).

Expected results:
Preupgrade should provide a way to complete upgrades remotely (via ssh only).
Comment 1 Will Woods 2008-10-21 16:44:48 EDT

*** This bug has been marked as a duplicate of bug 446846 ***
Comment 2 Will Woods 2008-10-24 10:51:11 EDT

*** This bug has been marked as a duplicate of bug 446846 ***

Note You need to log in before you can comment on or make changes to this bug.