Bug 446911 - Unable to locate stropts.h
Unable to locate stropts.h
Status: CLOSED DUPLICATE of bug 439403
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 12:28 EDT by Bryan Christ
Modified: 2008-05-20 21:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 05:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Christ 2008-05-16 12:28:06 EDT
I hate to file a BZ on this, but I cannot find stropts.h.  I have read in
several places that it was removed from F9, but I cannot find any information
about where the module macros (like I_PUSH, I_POP, etc..) were moved to.
Comment 1 Jakub Jelinek 2008-05-19 05:14:02 EDT
Why do you need the I_PUSH/I_POP macros when Linux kernel doesn't support them?

*** This bug has been marked as a duplicate of 439403 ***
Comment 2 Bryan Christ 2008-05-19 10:44:03 EDT
If the kernel doesn't support them, then I have my answer.  I am curious as to
why they are not since the man pages are written in such a way that these macros
appear to be mandated by the IEEE and Open Group.  Also, I_PUSH is used in the
GNU primer for initiating ptys.  See the example here:

http://www.gnu.org/software/libc/manual/html_node/Allocation.html#Allocation

Note You need to log in before you can comment on or make changes to this bug.