Bug 439403 - /usr/include/stropts.h missing from rawide
/usr/include/stropts.h missing from rawide
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
: 439802 444676 446911 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 11:37 EDT by John Ellson
Modified: 2016-11-24 07:31 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 11:52:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2008-03-28 11:37:07 EDT
Description of problem:
/usr/include/stropts.h missing from rawhide, but present in fc8

Version-Release number of selected component (if applicable):
glibc-headers-2.7.90-12.x86_64

How reproducible:
100%

Steps to Reproduce:
1. attempt to build graphviz, which uses it.
2.
3.
  
Actual results:
build fails due to missing stropts.h

Expected results:


Additional info:
Comment 1 Jakub Jelinek 2008-03-28 11:52:32 EDT
That's on purpose.  Linux doesn't support STREAMS (many years ago it was
available as a third party module, but it hasn't worked for years).
stropts.h is part of a POSIX XSR option, which Linux now, matching reality, says
it is not supported.
No idea why graphviz needs it (when all the syscalls are stubbed), but it needs
fixing (either by adding configure checks, or by using the POSIX recommended
check - #include <unistd.h>, 
#if defined _XOPEN_STREAMS && _XOPEN_STREAMS == -1
/* XSR option is not available, headers, data types etc. may not be available.  */
#endif
see http://www.opengroup.org/onlinepubs/009695399/basedefs/unistd.h.html
for more details).
Comment 2 Jakub Jelinek 2008-03-31 13:32:15 EDT
*** Bug 439802 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Jelinek 2008-04-29 18:17:21 EDT
*** Bug 444676 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2008-05-19 05:14:03 EDT
*** Bug 446911 has been marked as a duplicate of this bug. ***
Comment 5 Frode Tennebø 2008-06-20 05:53:32 EDT
I'm "reopening" this one the basis that the ioctl(p) provides a whole host of 
requests/args which, I take it, does not work?

Shouldn't there be *some* indication that this actually doesn't work other than 
just a gaping hole?  The man-page is still there....

Also, it's my understanding that some of these requests also applies to pipes/
fifos.  I could very well be plain wrong.....

Sorry about the rant; I was in the middle of a rather tireing debug-job of a 
port from solaris when I discovered I had to redo the STREAMS stuff....:/

Note You need to log in before you can comment on or make changes to this bug.