Bug 446964 - Deactivating automatic update checks nonfunctional.
Deactivating automatic update checks nonfunctional.
Status: CLOSED DUPLICATE of bug 441127
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 15:23 EDT by August Schwerdfeger
Modified: 2008-06-03 09:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 09:38:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description August Schwerdfeger 2008-05-16 15:23:58 EDT
Description of problem:

The option in the "Software Update Preferences" dialog NEVER to check for
updates is ignored by the update daemon, which checks for them quite often when
this option is set.

Version-Release number of selected component (if applicable):

gnome-packagekit-0.1.12-12.20080430.fc9.i386

How reproducible:

Set the option "Check for Updates" in the "Software Update Preferences" dialog
to NEVER; observe the behavior of the update daemon.
  
Expected results:

I interpret the NEVER option as meaning that I must check for updates manually
if I want them, thus avoiding lengthy update checks over sluggish wireless
connections.

Actual results:

The update daemon appears to interpret NEVER as meaning EVERY TIME A NETWORK
CONNECTION GOES LIVE.
Comment 1 Richard Kennedy 2008-05-21 08:34:09 EDT
I'm seeing this problem too.
I would like to disable packagekit completely on my laptop & only do manual updates.

also there seems be no way to remove the packagekit applets from the menu bar :(

I tried to uninstall packagekit but that removes print-config as well.

yumex does a much better job for me

Richard
Comment 2 Richard Hughes 2008-05-28 05:33:22 EDT
So if you set the option to "never" and then restart your computer, is an update
scheduled? I can;t reproduce here. Thanks.
Comment 3 August Schwerdfeger 2008-05-28 11:12:52 EDT
I have had the option set to NEVER since installing Fedora 9 some weeks ago,
restarting the computer a great number of times in the intervening period.

I take this computer between several wireless networks and one wired network;
update checks are made when I establish a connection with a network.

I originally installed from the Live-CD for the preview release, if that is a
relevant factor.
Comment 4 Richard Hughes 2008-06-03 09:38:58 EDT

*** This bug has been marked as a duplicate of 441127 ***

Note You need to log in before you can comment on or make changes to this bug.