Bug 441127 - PackageKit ignores user preferences
PackageKit ignores user preferences
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: Reopened
: 442998 446964 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 11:36 EDT by Stewart Adam
Modified: 2008-10-27 09:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 09:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Outout of gpk-update-icon --verbose (42.02 KB, text/plain)
2008-04-07 21:13 EDT, Stewart Adam
no flags Details
Verbose log of when PK refreshed + notified of updates (42.24 KB, text/plain)
2008-04-10 00:03 EDT, Stewart Adam
no flags Details
gpk refresh status (19.38 KB, image/png)
2008-05-07 18:51 EDT, Stewart Adam
no flags Details

  None (edit)
Description Stewart Adam 2008-04-06 11:36:59 EDT
Description of problem:
Even when I've opened the "Software Updates" preferences and disable all
notifications and set "Check for Updates" to "Never", the applet attempts to
refresh metadata and notify me of updates. In cases where mirrors aren't synced
up yet, this can easily use up 50MB in bad checksum downloads which is very bad
for people with bandwidth caps.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.11-1.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open "Software Updates" preferences and disable all notifications, as well as
setting "Check for Updates" to "Never"
2. Login with the PackageKit applet installed
3. The icon still appears and refreshes metadata

Actual results:
The applet appears in the panel and attempts to refresh metadata (will notify of
updates if available as well)

Expected results:
Once "Check for Updates" is set to never I don't want it to be refreshing
metadata all the time and once I've disabled all notifications it shouldn't be
notifying me of updates either.
Comment 1 Richard Hughes 2008-04-07 05:19:57 EDT
Hmm, this is a bug. Could you do:

gpk-update-icon --verbose > log.txt

and wait until you get the network access of a CacheRefresh or check-update.
Then, please attach log.txt to this bug please. Thanks.
Comment 2 Stewart Adam 2008-04-07 21:13:30 EDT
Created attachment 301587 [details]
Outout of gpk-update-icon --verbose

I'll get back to you with the refresh log as soon as I can... As usual, the
second you try to catch a bug it starts working normally ;)

It's not refreshing now, but rather using the week-old cached data (which is
what I would expect). However, it is still notifying me of potential updates
when I requested it not to do so - I've attached the log for that run.
Comment 3 Stewart Adam 2008-04-10 00:03:07 EDT
Created attachment 301922 [details]
Verbose log of when PK refreshed + notified of updates

OK, it just refreshed on me - Here's the log.
Comment 4 Matthias Clasen 2008-04-11 17:47:55 EDT
The 'never' setting doesn't work in the current package.
I've committed a fix to git that will appear in the next stable update.
Comment 5 George Billios 2008-04-12 10:13:40 EDT
Any idea when the next stable version is coming because it's very irritating
especially since it consumes lots of cpu time while getting the updates.

Thanks
Comment 6 Stewart Adam 2008-04-12 12:01:39 EDT
(In reply to comment #4)
> The 'never' setting doesn't work in the current package.
> I've committed a fix to git that will appear in the next stable update.
Thanks, sounds good. Does this also fix the notification bug (it displayed
notifications when that checkbox was unticked in the preferences) or that's
something else?
Comment 7 Richard Hughes 2008-04-12 12:17:34 EDT
I built a new package this morning.
Comment 8 Stewart Adam 2008-04-19 12:36:23 EDT
I haven't seen it refresh, but it still notifies me about updates when I've told
it not to with these versions:
  PackageKit-libs-0.1.12-4.20080416git.fc9.x86_64
  yum-packagekit-0.1.12-4.20080416git.fc9.x86_64
  gnome-packagekit-0.1.12-5.20080416git.fc9.x86_64
  PackageKit-0.1.12-4.20080416git.fc9.x86_64
Comment 9 Robin Norwood 2008-04-25 12:38:56 EDT
*** Bug 442998 has been marked as a duplicate of this bug. ***
Comment 10 Stewart Adam 2008-04-29 20:32:54 EDT
Fix still unconfirmed, the gpk update icon comes up every time I login.
Comment 11 Robin Norwood 2008-04-30 11:19:40 EDT
Stewart,

Are you seeing just the icon, or are you seeing an actual message saying
'updates are available'?  Just the icon being there is by design - the 'Display
Notification' configuration is to turn on or off notifications like this:

http://www.packagekit.org/img/gpk-updates-warning.png

If it is the icon that bugs you - I don't think we have an option to disable
that in the GUI...I'll start a conversation with upstream about it.  I would
suspect that if the 'check for updates' box is set to 'never', we should
probably never show the icon.
Comment 12 Robin Norwood 2008-04-30 11:24:18 EDT
And, would you want the option to just disable the software update service
completely (never show the icon, never update the system unless the user runs
the updater from the menus), or do you want the update service to completely
silently update the system (no icon, no notification, but still do updates)?
Comment 13 Jonathan Kamens 2008-04-30 11:31:59 EDT
Yes, the desire is to make the icon go away.
No, the desire is NOT to have the update service install updates completely 
silently.  The point is to make it not update the system and not display the 
icon.
I use "sudo yum update --skip-broken" to update my system.  I want to be able 
to completely disable the PackageKit GUI front-end as well as any work it might 
do in the background hosing my system needlessly.
Comment 14 Matthias Clasen 2008-04-30 14:08:25 EDT
That is very simple: 

rm /etc/xdg/autostart/gpk-update-icon.desktop
Comment 15 Jonathan Kamens 2008-04-30 15:26:58 EDT
Surely you don't really believe that's an adequate solution?
Comment 16 Matthias Clasen 2008-04-30 15:42:54 EDT
if you never want to see the icon and don't want PK to do anything in the
background, then yes, simply not running the icon is a very adaequate solution.
Comment 17 Jonathan Kamens 2008-04-30 15:47:32 EDT
I strongly disagree.  This is a GUI we're talking about.  GUIs are supposed to 
be configurable through GUIs.  I shouldn't have to do something as root from 
the command line to tell a GUI that I don't want it to do anything.
Comment 18 Robin Norwood 2008-04-30 16:09:30 EDT
mclasen's suggestion in comment #14 is a perfectly reasonable workaround for
now.  I agree with Jonathan that we probably need a way to have the icon not
show up (unless the user manually uses part of PK), especially because
system-config-printer depends on PK, making it hard to remove.  But since
there's an easy workaround, and the class of user who doesn't want it there at
all is assumed (by me) to be fairly small, I don't think it's an F9 blocker.

So I'm removing this bug from the F9 blocker list, but leaving it open.
Comment 19 Robin Norwood 2008-04-30 16:11:35 EDT
(by 'a way to have the icon not show up', I mean from the GUI)
Comment 20 Matthias Clasen 2008-04-30 16:18:33 EDT
If you want to click it away, go to  System > Preferences > Personal > Sessions,
Startup Programs tab, uncheck "PackageKit Update Applet"
Comment 21 Jonathan Kamens 2008-04-30 16:21:51 EDT
Did that.  Over and over again.  Doesn't work.
Comment 22 Stewart Adam 2008-04-30 17:07:40 EDT
(In reply to comment #11)
> If it is the icon that bugs you - I don't think we have an option to disable
> that in the GUI...I'll start a conversation with upstream about it.  I would
> suspect that if the 'check for updates' box is set to 'never', we should
> probably never show the icon.
Ah, my bad - It no longer gives me a notification, but the icon does come up. 

Easiest solution would probably be to add a gtk.CheckButton for "Show tray
icon", and set the sensitivity of the "Display Notifications" frame accordingly.

(In reply to comment #12)
> And, would you want the option to just disable the software update service
> completely (never show the icon, never update the system unless the user runs
> the updater from the menus), or do you want the update service to completely
> silently update the system (no icon, no notification, but still do updates)?
Personally, I prefer using Smart PM for package management which is why I don't
want any notification at all - The service doesn't even have to run, but if it
does then I'd prefer it doesn't use bandwidth for things I've already
downloaded/refreshed in Smart PM. However, I'm sure some users will want the
daemon to run silently, so that's why I suggest the tray icon being optional.

(In reply to comment #14)
> That is very simple: 
> 
> rm /etc/xdg/autostart/gpk-update-icon.desktop
Why design a simple, easy to use program graphical and then asking users to use
the command line? It is easy, and a bit of research will show them how to remove
startup programs but I don't think any of that should be needed just to hide a
tray icon. (Sorry if I misunderstood and you meant that only as a temporary
workaround)

(In reply to comment #21)
> Did that.  Over and over again.  Doesn't work.
I tried that too - every update re-enables it.
Comment 23 Matthias Clasen 2008-04-30 17:37:15 EDT
> Did that.  Over and over again.  Doesn't work.

Ah, I think I see what is going on. gpk-update-icon 'plays it safe' by not only
installing an autostart file, but also registering with the session manager.
Thats broken.

So, in addition to disbling it on the Startup Programs, you also have to go to the
"Current Session" tab, select gpk-update-icon, click "Remove" and "Apply", then
go to the last tab, and click on "Remember...". Pretty unelegant...
Comment 24 Jonathan Kamens 2008-04-30 17:41:47 EDT
Did that too.  Didn't work.
Comment 25 Matthias Clasen 2008-04-30 20:51:51 EDT
I just tried it, worked for me.
Comment 26 Matthias Clasen 2008-05-02 21:47:38 EDT
I don't think this should be on the blocker list, really.
Comment 27 Stewart Adam 2008-05-04 23:29:06 EDT
It just refreshed on me with the following packages installed:
  PackageKit-0.1.12-9.20080502.fc9.x86_64
  PackageKit-libs-0.1.12-9.20080502.fc9.x86_64
  gnome-packagekit-0.1.12-12.20080430.fc9.x86_64
Comment 28 Darwin H. Webb 2008-05-05 21:38:19 EDT
PackageKit-0.1.12-10.20080505.fc9.i386.rpm
PackageKit-cron-0.1.12-10.20080505.fc9.i386.rpm
PackageKit-libs-0.1.12-10.20080505.fc9.i386.rpm
yum-packagekit-0.1.12-10.20080505.fc9.i386.rpm

Still starts up and never stops.
I have to kill 3 tasks to stop it.
It always runs at boot time but that stops and the icon goes away. It is later
that it starts up and rolls through the mirrors.
Darwin
Comment 29 Matthias Clasen 2008-05-05 21:58:17 EDT
I believe there is considerable confusion in this bug report by now. 
If you set "Check for updates" to "never", gpk-update-icon is still running in
the session, but it is never checking for updates, not at bootup, not at login,
not later. I just tried this again, and it works.
Comment 30 Darwin H. Webb 2008-05-06 15:27:18 EDT
There is several bugs and threads about it so yes it is confusing because there
is multiple conditions occurring. 
Never booting up would work also. :)

####
ok, .11 worked for bootup when updates exit.
There is a show and apply property on the icon after the getting is over and it
tuns red-dish.

Show updates opens a medium sized window with a preview updates button.
The preview shows the updates and info.
click apply button.

A small window opens with activity heading - resolving, downloading, updating,
cleanup.
There are 2 buttons, close and a grayed out cancel updates.

After resolving the downloading starts and the cancel updates button becomes active.
When updating starts, the cancel updates button goes gray.

Updates completed, close

reboot again

Icon starts up with property - getting info, then ends normally, disappears.

So when the yum-cron runs what will happen?
The simple check on and end or the run away sqlltbz downloads?
If the run away, can it be stopped by the gui?

I'm guessing NOT. And this is what thousands will get the day after firstboot.

Darwin
Comment 31 Richard Hughes 2008-05-06 17:07:47 EDT
>yum-cron runs what will happen?

The same thing as normal - PackageKit only locks yum when it needs to do an action.

>If the run away, can it be stopped by the gui?

Well, no. If you use PackageKit-cron then it works with PackageKit (so you can
cancel it using the GUI) and you don't get a nasty interaction.

Why would yum-cron be running after firstboot anyway?
Comment 32 Stewart Adam 2008-05-06 17:16:39 EDT
I think he meant after firstboot when the login.
Comment 33 Stewart Adam 2008-05-07 18:51:07 EDT
Created attachment 304814 [details]
gpk refresh status

I'll post a debug log as soon as I can catch it, as far as I can tell it
happens at random but here's a screenie that says it refreshed not days/weeks
ago but a few hours ago.
Comment 34 Bug Zapper 2008-05-14 04:58:39 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 35 Stewart Adam 2008-05-28 17:06:19 EDT
TI:16:36:39	TH:0x11c35a0	FI:gpk-auto-refresh.c	FN:gpk_auto_refresh_idle_cb,313
 - setting is_idle 0
TI:16:36:39	TH:0x11c35a0	FI:gpk-auto-refresh.c
FN:gpk_auto_refresh_maybe_refresh_cache,207
 - not when session active
TI:16:36:39	TH:0x11c35a0	FI:gpk-auto-refresh.c
FN:gpk_auto_refresh_maybe_get_updates,250
 - not when policy is to never refresh

It seems to be following the preferences... Would opening the "Show Updates"
dialog cause it to refresh? Or yum-refreshpackagekit? I've been using Yum and
opening the Show Updates dialog but I haven't specifically told PK to refresh.
Comment 36 Stewart Adam 2008-05-29 17:35:10 EDT
Okay, I just caught it but no long unfortunately. I had rebooted and didn't
login for a few hours, and about a minute after I logged in it started to
refresh. Is there a way to make it log when it autostarts with the session?
Comment 37 Richard Hughes 2008-06-03 09:38:59 EDT
*** Bug 446964 has been marked as a duplicate of this bug. ***
Comment 38 Richard Hughes 2008-06-03 10:49:59 EDT
>Would opening the "Show Updates" dialog cause it to refresh?

Yes.
Comment 39 udo 2008-06-29 07:41:33 EDT
Just experienced the same issue on my F9 box. Out of nowhere PK appears although
set to never check.
Comment 40 Jonathan Kamens 2008-08-17 05:26:56 EDT
It seems like this problem went away for a while (or perhaps I was imagining it) but then came back with current rawhide.

On the other hand, since gpk-update-icon is crashing (there's another open bug about that), at least it doesn't hang out in the system tray annoying me for very long :-).
Comment 41 Richard Hughes 2008-10-27 09:23:03 EDT
Okay, there's a proper upstream fix for this in rawhide. I'll look into building F9 rpms now.

Note You need to log in before you can comment on or make changes to this bug.