Bug 447004 - There is no NetworkManagerDispatcher service present
There is no NetworkManagerDispatcher service present
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 18:26 EDT by Răzvan Sandu
Modified: 2008-05-27 10:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-26 17:07:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-05-16 18:26:51 EDT
Description of problem:

Despite these instructions (which I've reached from F9 release notes),

http://fedoraproject.org/wiki/Tools/NetworkManager

there is no NetworkManagerDispatcher service present (it once was, in F8).


Is this a bug or it was eliminated ?


Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.3.svn3623.fc9.i386
NetworkManager-0.7.0-0.9.3.svn3623.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install fresh Fedora 9, including NetworkManager
2. Start ntsysv or use chkconfig to see available daemons

  
Actual results:
There is no NetworkManagerDispatcher.

Expected results:
It is unclear if NetworkManagerDispatcher is no longer included/necessary in the
RPM package or this is a bug. If it was eliminated, please update documentation
accordingly.
Comment 1 Dan Williams 2008-05-16 18:41:41 EDT
It's been replaced by a dbus-activated callout that is run on-demand rather than
always-on consuming memory.  /usr/libexec/nm-dispatcher.action.  But it runs the
same scripts in the same way and you shouldn't notice any difference.

Is it not working the way you expect?
Comment 2 Răzvan Sandu 2008-05-16 19:02:48 EDT
Hello,


I've opened this bug only for the NetworkManagerDispatcher absence. If it was
replaced, it's OK - please only update this webpage accordingly:

http://fedoraproject.org/wiki/Tools/NetworkManager


On the other hand, unfortunately, NetworkManager only works as expected in
*some* cases. Please see bug #447383, comment 7 and the issues in bug # 134886,
which occurs frequently.

For the moment I only use NetworkManager on non-critical workstations, where I
can afford to test. It still can't be used on servers/critical machines.



Thanks *a lot*,
Răzvan
Comment 3 Răzvan Sandu 2008-05-16 19:04:36 EDT
Sorry, I've meant bug #445383, comment 7 and bug #134886 above.

Răzvan
Comment 4 Răzvan Sandu 2008-05-21 11:17:19 EDT
After the last upgrade (NetworkManager-0.7.0-0.9.3.svn3669.fc9.i386), it works
for me, except this: 

- on a laptop, I was unable to fix the "keyring password" issue
for the wireless connection, despite the fact I've followed exactly the
instructions given at
http://fedoraproject.org/wiki/Tools/NetworkManager?action=show&redirect=NetworkManager


Regards,
Răzvan
Comment 5 Răzvan Sandu 2008-05-26 17:07:37 EDT
Closing this as NOTABUG, since you've explained that NetworkManagerDispatcher
was replaced by another mechanism.

Please update this docs accordingly
http://fedoraproject.org/wiki/Tools/NetworkManager

Thanks a lot,
Răzvan
Comment 6 Dan Williams 2008-05-27 10:51:26 EDT
Thanks, references to the dispatcher have been removed from the wiki page.

Note You need to log in before you can comment on or make changes to this bug.