Bug 447091 - F8 screensavers disappeared
F8 screensavers disappeared
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdeartwork (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 16:16 EDT by Landon Kelsey
Modified: 2008-05-17 22:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 22:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot of yumex window (97.00 KB, image/jpeg)
2008-05-17 16:51 EDT, Landon Kelsey
no flags Details

  None (edit)
Description Landon Kelsey 2008-05-17 16:16:57 EDT
Description of problem:

under Fedora 8 there were a host of screensavers like sonar and molecule!

Just after my update F8->f9 (and before massive yum update 528 meg), there was a
path to those screensavers that generated an error. 

Then came massive yum update 528 meg.

Now that path is gone and the screensavers are not to be found.

In the past these screensavers have appeared and disappeared with successive
Fedora versions!

I did try yumex to no avail!

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Kofler 2008-05-17 16:25:02 EDT
Do you have all the relevant packages installed? In particular:
* kdeartwork-kxs,
* all the xscreensaver* packages (the base xscreensaver only contains a 
selected set of screensavers, the -extras, -gl and -gl-extras subpackages have 
the others).
Comment 2 Kevin Kofler 2008-05-17 16:27:31 EDT
kdeartwork-extras too.
Comment 3 Landon Kelsey 2008-05-17 16:45:25 EDT
I opened yumex and installed everything but gnome stuff!

Actually the path (I mentioned) that did show sonar and molecule does exist but
since massive yum update after (F8->F9) only kasciiquarium and kbiof appear.

This path that doesn't work is under applications->system->screensavers.

There is another path to screensavers but it shows a hitherto unknown set of
screensavers

These missing screensavers worked great under F8!
Comment 4 Landon Kelsey 2008-05-17 16:51:41 EDT
Created attachment 305820 [details]
snapshot of yumex window

yumex on kdeartwork...all there...
Comment 5 Landon Kelsey 2008-05-17 17:00:27 EDT
actually kasciquarium works but it only produces a window with the "fish" in it

KDE should investigate the traffic jam when the panel is at the bottom

There are 2 panels???

on reappear, things get jitery so I am moving the main panel to the top where
there is no collision
Comment 6 Landon Kelsey 2008-05-17 17:32:39 EDT
good news! Somehow that world clock background has reappeared having disappeared
back in Redhat 9!

A similar problem...what happened to those super wonderful desktop background
options
Comment 7 Rex Dieter 2008-05-17 20:37:42 EDT
please, 1 issue per bug.  And please, bugzilla isn't a help forum, if you have
questions, this isn't the place for it.  mailing lists (fedora-general) or
fedoraforum.org would yield better and faster results.
Comment 8 Landon Kelsey 2008-05-17 21:14:35 EDT
not sure who needs the help!

The background and screensaver situation is a mess!

There are two ways to set the screensaver and background but one of the two ways
has no effect!
Comment 9 Rex Dieter 2008-05-17 21:24:29 EDT
What do any of those things you just mentioned have to do with the summary of
this bug?
Comment 10 Landon Kelsey 2008-05-17 21:36:21 EDT
to make Fedora 9 acceptable to users, the whole system of background and
screensaver configuration must be repaired! The whole KDE option system seems to
have suffered going into F9

Not just a minuscule bug!

goodnight!

Comment 11 Rex Dieter 2008-05-17 21:42:44 EDT
Fwiw, 
authoritative way to configure Screensaver:
systemsetting -> desktop -> screensaver

authoritive set desktop:
right click desktop -> configure desktop
Comment 12 Landon Kelsey 2008-05-17 22:33:50 EDT
what you have written has no relation whatsoever to F9
Comment 13 Kevin Kofler 2008-05-17 22:44:53 EDT
Looks like you're actually running GNOME, not KDE 4, both from the screenshot 
in bug 447114 and from the presence of Nodoka window decorations in the 
screenshot in comment #4 of this bug.

GNOME uses a different screensaver system called gnome-screensaver, try 
installing xscreensaver-extras-gss and xscreensaver-gl-extras-gss, or actually 
switching back to KDE.

KDE 4 looks like this:
http://video.linux-noob.com/screenshots/fedora/9/post-67-1210463844.png
not like this:
https://bugzilla.redhat.com/attachment.cgi?id=305826

Note You need to log in before you can comment on or make changes to this bug.