Bug 447166 - iwl4965: booting with killswitch set (no radio) requires module-reload after switching killswitch to get wireless working (with "workaround")
iwl4965: booting with killswitch set (no radio) requires module-reload after ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 448618 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 09:13 EDT by Stefan Neufeind
Modified: 2008-08-25 16:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-25 16:22:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-05-18 09:13:02 EDT
Booting with wireless turned off (killswitch) and trying to activate it
afterwards (switching the killswitch) does not work. However upon unload of
iwl4965 it gets autoloaded again and state returns to work as expected.



May 18 13:41:41 machine NetworkManager: <info>  Wireless now enabled by radio
killswitch
May 18 13:41:41 machine NetworkManager: <info>  (wlan0): device state change: 2 -> 3

# iwlist scan wlan0
wlan0     Interface doesn't support scanning : Network is down

# rmmod iwl4965

May 18 13:42:07 machine NetworkManager: <info>  (wlan0): now unmanaged
May 18 13:42:07 machine NetworkManager: <info>  (wlan0): device state change: 3 -> 1
May 18 13:42:07 machine kernel: iwl4965: Intel(R) Wireless WiFi Link 4965AGN
driver for Linux, 1.2.26kds
May 18 13:42:07 machine kernel: iwl4965: Copyright(c) 2003-2008 Intel Corporation
May 18 13:42:07 machine kernel: ACPI: PCI Interrupt 0000:0c:00.0[A] -> GSI 17
(level, low) -> IRQ 17
May 18 13:42:07 machine kernel: iwl4965: Detected Intel Wireless WiFi Link 4965AGN
May 18 13:42:08 machine kernel: iwl4965: Tunable channels: 13 802.11bg, 19
802.11a channels
May 18 13:42:08 machine kernel: input: 4965AGN as
/devices/pci0000:00/0000:00:1c.1/0000:0c:00.0/input/input12
May 18 13:42:08 machine kernel: ACPI: PCI Interrupt 0000:0c:00.0[A] -> GSI 17
(level, low) -> IRQ 17
May 18 13:42:08 machine kernel: Registered led device: iwl-phy1:radio
May 18 13:42:08 machine kernel: Registered led device: iwl-phy1:assoc
May 18 13:42:08 machine kernel: Registered led device: iwl-phy1:RX
May 18 13:42:08 machine kernel: Registered led device: iwl-phy1:TX
May 18 13:42:08 machine kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready

# iwlist scan wlan0
wlan0     Scan completed :
[... shows found cells ...]
Comment 1 Stefan Neufeind 2008-05-18 09:15:26 EDT
PS: test run with kernel 2.6.25.3-18.fc9.x86_64
Comment 2 John W. Linville 2008-05-20 14:54:40 EDT
Can you recreate this issue with the test kernels here?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=49743
Comment 3 Stefan Neufeind 2008-05-20 16:41:22 EDT
Unfortunately still no luck. Exact same symptoms. /var/log/messages again says
that wireless is now enabled through the radio killswitch, however "iwlist scan"
claims the network as down and therefor does not scan for anything.
Comment 4 John W. Linville 2008-05-20 16:47:41 EDT
Did you execute "ifconfig wlan0 up"?  If the interface is down, no scanning 
will be performed.
Comment 5 Stefan Neufeind 2008-05-20 17:15:38 EDT
"ifconfig wlan0 up" gives me:
SIOCSIFFLAGS: Connection timed out

Not sure if bringing it up with ifconfig was needed before. Thought with Fedora
8 I just enabled wireless and was ready to go ... hmm ...
Comment 6 John W. Linville 2008-06-12 13:44:51 EDT
*** Bug 448618 has been marked as a duplicate of this bug. ***
Comment 7 John W. Linville 2008-06-12 13:53:09 EDT
The iwlwifi driver continues to get a lot of changes...try something more 
recent?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=52276

This has seen recent discussion upstream, and the iwl4965 driver should get an 
interrupt when the switch is changed.
Comment 8 Stefan Neufeind 2008-08-12 09:44:00 EDT
Think I tested it when you updated the bug and it didn't work at that time. (However I can't make sure anymore ...)

Meanwhile tested on fully updated system running 2.6.25.11-97.fc9.x86_64 and it works fine now. Switching the rfkill-switch the interface comes up fine, network manager notices and configures the device.

Works now, please declare fixed.

Note You need to log in before you can comment on or make changes to this bug.