Bug 448618 - Unable to use wireless Intel 4965 if Thinkpad T61 booted with rf switch off
Unable to use wireless Intel 4965 if Thinkpad T61 booted with rf switch off
Status: CLOSED DUPLICATE of bug 447166
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 17:08 EDT by Alain Lafontaine
Modified: 2008-06-12 13:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 13:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci result (2.57 KB, text/plain)
2008-05-27 19:08 EDT, Alain Lafontaine
no flags Details
lsusb result (591 bytes, text/plain)
2008-05-27 19:08 EDT, Alain Lafontaine
no flags Details
dmesg output with rf killswitch off (33.03 KB, text/plain)
2008-05-27 19:09 EDT, Alain Lafontaine
no flags Details
dmesg output with rf killswitch on (32.48 KB, text/plain)
2008-05-27 19:09 EDT, Alain Lafontaine
no flags Details
dmesg output when switching rf killswitch on to off (459 bytes, text/plain)
2008-05-27 19:10 EDT, Alain Lafontaine
no flags Details

  None (edit)
Description Alain Lafontaine 2008-05-27 17:08:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
Power up thinkpad with rf switch ON:  network manager detects all wireless networks and works correctly

Power up thinkpad with rf switch OFF: network manager does not detect any wireless network, only shows wired network adapter.  Change switch position to ON: only bluethoot activates, network manager never detects card or wireless networks

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Power up laptop with rf switch off
2.
3.

Actual Results:
No wireless networks or wireless cards in network manager

Expected Results:
Wireless cards and networks appear in Network Manager.  Connect to wireless network.

Additional info:
dmesg output when switch rf switch on and off:

RF Switch ON:

hub 1-0:1.0: unable to enumerate USB device on port 1
usb 3-1: new full speed USB device using uhci_hcd and address 6
usb 3-1: configuration #1 chosen from 1 choice
usb 3-1: New USB device found, idVendor=0a5c, idProduct=2110
usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 3-1: Product: BCM2045B
usb 3-1: Manufacturer: Broadcom Corp


RF Switch OFF:

usb 3-1: USB disconnect, address 6
Comment 1 Nicolas Chauvet (kwizart) 2008-05-27 17:35:15 EDT
This bug has been assigned to the wrong component.

Can you provide an output of theses command. 
(or the smolt profile for your laptop)
/sbin/lspci
/sbin/lsusb

This also seems useful, a "full" dmesg output. (once with RFKS on, and the other
off) and also dmesg |tail when switch goes from ON to OFF.
 (Pick "Create a New Attachment" to upload each file )

Note that we usually say that RF kill switch (Radio Frequency Kill switch) is
OFF when you can use your wireless, whereas is it is ON when wireless is disabled.

Comment 2 Alain Lafontaine 2008-05-27 19:08:18 EDT
Created attachment 306852 [details]
lspci result
Comment 3 Alain Lafontaine 2008-05-27 19:08:40 EDT
Created attachment 306853 [details]
lsusb result
Comment 4 Alain Lafontaine 2008-05-27 19:09:15 EDT
Created attachment 306854 [details]
dmesg output with rf killswitch off
Comment 5 Alain Lafontaine 2008-05-27 19:09:44 EDT
Created attachment 306855 [details]
dmesg output with rf killswitch on
Comment 6 Alain Lafontaine 2008-05-27 19:10:32 EDT
Created attachment 306856 [details]
dmesg output when switching rf killswitch on to off
Comment 7 John W. Linville 2008-05-28 08:55:51 EDT
Can you replicate this issue with the kernels here?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=50669
Comment 8 Alain Lafontaine 2008-05-28 10:00:06 EDT
Booted the new kernel with the rf killswitch off, logged in then system hung
with caps lock led flashing.

Booted the new kernel with rf killswitch on, system working fine, no wireless,
switch rf kill switch off still no wireless but system did not hang. 
Comment 9 John W. Linville 2008-06-12 13:44:50 EDT

*** This bug has been marked as a duplicate of 447166 ***

Note You need to log in before you can comment on or make changes to this bug.