Bug 44718 - AltGr is non-functional in gdm
Summary: AltGr is non-functional in gdm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 48061 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-15 15:42 UTC by Patrick C. F. Ernzer
Modified: 2007-04-18 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 16:07:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick C. F. Ernzer 2001-06-15 15:42:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9.1)
Gecko/20010607

Description of problem:
AltGr-<key> only generates <key>, thus making it impossible to enter
symbols that are only accessible in conjunction with AltGr.

How reproducible:
Always

Steps to Reproduce:
1. Install RHL 7.0
2. Go to runlevel 5
3. try to enter a symbol that is accessible by pressing AltGr


Actual Results:  AltGr is ignored, thus some special signs (i.e. @ on a
French keyboard) are not accessible

Expected Results:  AltGr should work the same way in gdm as it does when
logged into X.

Additional info:

Comment 1 Havoc Pennington 2001-06-18 14:54:39 UTC
I'm not really sure how AltGr gets set up normally - Mike is there some file 
that is supposed to get loaded with the keymap in it?

Comment 2 Havoc Pennington 2001-07-12 16:07:11 UTC
*** Bug 48061 has been marked as a duplicate of this bug. ***

Comment 3 Havoc Pennington 2001-07-12 16:09:49 UTC
Fixed in rawhide. Believed to have been an X bug where grabbing the keyboard 
broke AltGr. gdm no longer grabs the keyboard in rawhide.


Note You need to log in before you can comment on or make changes to this bug.