Bug 447190 - preupgrade died on unison update
preupgrade died on unison update
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 450846 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-18 13:49 EDT by Stephen John Smoogen
Modified: 2008-10-27 12:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 12:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 450846 None None None Never

  None (edit)
Description Stephen John Smoogen 2008-05-18 13:49:35 EDT
Description of problem:

Not sure if this is a preupgrade problem, a unison problem, or anaconda.. will
start with preupgrade and go from there.

The preupgrade downloaded all the applications for my system but seemed really
slow. I had to restart the download of the packages twice.. and it seemed to
recover correctly. However on the upgrade I ran into a problem with the unison
package saying it could not be upgraded... and the install was not stable so
please re-install. On a reboot the unison RPM seemed to have been upgraded with

unison213.i386                           2.13.16-10.fc9         fedora          
unison227.i386                           2.27.57-8.fc9          fedora        

installed on the system. That seemed to have been the only issue. I reinstalled
with Fedora9 DVD. I would have tried to replay the F8 install but I did a stupid 

rpm -qa | sort | uniq > RPM-QA (forgot to move the old one...)
Comment 1 Lev Shamardin 2008-06-11 07:02:26 EDT
Confirmed, I had the same problem with preupgrade & unsion. Seemes to be the
preupgrade problem, because I have manually downloaded the unison rpms from the
text console to /mnt/sysimage/var/cache/yum/anaconda-upgrade/packages, hit retry
and the upgrade succeeded.
Comment 2 Will Woods 2008-06-11 09:17:09 EDT
*** Bug 450846 has been marked as a duplicate of this bug. ***
Comment 3 Will Woods 2008-06-11 09:40:44 EDT
Is this on an i386 system or an x86_64? 

x86_64/ppc64 preupgrade is known not to work without a network connection.
There's a big fat warning about this in the upcoming preupgrade version.

If it's i386.. I'll take a closer look.
Comment 4 Lev Shamardin 2008-06-11 10:07:30 EDT
This was on i386.
Comment 5 Stephen Warren 2008-08-18 17:03:55 EDT
I saw this too. I think the issue is that unison*.rpm isn't in the repo that preupgrade looks at, hence it blows up. No idea why; it's in the Everything repo though. I'm not sure why preupgrade doesn't look at the updates repo too.

To solve the problem, I found that if I manually download the file and place it where preupgrade puts all the other d/l'd packages, it works.
Comment 6 Will Woods 2008-10-27 12:13:00 EDT
The long-term solution to this bug - that we're using for F10 Beta and later - is to have the installer use the downloaded packages like a normal repo. This makes it gracefully handle missing packages.

So this is fixed by preupgrade-0.9.8 (currently in updates-testing) but only for upgrading to F10 Beta or later. Upgrading to F9 or earlier is not supported.

Note You need to log in before you can comment on or make changes to this bug.