This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 447309 - new gnome-session no longer honors (uses?) gnome-wm preferences
new gnome-session no longer honors (uses?) gnome-wm preferences
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
: 449048 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-05-19 09:41 EDT by sangu
Modified: 2008-09-17 00:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 15:16:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 546496 None None None Never

  None (edit)
Description sangu 2008-05-19 09:41:43 EDT
Description of problem:
$ gconftool-2 --get /apps/gnome-session/rh/window_manager
compiz

But when gnome starts, metacity starts.

Version-Release number of selected component (if applicable):
2.23.2.2-3.fc10

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ray Strode [halfline] 2008-05-30 14:27:36 EDT
*** Bug 449048 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Clasen 2008-08-05 17:58:40 EDT
This should be fixed with the following commit, I think:

2008-07-31  William Jon McCann  <jmccann@redhat.com>

        * data/Makefile.am:
        * data/gnome-session.schemas.in:
        * data/gnome-wm:
        * data/gnome-wm.desktop.in:
        * gnome-session/gsm-util.c (gsm_util_get_app_dirs):
        Install a desktop file for gnome-wm and use that
        as the default window manager instead of calling
        metacity directly.  Add a gconf key to allow
        changing the default program for gnome-wm to use.
        Remove the gnome/wm-properties directory from
        the autostart search path.
Comment 3 sangu 2008-08-05 20:53:04 EDT
(In reply to comment #2)
> This should be fixed with the following commit, I think:
> 
> 2008-07-31  William Jon McCann  <jmccann@redhat.com>
> 
>         * data/Makefile.am:
>         * data/gnome-session.schemas.in:
>         * data/gnome-wm:
>         * data/gnome-wm.desktop.in:
>         * gnome-session/gsm-util.c (gsm_util_get_app_dirs):
>         Install a desktop file for gnome-wm and use that
>         as the default window manager instead of calling
>         metacity directly.  Add a gconf key to allow
>         changing the default program for gnome-wm to use.
>         Remove the gnome/wm-properties directory from
>         the autostart search path.

in gnome-session-2.23.6-1.fc10.i386.

$ cat /etc/gconf/schemas/gnome-session.schemas | grep prefered_window_manager
         <key>/schemas/apps/gnome-session/gnome-wm/prefered_window_manager</key>

prefered_window_manager <- this name is wrong.  maybe missing spell? in gnome-session.schemas.

$ cat /usr/bin/gnome-wm | grep preferred
  WINDOW_MANAGER=$(gconftool-2 --get /apps/gnome-session/gnome-wm/preferred_window_manager)
Comment 4 sangu 2008-08-05 21:17:57 EDT
(In reply to comment #3)

> in gnome-session-2.23.6-1.fc10.i386.
> 
> $ cat /etc/gconf/schemas/gnome-session.schemas | grep prefered_window_manager
>         
> <key>/schemas/apps/gnome-session/gnome-wm/prefered_window_manager</key>
> 
> prefered_window_manager <- this name is wrong.  maybe missing spell? in
> gnome-session.schemas.
> 
> $ cat /usr/bin/gnome-wm | grep preferred
>   WINDOW_MANAGER=$(gconftool-2 --get
> /apps/gnome-session/gnome-wm/preferred_window_manager)

Added http://bugzilla.gnome.org/show_bug.cgi?id=546496 to gnome bugzilla.
Comment 5 Matthias Clasen 2008-08-07 15:16:13 EDT
I've fixed the typo upstream now. Will be in the next build.
Comment 6 James Ralston 2008-09-16 18:41:09 EDT
Is this fix in Rawhide yet?

I ask because I'm running Rawhide on my laptop (gnome-session-2.23.92-1), and I'm still fighting with gnome-session to run my preferred window manager:

$ gconftool-2 --get-type /apps/gnome-session/gnome-wm/preferred_window_manager
string

$ gconftool-2 --get /apps/gnome-session/gnome-wm/preferred_window_manager
sawfish

$ type sawfish
sawfish is /usr/bin/sawfish

Yet when I login, I get metacity.  And gnome-session will stubbornly restart metacity if I attempt to kill it and run sawfish instead.  :(

If I keep executing "killall metacity; daemon sawfish", sawfish will eventually win the race, but man oh man does gnome-session become perturbed if that happens.  (As in, it keeps trying to fork metacity processes as fast as they die, thereby pegging the CPU.)
Comment 7 sangu 2008-09-17 00:21:33 EDT
(In reply to comment #6)
> Is this fix in Rawhide yet?
> 
> I ask because I'm running Rawhide on my laptop (gnome-session-2.23.92-1), and
> I'm still fighting with gnome-session to run my preferred window manager:
> 
> $ gconftool-2 --get-type /apps/gnome-session/gnome-wm/preferred_window_manager
> string
> 
> $ gconftool-2 --get /apps/gnome-session/gnome-wm/preferred_window_manager
> sawfish

See Also bug 460552, comment 2
changed gconf vaule

> 
> $ type sawfish
> sawfish is /usr/bin/sawfish
> 
> Yet when I login, I get metacity.  And gnome-session will stubbornly restart
> metacity if I attempt to kill it and run sawfish instead.  :(
> 
> If I keep executing "killall metacity; daemon sawfish", sawfish will eventually
> win the race, but man oh man does gnome-session become perturbed if that
> happens.  (As in, it keeps trying to fork metacity processes as fast as they
> die, thereby pegging the CPU.)

See Also bug 461622 : install desktop file intoXDG application dirs 

So.
Using compiz, temporary measure.
Make two file. 

$ cat /usr/share/applications/compiz.desktop 
[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Compiz
Exec=startcompiz
NoDisplay=true
# name of loadable control center module
X-GNOME-WMSettingsModule=compiz
# name we put on the WM spec check window
X-GNOME-WMName=Compiz
# back compat only 
X-GnomeWMSettingsLibrary=compiz
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=compiz
X-GNOME-Bugzilla-Component=general
X-GNOME-Autostart-Phase=WindowManager
X-GNOME-Provides=windowmanager
X-GNOME-Autostart-Notify=true

$ cat /usr/bin/startcompiz 
#!/bin/sh
gtk-window-decorator &
compiz --replace glib gconf &

$ ls -al /usr/bin/startcompiz 
-rwxr-xr-x 1 root root 124 2008-09-10 22:52 /usr/bin/startcompiz

$ gconftool-2 --get /desktop/gnome/session/required_components/windowmanager
compiz

Note You need to log in before you can comment on or make changes to this bug.