Bug 449048 - new gnome-session no longer honors (uses?) gnome-wm preferences
Summary: new gnome-session no longer honors (uses?) gnome-wm preferences
Keywords:
Status: CLOSED DUPLICATE of bug 447309
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-30 02:59 UTC by Michal Jaegermann
Modified: 2008-05-30 18:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-30 18:27:35 UTC
Type: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2008-05-30 02:59:08 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michal Jaegermann 2008-05-30 03:11:01 UTC
Sigh!  Here is this report for real.

'man gnome-wm' from gnome-session package claims:

The user can overwrite the selection of a window manager by setting the
WINDOW_MANAGER environment variable.

OK, lets try.  'echo $WINDOW_MANAGER' shows 'sawish' (in case you wonder
I do have sawfish compiled for rawhide and it was even running not so
long time ago).  What actually runs?  metacity.

A script /usr/bin/gnome-wm looks at a value provided by
gconftool-2 --get /apps/gnome-session/rh/window_manager
in case WINDOW_MANAGER was not set.  So lets try to set that to
"sawfish".  What runs?  You guessed it - metacity.

That is not so surprising when even after "hardwiring"
WINDOW_MANAGER=sawfish
in /usr/bin/gnome-wm script one ends up running .... metacity!

So how to change that default?

gnome-session-2.23.2.2-3.fc10


Comment 2 Michal Jaegermann 2008-05-30 03:13:33 UTC
Obviously susbstitute above "sawfish" for "sawish".

Comment 3 Rex Dieter 2008-05-30 15:22:01 UTC
export WINDOW_MANAGER ?

Comment 4 Michal Jaegermann 2008-05-30 15:59:20 UTC
> export WINDOW_MANAGER ?

It is exported but if write directly in /usr/bin/gnome-wm
WINDOW_MANAGER=sawfish
before it is used then one would think that this is even "stronger".

Going through a bug search again it appears that bug 447309
would be another, more specific, instance of really the same issue.

Comment 5 Ray Strode [halfline] 2008-05-30 18:27:35 UTC

*** This bug has been marked as a duplicate of 447309 ***


Note You need to log in before you can comment on or make changes to this bug.