This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 447310 - Touchpad tapping doesn't work
Touchpad tapping doesn't work
Status: CLOSED DUPLICATE of bug 439386
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 09:42 EDT by Dawid Lorenz
Modified: 2008-06-21 15:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 15:32:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dawid Lorenz 2008-05-19 09:42:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
Tapping on touchpad no longer work with F9. Used to work OK with F8. It doesn't work with default xorg.conf configuration file, as well as with my modifications, that I've had on F8.

Version-Release number of selected component (if applicable):
F9 initial release

How reproducible:
Always


Steps to Reproduce:
Just don't work - nothing to reproduce.

Actual Results:
Tapping the touchpad doesn't work.

Expected Results:
Tapping the touchpad should emulate a mouse click.

Additional info:
xorg.conf section I use to configure touchpad:

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
        Option      "LeftEdge" "120"
        Option      "RightEdge" "830"
        Option      "TopEdge" "120"
        Option      "BottomEdge" "650"
        Option      "FingerLow" "14"
        Option      "FingerHigh" "15"
        Option      "MaxTapMove" "110"
        Option      "VertScrollDelta" "20"
        Option      "HorizScrollDelta" "20"
        Option      "MinSpeed" "0.3"
        Option      "MaxSpeed" "0.75"
EndSection
Comment 1 Todd J Martin 2008-05-19 11:35:37 EDT
This is a duplicate of bug 439386.
Comment 2 Axel Thimm 2008-05-21 10:55:52 EDT
(In reply to #bug 437702 comment #1)
> OK, looks like this one was intentional:
> 
> * Mon Mar 10 2008 Adam Jackson <ajax@redhat.com> 0.14.6-4
> - synaptics-0.14.6-tap-to-click.patch: Disable tap to click by default in
>   the name of accessibility.
> 
> I'm not sure this is really a good idea, since this is unexpected behaviour,
> both by upstream documentation as well as shipped documentation (e.g. the patch
> would have had to patch the man pages for example as well).
> 
> Instead it could be something that the gdm login screen could be turning on/off
> along with all the other accessibility items. Also if you really want the
> default to change then do it in teh created xorg.conf, not hardwired in the
> sources where no one will be seraching for this change in behaviour. If F9 ships
> out that way you will get lots of duplicates to this bug report.

OK, so we have 5 reports out of a total of 56 reports of all synaptics bug
reports ever filed. Not the bug raining day, but still a very unpleasant
experience with F9 and tapping.

Fixing it is easy, here is the patch
--- synaptics.spec~	2008-03-28 20:28:10.000000000 +0100
+++ synaptics.spec	2008-04-10 19:45:27.000000000 +0200
@@ -4,3 +4,3 @@
 Version:        0.14.6
-Release:	7%{?dist}
+Release:	8%{?dist}
 Summary:        Synaptics Touchpad Driver
@@ -14,3 +14,2 @@
 Patch1: synaptics-0.14.6-newx.patch
-Patch2: synaptics-0.14.6-tap-to-click.patch
 Patch3: synaptics-0.14.6-poll-delay.patch
@@ -55,3 +54,2 @@
 %endif
-%patch2 -p1 -b .tap
 %patch3 -p1 -b .polldelay
@@ -89,2 +87,5 @@
 %changelog
+* Thu Apr 10 2008 Axel Thimm <Axel.Thimm@ATrpms.net> - 0.14.6-8
+- Reenable tap to click.
+
 * Fri Mar 28 2008 Rex Dieter <rdieter@fedoraproject.org> 0.14.6-7

And for the ones too lazy to rebuild I've placed the fixed synaptics package in
ATrpms' testing area or you can get it directly from

http://atrpms.net/dist/f9/synaptics/

Bought my sanity back.
Comment 3 Matěj Cepl 2008-06-21 15:32:42 EDT

*** This bug has been marked as a duplicate of 439386 ***

Note You need to log in before you can comment on or make changes to this bug.