Bug 437702 - tapping stopped working
tapping stopped working
Status: CLOSED DUPLICATE of bug 437609
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-16 14:45 EDT by Axel Thimm
Modified: 2008-05-21 10:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 13:15:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2008-03-16 14:45:59 EDT
Description of problem:
Tapping on touchpads does not work anymore.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.4.99.901-8.20080310.fc9.x86_64
synaptics-0.14.6-4.fc9.x86_64
kernel-2.6.25-0.121.rc5.git4.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1.boot into X11
2.
3.
  
Actual results:
no tapping works

Expected results:
tapping should work

Additional info:
xorg.conf is the one from https://bugzilla.redhat.com/show_bug.cgi?id=436636
(bug #436636). At that time (a week ago) tapping worked. Now with the same
config file tapping is broken. Diffing the Xorg.0.logs reveals:

@@ -5,5 +5,5 @@
 Build Operating System: Linux 2.6.18-53.1.6.el5xen x86_64 
-Current Operating System: Linux victor 2.6.25-0.101.rc4.git3.fc9 #1 SMP Sat Mar
8 15:44:24 EST 2008 x86_64
-Build Date: 07 March 2008  01:48:46PM
-Build ID: xorg-x11-server 1.4.99.901-1.20080307.fc9 
+Current Operating System: Linux victor 2.6.25-0.121.rc5.git4.fc9 #1 SMP Fri Mar
14 22:50:25 EDT 2008 x86_64
+Build Date: 13 March 2008  03:19:54PM
+Build ID: xorg-x11-server 1.4.99.901-8.20080310.fc9 
        Before reporting problems, check http://wiki.x.org
@@ -14,3 +14,3 @@
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
-(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 10 23:46:18 2008
+(==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar 16 20:32:02 2008
 (==) Using config file: "/etc/X11/xorg.conf"
@@ -32,3 +32,3 @@
 (II) Open ACPI successful (/var/run/acpid.socket)
-(II) Loader magic: 0x7b4f80
+(II) Loader magic: 0x7b4ec0
 (II) Module ABI versions:
[...]
@@ -483,2 +478,12 @@
 (II) XINPUT: Adding extended input device "Macintosh mouse button emulation"
(type: MOUSE)
+(II) Synaptics touchpad driver version 0.14.6 (1406)
+(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event2
+(**) Option "Device" "/dev/input/event2"
+(--) SynPS/2 Synaptics TouchPad touchpad found
+(**) SynPS/2 Synaptics TouchPad: always reports core events
+(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type:
MOUSE)
+(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event2
+(**) Option "Device" "/dev/input/event2"
+(WW) SynPS/2 Synaptics TouchPad can't grab event device, errno=16
+(--) SynPS/2 Synaptics TouchPad touchpad found
 (**) AT Translated Set 2 keyboard: always reports core events
Comment 1 Axel Thimm 2008-03-20 15:36:37 EDT
OK, looks like this one was intentional:

* Mon Mar 10 2008 Adam Jackson <ajax@redhat.com> 0.14.6-4
- synaptics-0.14.6-tap-to-click.patch: Disable tap to click by default in
  the name of accessibility.

I'm not sure this is really a good idea, since this is unexpected behaviour,
both by upstream documentation as well as shipped documentation (e.g. the patch
would have had to patch the man pages for example as well).

Instead it could be something that the gdm login screen could be turning on/off
along with all the other accessibility items. Also if you really want the
default to change then do it in teh created xorg.conf, not hardwired in the
sources where no one will be seraching for this change in behaviour. If F9 ships
out that way you will get lots of duplicates to this bug report.

For anyone hitting this bug report and in need of restoring the upstream
behaviour, please add

        Option      "RTCornerButton" "2"
        Option      "RBCornerButton" "3"
        Option      "TapButton1" "1"
        Option      "TapButton2" "2"
        Option      "TapButton3" "3"

to your xorg.conf in Section "InputDevice" with Driver "synaptics".

To sum up:
a) please don't make that the default
b) if you want to change the default do so with Options in xorg.conf which will
   document the changes to any user wondering why the touchpad doesn't work as
   before.

Thanks!
Comment 2 Thorsten Leemhuis 2008-03-28 13:15:14 EDT

*** This bug has been marked as a duplicate of 437609 ***
Comment 3 Matthew D'Onofrio 2008-05-20 19:54:36 EDT
The touchpad is a critical element of my notebook and as a new Linux user I did
not understand what was wrong in F9 and why my touchpad did not work. I was
lucky to figure it out by remembering that it worked on my F8 live cd so I did a
little research and copied over the missing information in my xorg.conf.

This was not a pleasant experience as a new user.
Comment 4 Axel Thimm 2008-05-21 10:55:58 EDT
(In reply to #bug 437702 comment #1)
> OK, looks like this one was intentional:
> 
> * Mon Mar 10 2008 Adam Jackson <ajax@redhat.com> 0.14.6-4
> - synaptics-0.14.6-tap-to-click.patch: Disable tap to click by default in
>   the name of accessibility.
> 
> I'm not sure this is really a good idea, since this is unexpected behaviour,
> both by upstream documentation as well as shipped documentation (e.g. the patch
> would have had to patch the man pages for example as well).
> 
> Instead it could be something that the gdm login screen could be turning on/off
> along with all the other accessibility items. Also if you really want the
> default to change then do it in teh created xorg.conf, not hardwired in the
> sources where no one will be seraching for this change in behaviour. If F9 ships
> out that way you will get lots of duplicates to this bug report.

OK, so we have 5 reports out of a total of 56 reports of all synaptics bug
reports ever filed. Not the bug raining day, but still a very unpleasant
experience with F9 and tapping.

Fixing it is easy, here is the patch
--- synaptics.spec~	2008-03-28 20:28:10.000000000 +0100
+++ synaptics.spec	2008-04-10 19:45:27.000000000 +0200
@@ -4,3 +4,3 @@
 Version:        0.14.6
-Release:	7%{?dist}
+Release:	8%{?dist}
 Summary:        Synaptics Touchpad Driver
@@ -14,3 +14,2 @@
 Patch1: synaptics-0.14.6-newx.patch
-Patch2: synaptics-0.14.6-tap-to-click.patch
 Patch3: synaptics-0.14.6-poll-delay.patch
@@ -55,3 +54,2 @@
 %endif
-%patch2 -p1 -b .tap
 %patch3 -p1 -b .polldelay
@@ -89,2 +87,5 @@
 %changelog
+* Thu Apr 10 2008 Axel Thimm <Axel.Thimm@ATrpms.net> - 0.14.6-8
+- Reenable tap to click.
+
 * Fri Mar 28 2008 Rex Dieter <rdieter@fedoraproject.org> 0.14.6-7

And for the ones too lazy to rebuild I've placed the fixed synaptics package in
ATrpms' testing area or you can get it directly from

http://atrpms.net/dist/f9/synaptics/

Bought my sanity back.

Note You need to log in before you can comment on or make changes to this bug.