Bug 447322 - kde3 apps, some menu fonts unreadable on Chinese system
kde3 apps, some menu fonts unreadable on Chinese system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 449270 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 10:44 EDT by Saul Thomas
Modified: 2008-06-30 01:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 07:31:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saul Thomas 2008-05-19 10:44:22 EDT
Description of problem:
Running fedora 9 86_64 gnome system with base language of Chinese. I have
several KDE apps installed. Some of the text in the menus of those apps is
completely unreadable. I believe this is happening both with text in English as
well as Chinese, though I am not sure, because the text is unreadable. I believe
this is happening only with kde3 apps such as basket and k3b. It does not happen
with keepassx or skype, which I believe are based on qt4. It does not happen
with any gnome applications. It also happens with the instant messaging
application Coccinella, which I understand is not based on kde. It does happen
with kde font configuration tool.


Version-Release number of selected component (if applicable):
kdeadmin(?) 3.5.9?

How reproducible:
  

Steps to Reproduce:
1.Install fedora 9 gnome x86_64.
2.Change default language to Chinese.
3.Install kde3 applications such as basket and k3b.
  
Actual results:
Many menu items fail to render, the text is unreadable. 

Expected results:
all menu items should be legible

Additional info:
I have posted a screenshot here:
http://picasaweb.google.com/saul.terence.thomas/Screenshot
I can provide other screenshots or information if it would be helpful.
Comment 1 Saul Thomas 2008-05-27 20:31:04 EDT
The problem is now happening with openoffice. I had previously not installed the
Chinese support package for openoffice, and it was running as if the default
language was English. After installing the package
openoffice.org-langpack-zh_CN-1:2.4.0-12.8.fc9 (x86_64), the default language
for openoffice switched to Chinese, but it has the same menu item font problem
described above. When I uninstalled the language package, openoffice stayed in
Chinese and the font rendering problem remained.

So it appears that this is not just a kde3 issue. But it does not affect gnome
apps or kde4 apps.
Comment 2 Saul Thomas 2008-05-31 17:29:03 EDT
I've discovered that the problem seems to have been caused by the configuration
file of the following font package:
wqy-bitmap-fonts-0.9.9.fc9 (noarch)

The fonts are superior to the standard Chinese fonts in most linux systems, but
the configuration file:
/etc/fonts/conf.d/61-wqy-bitmapsong.conf
seems to be problematic with regard to non-gnome apps' use of the fonts.
Changing the name of the configuration file causes the system to use standard
Chinese fonts in all apps (if those fonts are installed). Restoring the name of
the configuration file causes gnome apps to work normally, but non-gnome apps
sometimes do not use the proper fonts. 

In previous editions of fedora, there was a similar problem in running kde
programs in a Chinese gnome system. At that time, the kde apps would display
empty squares to denote missing fonts. The new edition of fedora does not
display empty squares, but a sort of blur, as shown in the screenshot attached. 

I am not sure why gnome and kde apps respond to Chinese fonts differently. Each
appears to look for the fonts in different places. KDE4 has an excellent font
manager which seems to alleviate this problem, but gnome and kde3 lack this
function.

I am attaching the problematic configuration file here (which, again, works for
gnome apps). I will send this to the creator of the wqy Chinese fonts as well. 



Comment 3 Rex Dieter 2008-05-31 17:48:02 EDT
Per  https://bugzilla.redhat.com/show_bug.cgi?id=230560#c30
"the provided fontconfig file allows the synergy of this bitmap 
font with other existing vector fonts at specific font sizes, which is a highly
desired feature and make web page display very pleasing."  

I guess "desired feature" is sometimes subjective. :)

imo, we should consider punting this over to wqy-bitmap-fonts maintainer(s), to
see what they think.
Comment 4 Qianqian Fang 2008-06-01 01:17:25 EDT
here is my reply to Saul's email. I would be glad to watch this bug if more
input is given.

==============================================
hi Saul

this is a strange problem. Frankly, I only see similar problems twice:

1) two years ago, Nvidia driver before 8754 will produce similar effect,
i.e.
for any Chinese fonts that embeds bitmaps, it will randomly show garbled
squares, select by mouse will recover. I had an early screen shot
uploaded in our gallery:
http://wenq.org/gallery/displayimage.php?album=4&pos=1

2) when I overwrite wqy's font by an updated fonts fonts (I did that
regularly
for testing purpose), if I don't restart X, it may give some funny lookings.

I see nothing wrong in 61-wqy-bitmapfont.conf: all are supported
features of fontconfig. Plus that it was working fine for the past 3 years.

so, that's all that I know. I doublt this is related to
61-wqy-bitmapfonts.conf,
it looks like either the driver problem, or KDE problem. but I am not
entirely sure (I am using Xfce4/GNOME as my desktop, don't have
this problem recently.)

I will be glad to follow closely with this bug, if you have more info or
feedback, please also let me know.

thanks

Qianqian
Comment 5 Qianqian Fang 2008-06-01 10:31:35 EDT
*** Bug 449270 has been marked as a duplicate of this bug. ***
Comment 6 Pedro 2008-06-01 11:29:26 EDT
I am the reporter of bug 449270 (my wqy fonts display badly too).   
I will add that my system uses NVidia as well. 
The version number of the Nvidia driver I am using is
NVIDIA-Linux-x86-173.14.05, for an nVidia Corporation NV44A [GeForce 6200] (rev a1).



Comment 7 Pedro 2008-06-01 12:27:42 EDT
I tried using other NVIDIA drivers, to find out whether the font would display
correctly with them.
However, I could not test them:   NVIDIA Drivers version 171.xx did not even
compile on my current F9 kernel (2.6.25.3-18.fc9.i686).    Driver version
NVIDIA-Linux-x86-173.08 did compile, but when I launched X, it would load up.
I went back to 173.14.05, which does compile, and allows X to run, but the font
still displays wrongly.   
Comment 8 Rex Dieter 2008-06-01 12:35:02 EDT
Ah,  so anyone seeing this, please report back what video hw/driver you're using.

Folks using NVidia driver, please try to confirm using fedora's nv driver, else
we'll have not much choice but to lay blame on the closed source driver here.
Comment 9 Pedro 2008-06-01 14:48:05 EDT
Thanks for the suggeston, Rex:    I just ran my Xwindows with the "nv" driver
instead of NVIDIA's own driver...  and the problem goes away.    

The fact that this problem seems to have surfaced with FC9 makes me think that
the NVIDIA problem appears with the new kernel in F9 (2.6.25.3-18.fc9.i686).

It could also be just a coincidence, because I only used the new driver
(NVIDIA-Linux-x86-173.14.05) at the same time I upgraded to F9.  (my F8 system
was using a previous driver version).

I will try to report this problem to NVIDIA as well.


Comment 10 Lukáš Tinkl 2008-06-02 07:31:16 EDT
Thanks for your investigation, you can report the bug to NVidia using the info
from here:

http://www.nvnews.net/vbulletin/showthread.php?t=46678
Comment 11 Granville Xiong 2008-06-13 03:31:56 EDT
I am running Fedora 9 on my Thinkpad Z60 which uses ATI graphics card, and
experiencing the same problem of displaying chinese fonts. So I don't think this
problem is specific to Nvidia cards. I met this problem in QT3-based
applications and even in GVim.
Comment 12 Pedro 2008-06-21 02:39:51 EDT
The new nVidia driver fixes the font corruption problem:
  http://www.nvidia.com/object/linux_display_ia32_173.14.09.html

They report that the nVidia problem appears with X.org 1.5

Xiong: It may be that ATI has similar problems with X.org 1.5...
Comment 13 Saul Thomas 2008-06-30 01:08:30 EDT
I get this problem with my ATI Radeon 200M integrated graphics card. 

Note You need to log in before you can comment on or make changes to this bug.