Bug 447517 - internal compiler error: in cgraph_estimate_size_after_inlining, at ipa-inline.c:188
internal compiler error: in cgraph_estimate_size_after_inlining, at ipa-inlin...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
: 449265 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-20 05:41 EDT by Julien Tane
Modified: 2008-06-03 05:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 08:41:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this contains the logs from the compiling of the kernel (786.74 KB, application/octet-stream)
2008-05-20 06:11 EDT, Julien Tane
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 35618 None None None Never

  None (edit)
Description Julien Tane 2008-05-20 05:41:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
I tried to compile the linux kernel linux-2.6.25. But obtained an internal compiler error from gcc.


Version-Release number of selected component (if applicable):
gcc-4.3.0-8.i386

How reproducible:
Always


Steps to Reproduce:
1. download linux kernel tar sources: linux-2.6.25
2. download config file for user mode linux for this kernel and put it as .config in the kernel src main directory
3. added a #include "limits.h" in some of the um file
4. make ARCH=um oldconfig
5. make ARCH=um


Actual Results:
the source were compiling until the point where an internal compiler error is output.


Expected Results:
the linux kernel should have compiled... But at least the compiler should not 
have any internal compiler error

Additional info:

In file included from kernel/sched.c:1252:
kernel/sched_idletask.c: In function ‘check_preempt_curr_idle’:
kernel/sched_idletask.c:20: internal compiler error: in cgraph_estimate_size_after_inlining, at ipa-inline.c:188
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccp5Dpta.out file, please attach this to your bugreport.
Comment 1 Julien Tane 2008-05-20 06:11:35 EDT
Created attachment 306101 [details]
this contains the logs from the compiling of the kernel
Comment 2 Julien Tane 2008-05-22 14:32:09 EDT
This bug seems to be solved in the next version of gcc (i.e 4.4), see:

<a href="http://gcc.gnu.org/bugzilla/show_bug.cgi?id=35618">
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=35618</a>.
Comment 3 Jakub Jelinek 2008-06-03 05:17:27 EDT
*** Bug 449265 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.