Bug 449265 - make linux ARCH=um - gcc crashes
make linux ARCH=um - gcc crashes
Status: CLOSED DUPLICATE of bug 447517
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 06:08 EDT by Laurent Wandrebeck
Modified: 2008-06-03 05:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 05:17:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gcc preprocessed source. (795.57 KB, text/plain)
2008-06-01 06:08 EDT, Laurent Wandrebeck
no flags Details

  None (edit)
Description Laurent Wandrebeck 2008-06-01 06:08:42 EDT
Description of problem:

GCC internal error while compiling linux-git head with make defconfig ARCH=um;
make linux ARCH=um

Version-Release number of selected component (if applicable):

gcc (GCC) 4.3.0 20080428 (Red Hat 4.3.0-8)

How reproducible:

always.

Steps to Reproduce:
1. git-clone
git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git your_dir
(will probably fail the same way with a 2.6.25-stable tree)
2. cd your_dir
3. make defconfig ARCH=um
4. make linux ARCH=um and wait a bit ;)
  
Actual results:

  CC      kernel/sched.o
In file included from kernel/sched.c:1486:
kernel/sched_idletask.c: In function ‘check_preempt_curr_idle’:
kernel/sched_idletask.c:20: erreur interne du compilateur: dans
cgraph_estimate_size_after_inlining, à ipa-inline.c:188


Expected results:

compiles flawlessly.

Additional info:
gcc log attached with gcc preprocessed source.
Comment 1 Laurent Wandrebeck 2008-06-01 06:08:42 EDT
Created attachment 307304 [details]
gcc preprocessed source.
Comment 2 Laurent Wandrebeck 2008-06-01 06:58:28 EDT
Tested with linux-next and 2.6.25.4, crashes the same way.
Comment 3 Jakub Jelinek 2008-06-03 05:17:26 EDT

*** This bug has been marked as a duplicate of 447517 ***

Note You need to log in before you can comment on or make changes to this bug.