Bug 447526 - nouveau + Randr12 == system lockup
Summary: nouveau + Randr12 == system lockup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-20 11:24 UTC by Tom Horsley
Modified: 2009-04-09 06:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-09 06:27:15 UTC


Attachments (Terms of Use)
The log from nouveau+Randr12 crash (7.92 KB, text/plain)
2008-05-20 11:25 UTC, Tom Horsley
no flags Details

Description Tom Horsley 2008-05-20 11:24:34 UTC
Description of problem:

While trying the nouveau driver to see if it works better than nv, I tried
turning on the Randr12 option (as recommended in a post on the fedora-list).
It is certainly different, but I can't call it better. Instead of getting
a rotten resolution, the system apparently freezes up. The last line in the
X log is:

(II) NOUVEAU(0): Attempting to locate BIOS image in PROM

I guess the attempt wasn't successful :-).


Version-Release number of selected component (if applicable):

(II) Loading /usr/lib/xorg/modules/drivers//nouveau_drv.so
(II) Module nouveau: vendor="X.Org Foundation"
	compiled for 1.4.99.901, module version = 0.0.10


How reproducible:

seems to be 100%

Steps to Reproduce:
1. see above
  
Actual results:

apparent system lockup

Expected results:

A 1920x1200 display would be nice :-).

Additional info:

See bug 446458 for my nv driver experience on same system.

Also, without the Randr12 option, nouveau behaves identical to nv
(i.e. a 1204x768 display).

I'll attach what there is of the X log written before the crash.

Comment 1 Tom Horsley 2008-05-20 11:25:30 UTC
Created attachment 306106 [details]
The log from nouveau+Randr12 crash

Comment 2 Scott Turnberg 2008-06-24 19:38:02 UTC
I ran into the same problem.  I was able to fix this by grabbing the nouveau
source and rebuilding the rpm.

Comment 4 Ben Skeggs 2009-04-09 06:27:15 UTC
Closing bug.  This should really work now with current releases.  If not, please reopen with new logs from the updated drivers!


Note You need to log in before you can comment on or make changes to this bug.