Bug 447752 - [glibc] Frequent segfaults in libresolv-2.8.90.so
[glibc] Frequent segfaults in libresolv-2.8.90.so
Status: CLOSED DUPLICATE of bug 448180
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 11:46 EDT by Joachim Frieben
Modified: 2008-05-25 04:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-25 04:29:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2008-05-21 11:46:00 EDT
Description of problem:
After upgrading to glibc-2.8.90, network is heavily affected by
a dysfunctional DNS service. Host names often fail to get resolved.
SSH connections always fail after a short period of time. This
even applies to the latest koji build.

Version-Release number of selected component (if applicable):
glibc-2.8.90-{1,2,3,4}

How reproducible:
Always.

Steps to Reproduce:
1. Open web browser.
2. Open URL.
  
Actual results:
Often an error message about an unknown server name appears
as if the server was down, or the name didn't get resolved
properly.

Expected results:
URL is loaded properly.

Additional info:
- Latency is high, and often one has to reload a web page several
  times to have it eventually be displayed.
- Regarding the SSH problems, I have spotted a related error message
  in /var/log/dmesg:

    ssh[4230]: segfault at 3 ip f063a9 sp 7fff1d20dc40 error 4 in
    libresolv-2.8.90.so[efe000+12000]
Comment 1 Joachim Frieben 2008-05-24 00:48:53 EDT
I have downgraded temporarily to glibc-2.8 and one of the stable F9
kernel. The segfault in libresolv-2.8.90.so disappears by doing so.
However, all other symptoms remain. After installing madwifi to
override the system default ath5k driver, network connectivity improves
a lot which points to a serious regression in the ath5 driver which is
responsible for the SSH drop-outs etc. This also explains why even the
latest glibc-2.8.90-4 hadn't brought much improvement.
Comment 2 Joachim Frieben 2008-05-25 04:29:39 EDT
No issue for kernels < 2.6.25.4-26.fc9, thus related to ath5k and
unlikely to depend on glibc-2.8.90.

*** This bug has been marked as a duplicate of 448180 ***

Note You need to log in before you can comment on or make changes to this bug.