Bug 448180 - [ath5k] Bad connectivity due to regression in outgoing data transfer
[ath5k] Bad connectivity due to regression in outgoing data transfer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 447752 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 01:28 EDT by Joachim Frieben
Modified: 2008-05-28 03:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 03:30:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2008-05-24 01:28:09 EDT
Description of problem:
For about 2 weeks now, the ath5k driver does not provide acceptable
network connectivity. Latencies are very high, often one has to
trigger the reload of a web page a couple of times to hit the 'right
moment' when data transfer happens. The same for retrieving files
with wget. It often takes several attempts to get the download started.
Once it has started, the download rate reaches normal values.
The worst for me is a completely broken SSH functionality. After
connecting to my lab from home, the session gets usually stuck while
I am typing some command. This already happens after simply hitting
the <return> key several times. Likewise, uploading even small files
via 'scp' is also impossible. the transfer will stall immediately,
something that does not happen when retrieving a file.

Version-Release number of selected component (if applicable):
kernel-2.6.26-0.25.rc3.git4.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Connect to some host via SSH.
2. Type a couple of characters.
  
Actual results:
Session gets stuck. It does not respond to user input anymore.

Expected results:
I/O via SSH proceeds without interruption.

Additional info:
- WLAN device is a D-Link DWL-G510 Rev. B4 sporting the supported
  AR2414 chipset.
- Networking works nicely after installing the madwifi driver.
- AP authentication is done via WEP.
- A possibly related thread on the ath5k-devel list:
  http://kerneltrap.org/mailarchive/linux-ath5k-devel/2008/5/21/1901024
Comment 1 Joachim Frieben 2008-05-24 07:50:42 EDT
There is a clear regression from kernel 2.6.25.3-18.fc9.x86_64 to
2.6.25.4-30.fc9.x86_64. Here are the module srcversions for both
kernels respectively:

         | 2.6.25.3-18.fc9.x86_64  2.6.25.4-30.fc9.x86_64
----------------------------------------------------------
ath5k    | 18908C2E600D9B437533B8C 5A711CFF69D9C2D6F93EE16
mac80211 | 0EB6E0DB88CA57CF73FF929 51709970CD733D92F93CD45
cfg80211 | F8516B9136CFABD233613B9 2F73EEBB2DE4F1D785951D4
Comment 2 Joachim Frieben 2008-05-25 04:26:18 EDT
The regression has been pinned down further to kernel 2.6.25.4-26.fc9
and later ones. From the changelog:

* Mon May 19 2008 John W. Linville <linville@redhat.com> 2.6.25.4-26
- Re-sync wireless bits w/ current upstream

Apart from the issues describes in the original report, I do also
observe intermittent crashes when connecting to the SSH server.
In a first time, I thought this was related to the new glibc-2.8.90
but for kernels < 2.6.25.4-26.fc9, they simply do not occur. Here
is an example of what I get from dmesg after ssh has returned
"segmentation fault" to the shell:

  ssh[2893]: segfault at 3 ip f063a9 sp 7fff0f00a260 error 4 in
  libresolv-2.8.90.so[efe000+12000]
Comment 3 Joachim Frieben 2008-05-25 04:29:40 EDT
*** Bug 447752 has been marked as a duplicate of this bug. ***
Comment 4 Helge Deller 2008-05-25 17:05:15 EDT
I see the same problems, but I don't think it's ath5k related, as I see the 
problems with p54 driver as well.
I think it happened between 2.6.26-rc2 and 2.6.26-rc3 (in this case both 
mainline kernels from Linus).
Comment 5 Joachim Frieben 2008-05-27 05:48:58 EDT
No improvement for kernel-2.6.26-0.33.rc4.fc10.x86_64.
Comment 6 Joachim Frieben 2008-05-28 03:30:37 EDT
Fixed in kernel 2.6.26-0.37.rc4.fc10.x86_64 with module versions

  ath5k   : 4ABA5AC1C9F2345308D07B0
  mac80211: 878E64070833DC29F41447C
  cfg80211: 2564D4FCC44D681E29221F0

Note You need to log in before you can comment on or make changes to this bug.