Bug 44779 - Installer crashed after start
Installer crashed after start
Status: CLOSED DUPLICATE of bug 19040
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-16 10:59 EDT by Petr Rympler
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 20:53:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Rympler 2001-06-16 10:59:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/usr/lib/anaconda/todo.py", line 1499, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 81af3b0>
mntPoint: /mnt/sysimage
selected: [Czech-HOWTO-txt, ImageMagick, LPRng, MAKEDEV, Mesa, ORBit, SDL, 
SysVinit, XFree86, XFree86-75dpi-fonts, XFree86-ISO8859-2, XFree86-ISO8859-
2-75dpi-fonts, XFree86-VGA16, XFree86-libs, XFree86-tools, XFree86-twm, 
XFree86-xdm, XFree86-xfs, Xaw3d, Xconfigurator, anacron, apache, apmd, 
ash, at, audiofile, aumix, authconfig, autorun, awesfx, basesystem, bash, 
bc, bdflush, bind-utils, binutils, bug-buddy, bzip2, cdda2wav, cdp, 
cdparanoia, cdrecord, chkconfig, chkfontpath, compat-libstdc++, console-
tools, control-center, control-panel, cpio, cracklib, cracklib-dicts, 
crontabs, cstools, cyrus-sasl, czech-adaptation, db1, db2, db3, desktop-
backgrounds, dev, dhcpcd, dia, diffutils, dip, dosfstools, e2fsprogs, ed, 
ee, eject, esound, etcskel-czech, etcskel-czech-root, etcskel-latin2, 
etcskel-latin2-root, expect, extace, file, filesystem, fileutils, 
findutils, finger, finger-server, fortune-mod, freetype, ftp, gawk, gd, 
gdbm, gdk-pixbuf, gdm, gedit, gftp, ghostscript, ghostscript-fonts, gimp, 
glade, glib, glibc, gmc, gmp, gnome-applets, gnome-audio, gnome-audio-
extra, gnome-core, gnome-libs, gnome-linuxconf, gnome-media, gnome-pim, 
gnome-print, gnome-users-guide, gnome-utils, gnorpm, gnotepad+, gnumeric, 
gnupg, gphoto, gpm, gqview, grep, groff, groff-czech, groff-perl, gtk+, 
gtk-engines, gtop, guile, gv, gzip, hdparm, imlib, imlib-cfgeditor, 
indexhtml, indexhtml-cs, info, initscripts, ipchains, iptables, iputils, 
isapnptools, isdn-config, isdn4k-utils, joe, kbdconfig, kdebase, kdelibs, 
kdemultimedia, kdenetwork, kdesupport, kdeutils, kernel, kernel-pcmcia-cs, 
kernel-utils, kernelcfg, kpppload, krb5-libs, kudzu, less, libghttp, 
libglade, libgtop, libjpeg, libpng, librep, libstdc++, libtermcap, 
libtiff, libungif, libxml, lilo, linuxconf, logrotate, losetup, lrzsz, m4, 
magicdev, mailcap, mailx, man, man-pages, man-pages-cs, mc, mikmod, 
mingetty, minicom, mkbootdisk, mkinitrd, mkisofs, mktemp, mkxauth, 
mod_csacek, mod_perl, mod_ssl, modemtool, modutils, mount, mouseconfig, 
mpage, mpg123, mtools, multimedia, ncftp, ncompress, ncurses, ncurses4, 
net-tools, netcfg, netpbm, netpbm-progs, netscape-common, netscape-
communicator, newt, nfs-utils, ntsysv, openldap, openssh, openssh-askpass, 
openssh-askpass-gnome, openssh-clients, openssh-server, openssl, pam, 
passwd, pciutils, perl, pidentd, pilot-link, pinfo, playmidi, playmidi-
X11, plugger, pnm2ppa, popt, portmap, ppp, printtool, procmail, procps, 
psmisc, pump, pwdb, pygnome, pygnome-libglade, pygtk, pygtk-libglade, 
python, python-xmlrpc, pythonlib, qt, qt1x, quota, raidtools, rdate, 
readline, redhat-logos, redhat-release, rep-gtk, rep-gtk-gnome, rep-gtk-
libglade, rhn_register, rhn_register-gnome, rhs-printfilters, rmt, 
rootfiles, rp-pppoe, rp3, rpm, rpm-build, rpm-python, rpmdb-redhat, 
rpmlint, rsh, rsh-server, rusers, rusers-server, rwall-server, rwho, rxvt, 
samba-client, samba-common, sane, sash, sawfish, sed, sendmail, setserial, 
setup, setuptool, sh-utils, shadow-utils, sharutils, slang, slocate, 
smpeg, sndconfig, sox, specspo, stat, statserial, stunnel, switchdesk, 
switchdesk-gnome, switchdesk-kde, sysklogd, sysstat, talk, talk-server, 
tar, tcl, tclx, tcp_wrappers, tcsh, telnet, telnet-server, termcap, tetex-
fonts, tetex-xdvi, textutils, tftp-server, time, timeconfig, timetool, 
tix, tk, tkinter, tksysv, tmpwatch, traceroute, umb-scheme, unzip, 
up2date, up2date-gnome, urw-fonts, usermode, utempter, util-linux, vim-
common, vim-minimal, vixie-cron, which, whois, words, wvdial, xcdroast, 
xchat, xinetd, xinitrc, xisdnload, xloadimage, xmms, xsane, xscreensaver, 
xsri, yp-tools, ypbind, ypserv, zip, zlib]
self: <image.CdromInstallMethod instance at 81956f0>
p: rpmdb-redhat
changeloop: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


How reproducible:
Always

Steps to Reproduce:
1.I start installer and he crash
2.
3.
	

Actual Results:  Nothing

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/usr/lib/anaconda/todo.py", line 1499, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 81af3b0>
mntPoint: /mnt/sysimage
selected: [Czech-HOWTO-txt, ImageMagick, LPRng, MAKEDEV, Mesa, ORBit, SDL, 
SysVinit, XFree86, XFree86-75dpi-fonts, XFree86-ISO8859-2, XFree86-ISO8859-
2-75dpi-fonts, XFree86-VGA16, XFree86-libs, XFree86-tools, XFree86-twm, 
XFree86-xdm,XFree86-xfs, Xaw3d, Xconfigurator, anacron, apache, apmd, 
ash, at, audiofile, aumix, authconfig, autorun, awesfx, basesystem, bash, 
bc, bdflush, bind-utils, binutils, bug-buddy, bzip2, cdda2wav, cdp, 
cdparanoia, cdrecord, chkconfig, chkfontpath, compat-libstdc++, console-
tools, control-center, control-panel, cpio, cracklib, cracklib-dicts, 
crontabs, cstools, cyrus-sasl, czech-adaptation, db1, db2, db3, desktop-
backgrounds, dev, dhcpcd, dia, diffutils, dip, dosfstools, e2fsprogs, ed, 
ee, eject, esound, etcskel-czech, etcskel-czech-root, etcskel-latin2, 
etcskel-latin2-root, expect, extace, file, filesystem, fileutils, 
findutils, finger, finger-server, fortune-mod, freetype, ftp, gawk, gd, 
gdbm, gdk-pixbuf, gdm, gedit, gftp, ghostscript, ghostscript-fonts, gimp, 
glade, glib, glibc, gmc, gmp, gnome-applets, gnome-audio, gnome-audio-
extra, gnome-core, gnome-libs, gnome-linuxconf, gnome-media, gnome-pim, 
gnome-print, gnome-users-guide, gnome-utils, gnorpm, gnotepad+, gnumeric, 
gnupg, gphoto, gpm, gqview, grep, groff, groff-czech, groff-perl, gtk+, 
gtk-engines, gtop, guile, gv, gzip, hdparm, imlib, imlib-cfgeditor, 
indexhtml, indexhtml-cs, info, initscripts, ipchains, iptables, iputils, 
isapnptools, isdn-config, isdn4k-utils, joe, kbdconfig, kdebase, kdelibs, 
kdemultimedia, kdenetwork, kdesupport, kdeutils, kernel, kernel-pcmcia-cs, 
kernel-utils, kernelcfg, kpppload, krb5-libs, kudzu, less, libghttp, 
libglade, libgtop, libjpeg, libpng, librep, libstdc++, libtermcap, 
libtiff, libungif, libxml, lilo, linuxconf, logrotate, losetup, lrzsz, m4, 
magicdev, mailcap, mailx, man, man-pages, man-pages-cs, mc, mikmod, 
mingetty, minicom, mkbootdisk, mkinitrd, mkisofs, mktemp, mkxauth, 
mod_csacek, mod_perl, mod_ssl, modemtool, modutils, mount, mouseconfig, 
mpage, mpg123, mtools, multimedia, ncftp, ncompress, ncurses, ncurses4, 
net-tools, netcfg, netpbm, netpbm-progs, netscape-common, netscape-
communicator, newt, nfs-utils, ntsysv, openldap, openssh, openssh-askpass, 
openssh-askpass-gnome, openssh-clients, openssh-server, openssl, pam, 
passwd, pciutils, perl, pidentd, pilot-link, pinfo, playmidi, playmidi-
X11, plugger, pnm2ppa, popt, portmap, ppp, printtool, procmail, procps, 
psmisc, pump, pwdb, pygnome, pygnome-libglade, pygtk, pygtk-libglade, 
python, python-xmlrpc, pythonlib, qt, qt1x, quota, raidtools, rdate, 
readline, redhat-logos, redhat-release, rep-gtk, rep-gtk-gnome, rep-gtk-
libglade, rhn_register, rhn_register-gnome, rhs-printfilters, rmt, 
rootfiles, rp-pppoe, rp3, rpm, rpm-build, rpm-python, rpmdb-redhat, 
rpmlint, rsh, rsh-server, rusers, rusers-server, rwall-server, rwho, rxvt, 
samba-client, samba-common, sane, sash, sawfish, sed, sendmail, setserial, 
setup, setuptool, sh-utils, shadow-utils, sharutils, slang, slocate, 
smpeg, sndconfig, sox, specspo, stat, statserial, stunnel, switchdesk, 
switchdesk-gnome, switchdesk-kde, sysklogd, sysstat, talk, talk-server, 
tar, tcl, tclx, tcp_wrappers, tcsh, telnet, telnet-server, termcap, tetex-
fonts, tetex-xdvi, textutils, tftp-server, time, timeconfig, timetool, 
tix, tk, tkinter, tksysv, tmpwatch, traceroute, umb-scheme, unzip, 
up2date, up2date-gnome, urw-fonts, usermode, utempter, util-linux, vim-
common, vim-minimal, vixie-cron, which, whois, words, wvdial, xcdroast, 
xchat, xinetd, xinitrc, xisdnload, xloadimage, xmms, xsane, xscreensaver, 
xsri, yp-tools, ypbind, ypserv, zip, zlib]
self: <image.CdromInstallMethod instance at 81956f0>
p: rpmdb-redhat
changeloop: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Brent Fox 2001-08-10 00:15:58 EDT

*** This bug has been marked as a duplicate of 19040 ***

Note You need to log in before you can comment on or make changes to this bug.