Bug 447852 - system:/ kio broken
system:/ kio broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase3 (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 483518
  Show dependency treegraph
 
Reported: 2008-05-22 01:10 EDT by Daniel Benamy
Modified: 2009-03-03 06:56 EST (History)
6 users (show)

See Also:
Fixed In Version: kdebase3-3.5.9-16.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-07 09:22:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 162454 None None None Never
KDE Software Compilation 163717 None None None Never

  None (edit)
Description Daniel Benamy 2008-05-22 01:10:22 EDT
Description of problem:
My initial problem is that I can't easily access cds since upgrading to fedora 9
/ kde 4. If I put in a cd, I get the box asking me what I want to do. If I pick
to open it in a new window, I get an error box that says:
URL cannot be listed
system:/media/sr0

If I try to access system:/ which I think used to list all the devices, I get an
error box:
URL cannot be listed
system:/
I'm thinking the initial problem might be caused by this.

I can become root and mount the cd manually and the automatic stuff seems to
work in gnome.

I blew away the ~/.kde directory of my test account and logged in again and it
didn't help.

Version-Release number of selected component (if applicable):
kdebase-runtime-4.0.4-1.fc9.x86_64
kdemultimedia-4.0.4-2.fc9.x86_64
kde-filesystem-4-14.fc9.noarch
kdebase-workspace-libs-4.0.4-4.fc9.i386
kdemultimedia-libs-4.0.4-2.fc9.x86_64
kdebase-libs-4.0.4-2.fc9.x86_64
kdebase-libs-4.0.4-2.fc9.i386
kdelibs-common-4.0.4-4.fc9.x86_64
kdelibs-4.0.4-4.fc9.i386
kdebase-workspace-4.0.4-4.fc9.x86_64
kdebase-workspace-libs-4.0.4-4.fc9.x86_64
kdebase-4.0.4-2.fc9.x86_64
hal-0.5.11-1.fc9.x86_64

How reproducible:
Every time.
Comment 1 Kevin Kofler 2008-05-22 01:18:05 EDT
There's no system:/ ioslave (at least no working one) in KDE 4. Mounting CDs 
doesn't work that way. So the fact that it tries to use system:/ sounds like a 
bug.
Comment 2 Daniel Benamy 2008-05-22 01:24:10 EDT
Oh. Thanks for the info. Should I file a new bug? What should I file it under?
Comment 3 Kevin Kofler 2008-05-22 01:26:37 EDT
I think this bug will be sufficient as far as Fedora is concerned. It would 
however be nice if you could also report this at http://bugs.kde.org for 
the "upstream" KDE project to see.
Comment 4 Daniel Benamy 2008-05-22 01:50:15 EDT
Done. Thanks for the quick reply!
Comment 5 Steven M. Parrish 2008-05-22 16:29:18 EDT
Closing local bug.  Will continue to monitor upstream for resolution.
Comment 6 Kevin Kofler 2008-06-10 12:01:34 EDT
Looks like the problem is that the dialog comes from KDE 3.
Comment 7 Kevin Kofler 2008-06-10 12:33:15 EDT
Daniel Benamy, do you have kdebase3 installed when this happens?
Comment 8 Fedora Update System 2008-06-11 11:26:45 EDT
kdebase3-3.5.9-16.fc9 has been submitted as an update for Fedora 9
Comment 9 Daniel Benamy 2008-06-12 01:11:01 EDT
I'm in the process of moving and don't hare that computer set up. I'll report
back when I get it set up again.
Comment 10 Fedora Update System 2008-06-12 22:26:23 EDT
kdebase3-3.5.9-16.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdebase3'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5306
Comment 11 Lukáš Tinkl 2008-06-24 11:10:54 EDT
Please test the update as described in comment #10
Comment 12 Kevin Kofler 2008-06-28 04:21:26 EDT
I just tried it, it fixes the problem. (The dialog from KDE 3 is no longer 
shown.)
Comment 13 Fedora Update System 2008-07-02 23:15:54 EDT
kdebase3-3.5.9-16.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-07-26 02:06:14 EDT
kdebase3-3.5.9-16.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Daniel Benamy 2008-07-29 04:52:30 EDT
(In reply to comment #7)
> Daniel Benamy, do you have kdebase3 installed when this happens?

Sorry for the delay. Yes I do and the latest update fixes this. Thanks!

Note You need to log in before you can comment on or make changes to this bug.