Bug 483518 - KlamAV shows error "KDE MediaManager not running"
KlamAV shows error "KDE MediaManager not running"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: klamav (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Andy Shevchenko
Fedora Extras Quality Assurance
:
Depends On: 447852
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 23:25 EST by Amit
Modified: 2009-03-31 16:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.46-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 16:31:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
klamav-0.44-no-kde3-mediamanager.patch (597 bytes, patch)
2009-03-08 04:49 EDT, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Amit 2009-02-01 23:25:11 EST
Description of problem:  
When launching KlamAV, an error message comes up stating "KDE MediaManager not running".  After posting on the Fedora Forum, someone confirmed that MediaManager service is not installed.

Version-Release number of selected component (if applicable):
Version-0.44
Release-3.fc10


How reproducible: Easily reproduce


Steps to Reproduce:
1. Launch KlamAV
2.
3.
  
Actual results: Error message shows that "KDE MediaManager is not running"


Expected results: No error message


Additional info:
Comment 1 Andy Shevchenko 2009-03-03 06:57:31 EST
Indeed. The error is present and I'm looking for proper fix. MediaManager for KDE3 was removed from Fedora due to bug #447852.
Comment 2 Kevin Kofler 2009-03-07 21:16:03 EST
Indeed, I don't think reenabling the KDE 3 media manager is an option. We need to fix KlamAV not to rely on it.
Comment 3 Kevin Kofler 2009-03-08 04:49:21 EDT
Created attachment 334430 [details]
klamav-0.44-no-kde3-mediamanager.patch

The attached patch should fix this. It simply disables the "Devices" tree which turned out empty anyway because there's no KDE 3 media manager anymore.

By the way, is there any reason you didn't upgrade Klamav to the recently-released 0.46? (It's not related to this bug though.)
Comment 4 Amit 2009-03-08 23:36:06 EDT
At the time this was posted, there was no update for klamav, I just updated to the latest version and still have the same issue.  I will run the patch to see if the issue is resolved.
Comment 5 Amit 2009-03-08 23:54:02 EDT
Sorry, but I am unable to locate the directorylist.cpp file, where is it located so I can install the patch?
Comment 6 Kevin Kofler 2009-03-09 00:48:45 EDT
It's a patch for the source code, it has to be applied by the package maintainer while compiling the package, not by you.
Comment 7 Kevin Kofler 2009-03-09 21:22:22 EDT
I had to rebuild klamav anyway for the new clamav in Rawhide, so I also applied my patch. Note that I also had to upgrade klamav to the latest version (0.46) to get support for the new clamav, I hope you won't mind. I really wanted to get the broken dependency fixed as soon as possible given the imminent beta freeze.

Fedora 9 and 10 still need to be fixed though.
Comment 8 Andy Shevchenko 2009-03-13 03:02:26 EDT
Kevin, thanks for quick help.
I'll try to update other Fedora branches ASAP.
Comment 9 Andy Shevchenko 2009-03-19 11:16:35 EDT
Nowadays packages are placed under koji. In evening I'm going to ask moving them to updates-testing repository.
Additionally the bug #490451 also fixed.
Comment 10 Fedora Update System 2009-03-19 17:49:00 EDT
klamav-0.46-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/klamav-0.46-2.fc10
Comment 11 Fedora Update System 2009-03-19 17:49:09 EDT
klamav-0.46-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/klamav-0.46-2.fc9
Comment 12 Fedora Update System 2009-03-20 14:33:06 EDT
klamav-0.46-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update klamav'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2863
Comment 13 Fedora Update System 2009-03-20 14:36:25 EDT
klamav-0.46-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update klamav'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2871
Comment 14 Amit 2009-03-21 12:16:47 EDT
I have installed the update and no longer receive the pop-up message.  I was able to update the virus definition file and scan my machine without issue.   Thank you for your assistance.
Comment 15 Fedora Update System 2009-03-31 16:31:34 EDT
klamav-0.46-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2009-03-31 16:36:58 EDT
klamav-0.46-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.