This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 447921 - perl-Unicode-MapUTF8 not rebuilt for Fedora 9
perl-Unicode-MapUTF8 not rebuilt for Fedora 9
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Unicode-MapUTF8 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
: 449194 (view as bug list)
Depends On:
Blocks: 444760 F9_5.10_REBUILD
  Show dependency treegraph
 
Reported: 2008-05-22 09:48 EDT by Paul Howarth
Modified: 2008-08-02 19:40 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.11-8.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-06 02:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2008-05-22 09:48:39 EDT
The perl-Unicode-MapUTF8 package in the Fedora 9 "Everything" repo is the
package originally built for perl 5.8.8 on Fedora 8, and is not found by perl
5.10.0 on Fedora 9. Somehow it managed to miss out on the great Fedora 9 perl
mass rebuild.

So when I try to use smbldap-tools, I get:

# smbldap-userlist 
Can't locate Unicode/MapUTF8.pm in @INC (@INC contains: /usr/sbin/
/usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi /usr/lib/perl5/5.10.0
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.10.0
/usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl .) at
/usr/lib/perl5/vendor_perl/5.10.0/smbldap_tools.pm line 28, <DATA> line 228.
BEGIN failed--compilation aborted at
/usr/lib/perl5/vendor_perl/5.10.0/smbldap_tools.pm line 28, <DATA> line 228.
Compilation failed in require at /usr/sbin/smbldap-userlist line 30, <DATA> line
228.
BEGIN failed--compilation aborted at /usr/sbin/smbldap-userlist line 30, <DATA>
line 228.

The package does rebuild OK as-is for Fedora 9, but could do with a bit of love
for better test coverage.
Comment 1 Paul Howarth 2008-05-22 10:23:01 EDT
I've checked into CVS (devel and F-9 branches) changes to bring the spec more in
line with the current perl spec template (as per the EL branches) and improve
the test coverage.

I've verified that the updated package, built for F9, fixes the problem shown above.

If you're happy with the changes, please tag and build them and prepare the
update for F-9.
Comment 2 Paul Howarth 2008-05-31 03:06:55 EDT
*** Bug 449194 has been marked as a duplicate of this bug. ***
Comment 3 Paul Howarth 2008-06-27 05:24:25 EDT
Aurelien, is there some problem why you're not wanting to issue an update for
this issue?
Comment 4 Paul Howarth 2008-07-04 15:47:36 EDT
OK, in the absence of any response from Aurelien and since this fix is basically
a no-brainer, I've tagged and built it myself and will now request an update in
bodhi.
Comment 5 Fedora Update System 2008-07-04 15:48:14 EDT
perl-Unicode-MapUTF8-1.11-8.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-07-06 02:12:43 EDT
perl-Unicode-MapUTF8-1.11-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.