Bug 448057 - xfce-setting-show and some of its applets do nothing
xfce-setting-show and some of its applets do nothing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce-mcs-plugins (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 04:34 EDT by Rob S.
Modified: 2009-05-02 12:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.4.3-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-02 12:24:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob S. 2008-05-23 04:34:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Description of problem:
On a default install of Fedora9 in Virtualbox, the XFCE control panel (/usr/bin/xfce-setting-show) does nothing at all. Neither do some of its plugins (notably the monitor settings).

The binary is in its normal location, however. I get no error messages when running /usr/bin/xfce-setting-show in a terminal, but nothing else happens either.

Is it safe to just uninstall and reinstall the package? 

I reinstalled Fedora9 thinking I had botched my install, but the same problem emerged again. 

Version-Release number of selected component (if applicable):
xfce-mcs-manager-4.4.2-2.fc9

How reproducible:
Always


Steps to Reproduce:
1.install Fedora without Gnome & with XFCE
2.try to run the xfce control panel in any way desired (via menu's or in terminal: /usr/bin/xfce-setting-show). 
3.nothing happens

Actual Results:
nothing :)

Expected Results:
the control panel should pop up

Additional info:
Running Virtualbox.
Comment 1 Rob S. 2008-05-23 04:51:24 EDT
I uninstalled/reinstalled xfce-mcs-manager and about half of XFCE, but I still
can't use the control panel. I also tried to start it as root, but no dice.
Comment 2 Kevin Fenzi 2008-05-23 12:09:28 EDT
Sounds like you might be getting hit by this bug: 
http://fedoraproject.org/wiki/Bugs/F9Common#head-4d00a901aba5a72b9f86a62147d1719af5717c66

So, try doing a 'yum groupinstall XFCE' and see if it pulls in some more
packages that were not installed? Then see if it works?
Comment 3 Rob S. 2008-05-24 08:22:38 EDT
I tried that, didn't work.

The full XFCE desktop is there, and even the binaries for xfce-setting-show (and
probably all the other related progs) are in place, they just don't work.

The worst thing about this is, that I badly need to change the screen size
because I have to do a lot of vertical scrolling (it looks like Virtualbox is
recognised as having a 1600x1200 screen or something like that).

Is there a way to 'group uninstall'? I may have missed something.

Comment 4 Kevin Fenzi 2008-05-24 13:47:00 EDT
There is a 'groupuninstall', but I don't think that will help... 

How are you logging in?

Is the xfce-mcs-manager process running? 'ps -axuww | grep xfce-mcs-manager' 

Does 'xfce-setting-show display' get you the display widget?
Comment 5 Rob S. 2008-05-25 07:18:17 EDT
- logging in: some graphical login screen (I assume the same one as in the Gnome
install)
- rob  2054  0.0  0.8  50672  4368  ?  Ss  15:04  0:00  xfce-mcs-manager (so
yes, it appears to be running. But what's with the question mark?)
- no, xfce-setting-show display doesn't get me the display widget, and I tried
some of the other widgets that are part of the same package and they don't work
either. (calendar settings & desktop settings don't work either)
Comment 6 Rob S. 2008-05-25 10:39:23 EDT
Now this is odd...

My problem is solved, but I don't understand how it may have happened.

I basically edited /etc/X11/xorg.conf manually (just added Modes "1024x768" to
Screen0) and rebooted. I was happy to see that my changes had been succesful,
and explored the rest of the system for a little while, until I accidentally
(without expecting anything) hit the 'Settings Manager' menu entry.

Lo and behold, the control panel (or Settings Manager, whatever) popped up!

Could it be that it's secretly dependent on a Mode being set in xorg.conf?

Comment 7 Kevin Fenzi 2008-05-25 12:43:44 EDT
Wow... that is odd. 

So everything is working for you now? 

When you had the higher resolution, was virtualbox showing it all, but having
you scroll a viewable area around in it? Or was it not showing everything?
Perhaps xfce-setting-show was being placed into an area of the screen you were
not looking? 

In any case, I guess we can go ahead and close this now? 
Comment 8 Rob S. 2008-05-25 12:52:23 EDT
Kevin,

I'm positive that nothing happened at all when I called xfce-setting-show. I was
scrolling around the screen all the time. (by the way, Virtualbox presented the
full screen with a vertical and horizontal scrollbar)

I think this is worth looking into; even if it might be an XFCE bug (or
feature), it should be straightened out whether or not the mcs manager depends
on display modes to succesfully run. I've had odd things happen in Xubuntu as
well when I opened the Display applet (though it only screwed up my font
rendering until next reboot). If we close this bug now w/out sending it upstream
with some more info, this might never get fixed, right?

If there's something else you'd like me to try (or if you want a DVD with my
virtual machine), feel free to ask.

Comment 9 Kevin Fenzi 2008-05-25 13:28:42 EDT
Agreed. I would be happy to file a bug for you upstream, but I can't duplicate
it, so I might not be able to provide full info for them. 

Would you be willing to file a bug upstream and assist them in tracking it down?
(bugzilla.xfce.org under Xfce and xfce-mcs-manager package)
Comment 10 Rob S. 2008-05-25 13:30:51 EDT
Can do.

But let's keep this one open, okay?

Comment 12 Kevin Fenzi 2008-05-25 13:59:35 EDT
I'd be happy to leave this open if you want, but not sure how much good it will
do. I have added myself to CC on the upstream bug, so I should know when it's
fixed upstream and we can update the Fedora packages at that time. 
Up to you. 
Comment 13 Rob S. 2008-05-25 14:16:36 EDT
Well, I don't know if we can re-open it if XFCE were to identify it as a bug
related to Fedora's implementation... If you prefer to, you can close the bug,
but it hasn't really been solved, has it...

Comment 14 Kevin Fenzi 2008-05-25 23:58:47 EDT
No big deal, I can leave it open... but there may not be much action until
upstream has had a chance to track it down. If they come up with a patch or the
like, I can surely update the fedora package when they do. 

BTW, thanks for reporting this bug... 
Comment 15 Christoph Wickert 2008-08-27 13:30:07 EDT
(In reply to comment #6)
> Now this is odd...
> 
..
> 
> Could it be that it's secretly dependent on a Mode being set in xorg.conf?

I don't think so, but maybe there is a bug in the display mcs plugin that breaks the plugin init when modes are not set, the plugin then prevents mcs-manager from starting up properly.

But just to make sure: Did you installed a screensaver in the meantime and we are seeing a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=448431 ?
Comment 16 Rob S. 2008-08-27 15:16:19 EDT
Quite sure. It wouldn't have made sense for me to install a screensaver in virtualbox...
Comment 17 Fedora Update System 2009-04-13 07:12:59 EDT
xfdesktop-4.4.3-1.fc9,gtk-xfce-engine-2.4.3-1.fc9,xfce4-icon-theme-4.4.3-1.fc9,orage-4.4.3-1.fc9,xfwm4-themes-4.4.3-1.fc9,xfce4-mixer-4.4.3-3.fc9,Thunar-0.9.3-1.fc9,Terminal-0.2.8.3-1.fc9,xfce4-session-4.4.3-1.fc9,xfce-utils-4.4.3-1.fc9,xfwm4-4.4.3-2.fc9,xfce4-panel-4.4.3-1.fc9,exo-0.3.4-3.fc9,xfce-mcs-plugins-4.4.3-1.fc9,xfce-mcs-manager-4.4.3-1.fc9.1,xfce4-appfinder-4.4.3-1.fc9,mousepad-0.2.14-1.fc9,libxfce4mcs-4.4.3-1.fc9,libxfcegui4-4.4.3-1.fc9,libxfce4util-4.4.3-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xfdesktop-4.4.3-1.fc9,gtk-xfce-engine-2.4.3-1.fc9,xfce4-icon-theme-4.4.3-1.fc9,orage-4.4.3-1.fc9,xfwm4-themes-4.4.3-1.fc9,xfce4-mixer-4.4.3-3.fc9,Thunar-0.9.3-1.fc9,Terminal-0.2.8.3-1.fc9,xfce4-session-4.4.3-1.fc9,xfce-utils-4.4.3-1.fc9,xfwm4-4.4.3-2.fc9,xfce4-panel-4.4.3-1.fc9,exo-0.3.4-3.fc9,xfce-mcs-plugins-4.4.3-1.fc9,xfce-mcs-manager-4.4.3-1.fc9.1,xfce4-appfinder-4.4.3-1.fc9,mousepad-0.2.14-1.fc9,libxfce4mcs-4.4.3-1.fc9,libxfcegui4-4.4.3-1.fc9,libxfce4util-4.4.3-1.fc9
Comment 18 Fedora Update System 2009-04-13 15:34:01 EDT
xfdesktop-4.4.3-1.fc9, gtk-xfce-engine-2.4.3-1.fc9, xfce4-icon-theme-4.4.3-1.fc9, orage-4.4.3-1.fc9, xfwm4-themes-4.4.3-1.fc9, xfce4-mixer-4.4.3-3.fc9, Thunar-0.9.3-1.fc9, Terminal-0.2.8.3-1.fc9, xfce4-session-4.4.3-1.fc9, xfce-utils-4.4.3-1.fc9, xfwm4-4.4.3-2.fc9, xfce4-panel-4.4.3-1.fc9, exo-0.3.4-3.fc9, xfce-mcs-plugins-4.4.3-1.fc9, xfce-mcs-manager-4.4.3-1.fc9.1, xfce4-appfinder-4.4.3-1.fc9, mousepad-0.2.14-1.fc9, libxfce4mcs-4.4.3-1.fc9, libxfcegui4-4.4.3-1.fc9, libxfce4util-4.4.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update xfdesktop gtk-xfce-engine xfce4-icon-theme orage xfwm4-themes xfce4-mixer Thunar Terminal xfce4-session xfce-utils xfwm4 xfce4-panel exo xfce-mcs-plugins xfce-mcs-manager xfce4-appfinder mousepad libxfce4mcs libxfcegui4 libxfce4util'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3521
Comment 19 Fedora Update System 2009-05-02 12:23:39 EDT
xfdesktop-4.4.3-1.fc9, gtk-xfce-engine-2.4.3-1.fc9, xfce4-icon-theme-4.4.3-1.fc9, orage-4.4.3-1.fc9, xfwm4-themes-4.4.3-1.fc9, xfce4-mixer-4.4.3-3.fc9, Thunar-0.9.3-1.fc9, Terminal-0.2.8.3-1.fc9, xfce4-session-4.4.3-1.fc9, xfce-utils-4.4.3-1.fc9, xfwm4-4.4.3-2.fc9, xfce4-panel-4.4.3-1.fc9, exo-0.3.4-3.fc9, xfce-mcs-plugins-4.4.3-1.fc9, xfce-mcs-manager-4.4.3-1.fc9.1, xfce4-appfinder-4.4.3-1.fc9, mousepad-0.2.14-1.fc9, libxfce4mcs-4.4.3-1.fc9, libxfcegui4-4.4.3-1.fc9, libxfce4util-4.4.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.