Bug 448431 - xfce-setting-show does not work
xfce-setting-show does not work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce-mcs-plugins (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 15:19 EDT by Kai Hambrecht
Modified: 2009-05-02 12:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.4.3-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 15:41:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace gdm 2.20 (44.14 KB, application/octet-stream)
2008-06-02 15:28 EDT, Michael Wagner
no flags Details
strace gdm 2.22 (44.41 KB, application/octet-stream)
2008-06-02 15:29 EDT, Michael Wagner
no flags Details
Before killing xfce-mcs-manager (20.23 KB, application/octet-stream)
2008-06-06 16:37 EDT, Michael Wagner
no flags Details
After killing xfce-mcs-manager (89.18 KB, application/octet-stream)
2008-06-06 16:38 EDT, Michael Wagner
no flags Details

  None (edit)
Description Kai Hambrecht 2008-05-26 15:19:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
XFCE settings manager does not show up at all. Neither from XFCE start menu nor from cmd-line (via xfce-setting-show).

Version-Release number of selected component (if applicable):
xfce-mcs-manager-4.4.2-2.fc9

How reproducible:
Always


Steps to Reproduce:
1. Login to XFCE desktop
2. launch "Settings Manager" from menu or start /usr/bin/xfce-setting-show
3. nothing happens

Actual Results:
nothing

Expected Results:
Settings Manager should show up.

Additional info:
I've seen, there is another bug in xfce-mcs-manager (see https://bugzilla.redhat.com/show_bug.cgi?id=448057 ), but this one is different. My xorg.conf does include the "Modes" line, but xfce-setting-show still does not work.

However i found out that xfce-setting-show will work if i manually kill xfce-mcs-manager before.
Comment 1 Michael Wagner 2008-06-02 11:00:58 EDT
I can confirm this behaviour. While it is working from runlevel 3 (startxfce4),
xfce-setting-show doesn't do anything when xfce4 is started from gdm. 

Furthermore, modifying /etc/xdg/xfce4/xinitrc and commenting out xfce4-session
makes xfce-setting-show working when xfce4 is started from gdm. It seems as if
gdm and xfce4-session conflict in some way.
Comment 2 Michael Wagner 2008-06-02 13:16:40 EDT
This issues has to be related to gdm-2.22. After rebuilding and "downgrading"
gdm-2.20 from Fedora 8, xfce-setting-show is working again.
Comment 3 Kevin Fenzi 2008-06-02 14:23:08 EDT
Very odd. I can't see this at all here, and I am using gdm-2.22 and F9. 

Is selinux enabled? Any AVC's in your /var/log/audit/audit.log that might
pertain to this issue?

Anything in either of your ~/.xsession-errors files when the problem is happening? 

Both of you are on i386? 
Comment 4 Michael Wagner 2008-06-02 15:28:46 EDT
Created attachment 307594 [details]
strace gdm 2.20
Comment 5 Michael Wagner 2008-06-02 15:29:44 EDT
Created attachment 307598 [details]
strace gdm 2.22
Comment 6 Michael Wagner 2008-06-02 15:31:01 EDT
Neither .xsession-errors nor audit.log contain any relevant information (i386,
SELinux=enforcing). Xfce-setting-show and xfce-mcs-manager do not produce any
backtraces as they terminate without errors. Attached are strace logs.
Comment 7 Kevin Fenzi 2008-06-02 15:44:56 EDT
Well, strace of xfce-setting-show isn't too useful, as all that command does is
tell xfce-mcs-manager to pop up the settings window. 

In both cases is xfce-mcs-manager running?

Can you make a new user and see if the problem happens with the new user account
as well?

A 'strace -p <pidofxfce-mcs-manager> -f' might be usefull for the failing case
at least. 
Comment 8 Michael Wagner 2008-06-02 16:15:24 EDT
Yes, xfce-mcs-manager is running in both cases. Even with a test user account,
xfce-setting-show fails to start. 

As it is working either from gdm 2.20 or from gdm 2.22 with xfce4-session
commented out, I wonder if gdm 2.22 is modifying any environment variables,
authentication mechanisms or settings resulting in an improper way of starting
xfce-mcs-manager via xfce4-session. Maybe it has to wait for something to
settle, as it is working after an "killall -s USR1 xfce-mcs-manager". 

I don't think that a trace of xfce-mcs-manager will provide any additional
information. The primary intention of the traces was to demonstrate, that
xfce-setting-show doesn't produce any viable error messages. 
Comment 9 Kevin Fenzi 2008-06-06 14:44:24 EDT
>I don't think that a trace of xfce-mcs-manager will provide any additional
>information. The primary intention of the traces was to demonstrate, that
>xfce-setting-show doesn't produce any viable error messages. 

Well, I disagree, due to the way that things are put together. 
xfce-setting-show is a very very simple program that simply sends a message to
the running xfce-mcs-manager process to popup and display the settings show
window. So, it's almost never going to have a problem, it's just sending a very
simple message to xfce-mcs-manager. 

A strace on xfce-mcs-manager should show why it's not honoring the request to
put up the window. Possibly it's not getting the message, or there is some error
communicating with the display, or something. I can't tell without the strace. 

can you try the strace of xfce-mcs-manager and run xfce-setting-show and then
attach the strace output?
Comment 10 Michael Wagner 2008-06-06 16:36:46 EDT
Attached is a trace of xfce-mcs-manager (before and after killing xfce-mcs-manager)

  strace -o xfce-mcs-manager.log -p `pgrep -f xfce-mcs-manager` -f &
  [1] 8201
  Process 3510 attached - interrupt to quit

  xfce-setting-show 
  kill -s 15 8201
  Process 3510 detached

  [1]+ Done strace -o xfce-mcs-manager.log -p `pgrep -f xfce-mcs-manager` -f
Comment 11 Michael Wagner 2008-06-06 16:37:51 EDT
Created attachment 308565 [details]
Before killing xfce-mcs-manager
Comment 12 Michael Wagner 2008-06-06 16:38:23 EDT
Created attachment 308566 [details]
After killing xfce-mcs-manager
Comment 13 Michael Wagner 2008-06-08 08:30:53 EDT
Hm, after installing either xscreensaver or gnome-screensaver xfce-setting-show
is working as expected. 
Comment 14 Kevin Fenzi 2008-06-08 17:12:55 EDT
That is very very strange. ;( 

Would you be able to: 

- remove them both and confirm problem re-occurs
- add them one at a time and see which one makes the error go away

I can try and duplicate here... I can't think of how xscreensaver would change
anything at all. 
Comment 15 Michael Wagner 2008-06-08 18:22:04 EDT
Sorry, it has nothing to do with xscreensaver, my fault. 

Prior trying xscreensaver, I have installed GNOME. In order to remove it
completely, I have greped yum.log with something like "Jun 08 13:4" and failed
to include gnome-screensaver. That's why I have been under the impression that
xscreensaver solves this issue as well.

However, gnome-screensaver really solves it for me. The following dependecies
are added by gnome-screensaver:
-libXScrnSaver-1.1.2-4.fc9.i386
-gnome-menus-2.22.2-1.fc9.i386
-fedora-screensaver-theme-1.0.0-1.fc8.noarch
-gnome-screensaver-2.22.1-1.fc9.i386
-fedorainfinity-screensaver-theme-1.0.0-1.fc8.noarch
Comment 16 Michael Wagner 2008-06-09 13:01:59 EDT
Yes, xscreensaver is solving this issue, too. In order to eliminate the
influence of any additional packages, that have been added after trying to hunt
down this problem, I have done a fresh network installation in a virtual
machine. The result: After installing either xscreensaver or gnome-screensaver,
xfce-setting-show is working as expected. 

If you try to duplicate it, here is what I have done:
1. Netinstall (additional packages unchecked [apart from yum and yum-utils])
2. yum groupinstall XFCE X-Window-System (group_package_types=mandatory)
3. yum install gdm
5. init 5
4. Verifying that xfce-setting-show doesn't work
5. yum install xscreensaver
6. logout -> login => xfce-setting-show is working
7. remove xscreensaver and its dependencies, install gnome-screensaver, logout/login
Comment 17 Kai Hambrecht 2008-06-09 15:02:37 EDT
I also checked this with xscreensaver and gnome-screensaver. Here my results:

1. neither xscreensaver nor gnome-screensaver installed: xfce-setting-show is
working
2. install one of xscreensaver or gnome-screensaver, or both of them:
xfce-setting-show does not work.
3. remove both, xscreensaver and gnome-screensaver: xfce-setting-show is working
again.
Comment 18 Michael Wagner 2008-06-14 03:46:52 EDT
Hm, this is in contrast to my experience. Is anybody able to reproduce it after
doing a fresh installation or am I missing something essential?
Comment 19 Wade Nelson 2008-07-22 19:51:27 EDT
I can confirm this bug with the same scenario as Comment #17

Here's what I've done:
1) Install Fedora 9 from the CD set, checking neither Gnome, KDE, nor Xfce
2) 'yum update'
3) 'yum groupinstall XFCE'
4) install a bunch of other software I use, including various xfce panel plugins
such as xfapplet, clipman, etc.

xfce-setting-show exits with no error, none of the xfce setting dialogs work
except "Autostarted Applications".

after remove gnome-screensaver (and/or xscreensaver, which I also tried)
xfce-setting-show and all other xfce setting dialogs work fine.

naturally there's no "Screensaver" setting in xfce-setting-show and the xfce
"Lock Screen" doesn't work, as I don't have xscreensaver or gnome-screensaver
installed.
Comment 20 Wade Nelson 2008-07-23 12:32:47 EDT
Followup to Comment #19 :

I had time to play around some more, and the following works:
'yum install xscreensaver{,-base,-extras,-gl-base,-gl-extras}'

I can then use xscreensaver and the Xfce "Lock Screen" works as well.
xfce-setting-show also works, however there's no option to configure the
screensaver.  There's also no option to configure the screensaver from the
"Settings" menu.

I currently have "xscreensaver" in Autostarted Applications and configure it via
"xscreensaver-demo"

gnome-screensaver still causes the same problem noted in Comment #17 and Comment #19
Comment 21 Kai Hambrecht 2008-07-25 10:15:47 EDT
I just checked this again. Same results as in Comment #17. If either
xscreensaver or gnome-screensaver is installed, xfce-setting-show does not work
(unless i manually kill xfce-mcs-manager before). If i uninstall both
screensavers, xfce-setting-show works well again.
Comment 22 Michael Wagner 2008-07-26 04:26:40 EDT
While xfce-setting-show is working, if I run xfce via startxfce4 (regardless of
whether or not a screensaver is installed), it is still not working without an
installed screensaver when running via gdm.

If requested, I can point to a snapshot showing xfce-setting-show with
xscreensaver installed.
Comment 23 Kevin Fenzi 2008-07-28 23:00:45 EDT
There should be no need to put xscreensaver in autostarted applications. 
It's automatically started by Xfce if its installed. In fact it could cause
there to be 2 xscreensaver instances running. 

I am pretty puzzled by this as I have xscreensaver installed here and settings
show works just dandy. 

I will do some installs in a virtual machine and see if I can duplicate or track
down whats going on here. Any additional information welcome...
Comment 24 Kai Hambrecht 2008-07-30 05:16:47 EDT
If you need some more details regarding my system (e.g. package list, system
trace of xfce-mcs-manager etc.), please let me know.
Comment 25 Kevin Fenzi 2008-08-11 20:39:51 EDT
Ok, this appears to be a bug in the screensaver-mcs-plugin. If it can't find a screensaver it fails and the entire settings show doesn't come up. 

We could just require gnome-screensaver here, or xscreensaver, or try and patch the plugin so that if neither one is installed it just doesn't do anything... 

Adding fedora@christoph-wickert.de here for his input.
Comment 26 Christoph Wickert 2008-08-27 13:37:27 EDT
Reassigning to xfce-mcs-plugins, since this is where the screensaver mcs plugin comes from.

The problem with this plugin is hardcodes "xscreensaver-demo" and returns MCS_PLUGIN_INIT_ERROR if it does not find it.

Our options are:
1. Require xscreensaver
2. Patch the plugin for gnome-screensaver. Fairly simple, but then we hardcode gnome-screensaver-preferences and need to require the gnome-screensaver package.
3. Patch the plugin to simply return MCS_PLUGIN_INIT_OK even if no screensaver is found. This would result in a non functional icon in mcs-manager, but at least we make sure the mcs manager init is not broken
4. Patch the plugin so that it can use both xscreensaver and gnome-screensaver and prefer the latter if installed, because it offers more functionality (user switching).
5. Add a copy of the screensaver plugin for gnome-screensaver. If somebody has both screensavers installed he will see two icons.

I dont really like 1-3, seems acceptable and 4 would be the best.

BTW. A patch to use gnome-screensaver in xfce-utils is attached to bug # 450425.
Comment 27 Christoph Wickert 2008-08-27 13:38:19 EDT
(In reply to comment #26)
> I dont really like 1-3, seems acceptable and 4 would be the best.

should read:
... 5 seems acceptable ...
Comment 28 Kai Hambrecht 2008-08-27 15:18:25 EDT
(In reply to comment #26)
> The problem with this plugin is hardcodes "xscreensaver-demo" and returns
> MCS_PLUGIN_INIT_ERROR if it does not find it.

unfortunately this is only half the truth ;-) This affects some users (see Comment #16). But for others, it's just the other way round (Comment #17). If xscreensaver is not installed, xfce-setting-show works, of course without the plugin for screensaver settings.

So there are some questions:

- why xfce-setting-show (x-s-s) does work with xscreensaver installed (and does not if xscreensaver is not installed) for some users, whereas for other users it is the other way round?

- what is the difference before and after manually killing xfce-mcs-manager, which would enable x-s-s?

- what is the difference between starting XFCE via gdm vs. starting via startxfce4, which also enables x-s-s?

- what happens if xscreensaver is started from autostart applications? This also enables x-s-s, but without screensaver plugin although "xscreensaver-demo" should exist.
Comment 29 Fedora Update System 2009-04-13 07:12:52 EDT
xfdesktop-4.4.3-1.fc9,gtk-xfce-engine-2.4.3-1.fc9,xfce4-icon-theme-4.4.3-1.fc9,orage-4.4.3-1.fc9,xfwm4-themes-4.4.3-1.fc9,xfce4-mixer-4.4.3-3.fc9,Thunar-0.9.3-1.fc9,Terminal-0.2.8.3-1.fc9,xfce4-session-4.4.3-1.fc9,xfce-utils-4.4.3-1.fc9,xfwm4-4.4.3-2.fc9,xfce4-panel-4.4.3-1.fc9,exo-0.3.4-3.fc9,xfce-mcs-plugins-4.4.3-1.fc9,xfce-mcs-manager-4.4.3-1.fc9.1,xfce4-appfinder-4.4.3-1.fc9,mousepad-0.2.14-1.fc9,libxfce4mcs-4.4.3-1.fc9,libxfcegui4-4.4.3-1.fc9,libxfce4util-4.4.3-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xfdesktop-4.4.3-1.fc9,gtk-xfce-engine-2.4.3-1.fc9,xfce4-icon-theme-4.4.3-1.fc9,orage-4.4.3-1.fc9,xfwm4-themes-4.4.3-1.fc9,xfce4-mixer-4.4.3-3.fc9,Thunar-0.9.3-1.fc9,Terminal-0.2.8.3-1.fc9,xfce4-session-4.4.3-1.fc9,xfce-utils-4.4.3-1.fc9,xfwm4-4.4.3-2.fc9,xfce4-panel-4.4.3-1.fc9,exo-0.3.4-3.fc9,xfce-mcs-plugins-4.4.3-1.fc9,xfce-mcs-manager-4.4.3-1.fc9.1,xfce4-appfinder-4.4.3-1.fc9,mousepad-0.2.14-1.fc9,libxfce4mcs-4.4.3-1.fc9,libxfcegui4-4.4.3-1.fc9,libxfce4util-4.4.3-1.fc9
Comment 30 Fedora Update System 2009-04-13 15:33:54 EDT
xfdesktop-4.4.3-1.fc9, gtk-xfce-engine-2.4.3-1.fc9, xfce4-icon-theme-4.4.3-1.fc9, orage-4.4.3-1.fc9, xfwm4-themes-4.4.3-1.fc9, xfce4-mixer-4.4.3-3.fc9, Thunar-0.9.3-1.fc9, Terminal-0.2.8.3-1.fc9, xfce4-session-4.4.3-1.fc9, xfce-utils-4.4.3-1.fc9, xfwm4-4.4.3-2.fc9, xfce4-panel-4.4.3-1.fc9, exo-0.3.4-3.fc9, xfce-mcs-plugins-4.4.3-1.fc9, xfce-mcs-manager-4.4.3-1.fc9.1, xfce4-appfinder-4.4.3-1.fc9, mousepad-0.2.14-1.fc9, libxfce4mcs-4.4.3-1.fc9, libxfcegui4-4.4.3-1.fc9, libxfce4util-4.4.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update xfdesktop gtk-xfce-engine xfce4-icon-theme orage xfwm4-themes xfce4-mixer Thunar Terminal xfce4-session xfce-utils xfwm4 xfce4-panel exo xfce-mcs-plugins xfce-mcs-manager xfce4-appfinder mousepad libxfce4mcs libxfcegui4 libxfce4util'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3521
Comment 31 Fedora Update System 2009-04-13 15:41:05 EDT
xfce-mcs-plugins-4.4.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2009-05-02 12:23:32 EDT
xfdesktop-4.4.3-1.fc9, gtk-xfce-engine-2.4.3-1.fc9, xfce4-icon-theme-4.4.3-1.fc9, orage-4.4.3-1.fc9, xfwm4-themes-4.4.3-1.fc9, xfce4-mixer-4.4.3-3.fc9, Thunar-0.9.3-1.fc9, Terminal-0.2.8.3-1.fc9, xfce4-session-4.4.3-1.fc9, xfce-utils-4.4.3-1.fc9, xfwm4-4.4.3-2.fc9, xfce4-panel-4.4.3-1.fc9, exo-0.3.4-3.fc9, xfce-mcs-plugins-4.4.3-1.fc9, xfce-mcs-manager-4.4.3-1.fc9.1, xfce4-appfinder-4.4.3-1.fc9, mousepad-0.2.14-1.fc9, libxfce4mcs-4.4.3-1.fc9, libxfcegui4-4.4.3-1.fc9, libxfce4util-4.4.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.