This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 448077 - gnome-typing-monitor locks only one head
gnome-typing-monitor locks only one head
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened, Triaged
: 499002 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 07:33 EDT by Jan "Yenya" Kasprzak
Modified: 2011-06-27 09:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 09:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2008-05-23 07:33:30 EDT
Description of problem:
In F8, I have used dual-screen setup (aka Zaphod mode, two separate screens,
:0.0 and :0.1). In F9 I have moved to xrandr-based single virtual screen (the F9
ATI driver has problems in Zaphod mode on my HW). The gnome-typing-monitor does
not work as expected: when the typing break occurs, it locks only one physical
screen, not the whole virtual screen. In F8, it locked both screens correctly.

Version-Release number of selected component (if applicable):
control-center-2.22.1-4.fc9.x86_64

How reproducible:
100 %

Steps to Reproduce:
0. Have a dual-head setup with single virtual screen based on xrandr.
1. Enable Typing break in Gnome Main Menu -> System -> Preferences -> Hardware
-> Keyboard (the Typing break tab).
2. Use the keyboard until the gnome-typing-break locks the screen.
  
Actual results:
Only the screen on which the cursor is is being locked.

Expected results:
Whole virtual screen (i.e. both heads) should be locked.

The typing break on Zaphod-mode setups probably still works as expected, but I
have no way of verifying it now.
Comment 1 Jan "Yenya" Kasprzak 2008-05-23 07:58:49 EDT
Another related problem: when the cursor is on the second head, the second head
gets locked, but the image under the grey stripes is taken from the first head.
Comment 2 Bastien Nocera 2008-05-23 08:23:48 EDT
Yeah, that code is probably uber busted.
Comment 3 Bastien Nocera 2008-05-23 08:27:00 EDT
Upstream is at:
http://bugzilla.gnome.org/show_bug.cgi?id=492974
Comment 4 Jan "Yenya" Kasprzak 2008-05-23 08:59:22 EDT
Thanks, I have added a back-reference to the upstream bugzilla. You can probably
close this one as UPSTREAM (?).
Comment 5 Jan "Yenya" Kasprzak 2008-12-19 05:51:38 EST
Just a short note - this bug is still not fixed in GNOME 2.24 (Fedora 10).
Comment 6 Bastien Nocera 2009-05-07 23:02:10 EDT
*** Bug 499002 has been marked as a duplicate of this bug. ***
Comment 7 Jan "Yenya" Kasprzak 2009-11-20 02:45:02 EST
Reopening, the bug is still present in Fedora 12 (control-center-2.28.1-4.fc12.x86_64), and still not fixed upstream.
Comment 8 Matthias Clasen 2010-01-24 22:47:27 EST
This was improved a while ago:

* Mon Dec  7 2009 Matthias Clasen <mclasen@redhat.com> 2.28.1-9
- Improve typing break locking for multiple monitors
Comment 9 Jan "Yenya" Kasprzak 2010-01-25 02:27:19 EST
Works for me (gnome-settings-daemon-2.28.1-10.fc12.x86_64), thanks!
Comment 10 Jan "Yenya" Kasprzak 2010-05-31 04:29:16 EDT
I am reopening the bug, because in gnome-settings-daemon-2.30.1-6.fc13.x86_64 and control-center-2.30.1-2.fc13.x86_64 the problem is back. Only the right head is locked. The left one is still available for mouse input, but not for the keyboard input.

In addition to that, the "Postpone break" button becomes active after about 5 seconds s after the screen is locked (I am not sure whether this a bug or feature, but it definitely does not help in the "I am in a hurry" situations :-).
Comment 11 Bug Zapper 2011-06-02 14:31:30 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2011-06-27 09:58:33 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.