Bug 448092 - Internal system error when selecting package group
Internal system error when selecting package group
Status: CLOSED DUPLICATE of bug 448062
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-05-23 09:16 EDT by Ken Doherty
Modified: 2008-05-28 05:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-28 05:08:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
PackageKit error (364.71 KB, image/png)
2008-05-23 09:17 EDT, Ken Doherty
no flags Details
Update History (39.40 KB, image/png)
2008-05-23 09:18 EDT, Ken Doherty
no flags Details
Installed PackageKit version (159 bytes, text/plain)
2008-05-23 09:20 EDT, Ken Doherty
no flags Details

  None (edit)
Description Ken Doherty 2008-05-23 09:16:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.1)

Description of problem:
Run System>Admin>Add/Remove Software and get "An Internal system error has occurred" error when selecting the package group in PackageKit software updater.  No Packages are displayed.

Same error appears for System>Admin>Update System but 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Upgraded from F8 to F9
2. Ran yum updategroup for several package groups
3. Rebooted
4. Used Add/Remove Software successfully to add Expect to system
5. Got notice of 11 new updates, installed all updates - See screenshot UpdateHistory.png
6. Went to install additional software via Add/Remove Software and got the "internal system error" message - See screenshot PackageKitError.png

Actual Results:

Expected Results:

Additional info:
Text of Error
Error Type: <type 'exceptions.AttributeError'>
Error Value: 'NoneType' object has no attribute 'cacheonly'
  File : /usr/share/PackageKit/helpers/yum/search-group.py , line 21, in <module>
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 226, in wrapper
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 469, in search_group
    pkgGroupDict = self._buildGroupDict()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 437, in _buildGroupDict
    cats = self.yumbase.comps.categories
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 594, in <lambda>
    comps = property(fget=lambda self: self._getGroups(),
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 529, in _getGroups
  File : /usr/lib/python2.5/site-packages/yum/repos.py , line 67, in doSetup
  File : /usr/lib/python2.5/site-packages/yum/plugins.py , line 175, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File : /usr/lib/yum-plugins/fastestmirror.py , line 133, in postreposetup_hook
    if opts.cacheonly
Comment 1 Ken Doherty 2008-05-23 09:17:29 EDT
Created attachment 306491 [details]
PackageKit error
Comment 2 Ken Doherty 2008-05-23 09:18:25 EDT
Created attachment 306492 [details]
Update History

Software Updater did not work after downloading the highlighted updates.
Comment 3 Ken Doherty 2008-05-23 09:20:24 EDT
Created attachment 306494 [details]
Installed PackageKit version
Comment 4 Richard Hughes 2008-05-23 09:51:03 EDT
Are you running the latest yum?
Comment 5 Ken Doherty 2008-05-23 11:26:01 EDT
[root@mimo-lt1 kdoherty]# rpm -qa | grep yum
[root@mimo-lt1 kdoherty]# 

Comment 6 Richard Hughes 2008-05-28 05:08:20 EDT

*** This bug has been marked as a duplicate of 448062 ***

Note You need to log in before you can comment on or make changes to this bug.