Bug 448062 - Pirut crashes after recent yum-* update
Pirut crashes after recent yum-* update
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
: 448092 448513 448614 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 05:24 EDT by Mary Ellen Foster
Modified: 2016-09-19 22:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 16:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pirut crash log (1.89 KB, text/plain)
2008-05-23 05:24 EDT, Mary Ellen Foster
no flags Details

  None (edit)
Description Mary Ellen Foster 2008-05-23 05:24:50 EDT
Description of problem:
I did an update this morning which installed new version of yum-utils,
yum-skip-broken, and yum-fastestmirror. Since that update, pirut crashes when it
tries to run. The dialogue box says
    "An unhandled exception has occurred.  This is most likely a bug.  Please
save the crash dump and file a detailed bug report against pirut at
https://bugzilla.redhat.com/bugzilla"

I'll attach the crash dump.

Version-Release number of selected component (if applicable):
pirut-1.3.28-1.fc8
But I didn't update that today, so I suspect one of the new yum packages:
yum-skip-broken-1.1.14-1.fc8
yum-utils-1.1.14-1.fc8
yum-fastestmirror-1.1.14-1.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Run "pirut"
  
Actual results:
Crash

Expected results:
System update

Additional info:
"yum update" now prints this at the start of its output:
Configuration file /etc/yum/pluginconf.d/fastestmirror-asyncore.conf not found
Unable to find configuration file for plugin fastestmirror-asyncore

Don't know if that's related.
Comment 1 Mary Ellen Foster 2008-05-23 05:24:50 EDT
Created attachment 306469 [details]
Pirut crash log
Comment 2 Jeremy Katz 2008-05-23 12:05:08 EDT
Plugin bug.
Comment 3 James Antill 2008-05-23 14:32:07 EDT
Relevant bit is:

  File "/usr/lib/yum-plugins/fastestmirror.py", line 133, in postreposetup_hook
    if opts.cacheonly:
AttributeError: 'NoneType' object has no attribute 'cacheonly'


...I'm guessing changing that to:

    if hasattr(opts, 'cacheonly') and opts.cacheonly

...will fix it (can you check/confirm mary?).
Comment 4 Luke Macken 2008-05-23 16:29:15 EDT
Fixed in 50e3b20a427335f914fa3e64b96324184cb0001d
Comment 5 Fedora Update System 2008-05-26 08:13:21 EDT
yum-utils-1.1.14-3.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-05-26 08:14:33 EDT
yum-utils-1.1.14-3.fc9 has been submitted as an update for Fedora 9
Comment 7 Luke Macken 2008-05-27 11:24:44 EDT
*** Bug 448513 has been marked as a duplicate of this bug. ***
Comment 8 Luke Macken 2008-05-27 17:11:00 EDT
*** Bug 448614 has been marked as a duplicate of this bug. ***
Comment 9 Richard Hughes 2008-05-28 05:08:21 EDT
*** Bug 448092 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2008-05-28 22:34:54 EDT
yum-utils-1.1.14-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-4407
Comment 11 Jan Hutař 2008-08-06 10:06:52 EDT
Checked that with yum-fastestmirror-1.1.14-1.fc8.noarch.rpm I was getting:

# yum upgrade
Loading "fastestmirror" plugin
Configuration file /etc/yum/pluginconf.d/fastestmirror-asyncore.conf not found
Unable to find configuration file for plugin fastestmirror-asyncore
Loading mirror speeds from cached hostfile
...

and after update to yum-fastestmirror-1.1.14-4.fc8 I have:

# yum upgrade
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
...

=> VERIFIED
Comment 12 Fedora Update System 2008-08-07 09:59:55 EDT
yum-utils-1.1.15-1.fc9 has been submitted as an update for Fedora 9
Comment 13 Fedora Update System 2008-08-07 10:05:46 EDT
yum-utils-1.1.15-1.fc8 has been submitted as an update for Fedora 8
Comment 14 Fedora Update System 2008-08-12 14:17:35 EDT
yum-utils-1.1.15-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7132
Comment 15 Fedora Update System 2008-08-12 14:25:05 EDT
yum-utils-1.1.15-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7211
Comment 16 Jan Hutař 2008-08-21 08:14:39 EDT
Changing to VERIFIED as per comment #11.
Comment 17 petrosyan 2008-09-09 16:55:36 EDT
If the bug has been fixed its status should be changed to CLOSED.
VERIFIED means that the bug is still present.
Comment 18 Fedora Update System 2008-09-10 02:47:23 EDT
yum-utils-1.1.15-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2008-09-10 03:04:54 EDT
yum-utils-1.1.15-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.