Bug 448111 - gnucash can't start, probably dbus problem, not sure where to assign
gnucash can't start, probably dbus problem, not sure where to assign
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: GConf2 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 11:02 EDT by Jonathan Kamens
Modified: 2008-08-23 23:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-23 23:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-05-23 11:02:27 EDT
Just updated everything on my machine from Rawhide.

When I launch gnucash in a remote session (i.e., not inside GNOME), I get this
dialog:

An error occurred while loading or saving configuration information for gnucash.
Some of your configuration sessins may not work properly.
                                        [Details]
                                        [OK]

And this dialog:

Cannot find default values
The configuration data used to specify default values for GnuCash cannot be
found in the default system locations.  Without this data GnuCash will still
operate properly but it may require some extra time to setup.  Do you wish to
setup the configuration data?
[Help] [Quit] [Skip] [Setup]

If I Click [Setup] and then [Forward] and then tell it to update the search path
automatically, it still fails, and prints message like this to stdout:

Failed to load key /apps/gnucash/general/show_splash_screen: Failed to contact
configuration server; some possible causes are that you need to enable TCP/IP
networking for ORBit, or you have stale NFS locks due to a system crash. See
http://www.gnome.org/projects/gconf/ for information. (Details -  1: Failed to
get connection to session: Failed to connect to socket /tmp/dbus-0RsFotJ65o:
Connection refused)Failed to load key /apps/gnucash/general/account_separator:
Failed to contact configuration server; some possible causes are that you need
to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a
system crash. See http://www.gnome.org/projects/gconf/ for information. (Details
-  1: Failed to get connection to session: Failed to connect to socket
/tmp/dbus-eBhCMJtWcB: Connection refused)Failed to load key
/apps/gnucash/general/auto_decimal_point: Failed to contact configuration
server; some possible causes are that you need to enable TCP/IP networking for
ORBit, or you have stale NFS locks 

If I launch gnucash with "dbus-launch gnucash", it works fine.

Like I said in the Summary, perhaps this is a dbus issue rather than a GnuCash
issue, but I'd like confirmation of that from the gnucash folks rather than just
assigning it straight to dbus.

Thanks.
Comment 1 Bill Nottingham 2008-05-23 11:10:08 EDT
This is rawhide-only, correct? Assigning to GConf2.
Comment 2 Matthias Clasen 2008-08-23 23:56:11 EDT
I believe this has been fixed meanwhile. For a while GConf wouldn't work with a session bus. See bug 446703. If you still experience this problem, please reopen.

Note You need to log in before you can comment on or make changes to this bug.