Bug 448145 - NFS4 mounts deleted from fstab during upgrade
NFS4 mounts deleted from fstab during upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 418641 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-23 14:55 EDT by Jeff Garzik
Modified: 2013-07-02 22:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 16:28:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Garzik 2008-05-23 14:55:14 EDT
Description of problem:
Upgrading from Fedora 8/x86-64 to Fedora 9/x86-64 using preupgrade-cli. 
Everything upgraded properly as expected, save for one thing:

The newly-upgraded machine's fstab was missing the NFS mounts manually placed
there, leading to users with NFS-mounted drives unable to login after the upgrade.

Version-Release number of selected component (if applicable):
Whatever preupgrade-cli installed on 2008-05-22 for Fedora 9 target.

How reproducible:
100%

Steps to Reproduce:
1. Install Fedora 8.
2. Manually add NFSv4 mount entry to /etc/fstab
3. Verify that mount works
4. Run pre-upgrade-cli, upgrading to Fedora 9
5. Reboot
6. Complete installation, via anaconda
7. Reboot
8. Note that no NFS filesystems are mounted, and no NFS entries are in /etc/fstab
  
Actual results:
No NFS mounts.

Expected results:
NFS settings carried through upgrade.

Additional info:
Comment 1 Greg Morgan 2008-05-26 01:59:38 EDT
fsset.py takes care of fstab edits.  I am guessing that preupdate is not passing
the correct rootPath to edit fstab similar to how a system is mounted during
upgrade or installation i.e. path = anaconda.rootPath + '/etc/fstab'.  Hence,
the fstab is not correctly read to copy the existing mount points to the new
system.  The only other problem could be that lines are dropped from your fstab
because they are not properly formatted i.e.   if len(fields) < 4: continue
..elif len(fields) > 6:continue.

Perhaps submitting your fstab nsf mounts may be helpful?

It looks like this should go to the preupdate folks so they can determine if a
patch is required for anaconda or a fix in their code.  However, I don't have
permission to change this yet.
Comment 2 Jeff Garzik 2008-05-26 17:37:55 EDT
Sure thing.  All the machines in my home lab have the following in /etc/fstab as
the last line of the file:

pretzel:/               /g                      nfs4    defaults 0 0

The rest of fstab contents is stock Fedora-via-anaconda.
Comment 3 Jeremy Katz 2008-05-27 11:36:18 EDT
nfs4 is the key here.  But should be fixed in git.
Comment 4 Chris Lumens 2008-08-06 15:15:55 EDT
*** Bug 418641 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.