Bug 448259 - current Rawhide named crashes with current Rawhide kernel
current Rawhide named crashes with current Rawhide kernel
Status: CLOSED DUPLICATE of bug 448277
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-24 23:14 EDT by Jonathan Kamens
Modified: 2013-04-30 19:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-26 08:22:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-05-24 23:14:25 EDT
jik2:/tmp!1008$ sudo service named restart
[sudo] password for jik: 
Stopping named:                                            [  OK  ]
Starting named: named: prctl(PR_SET_DUMPABLE) failed: Success
                                                           [FAILED]
jik2:/tmp!1009$ rpm -q bind; uname -r
bind-9.5.0-34.rc1.fc10.i386
2.6.26-0.25.rc3.git4.fc10.i686
jik2:/tmp!1010$
Comment 1 Jonathan Kamens 2008-05-24 23:47:42 EDT
Turns out the PR_SET_DUMPABLE error is a false flag.  From /var/log/messages,
here's what's really going wrong:

May 24 23:41:59 jik2 named[7492]: isc_log_open '/var/run/named/named.run'
failed: permission denied
May 24 23:41:59 jik2 named[7492]: couldn't open pid file
'/var/run/named/named.pid': Permission denied

/var/run/named isn't group-writeable in the bind RPM, even though it needs to be
for the named user to be able to write to it.
Comment 2 Adam Tkac 2008-05-26 08:22:42 EDT

*** This bug has been marked as a duplicate of 448277 ***

Note You need to log in before you can comment on or make changes to this bug.