Bug 448277 - named: couldn't open pid file '/var/run/named/named.pid': File exists
named: couldn't open pid file '/var/run/named/named.pid': File exists
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 448259 448394 (view as bug list)
Depends On:
Blocks: 225614
  Show dependency treegraph
 
Reported: 2008-05-25 07:10 EDT by Robert Scheck
Modified: 2013-04-30 19:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-26 12:07:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-05-25 07:10:32 EDT
Description of problem:
Adam, can you please fix ASAP what Jon with his fscking rpmlinting package 
review broke? Thanks. Try to restart 9.5.0-34.rc1 (without chroot):

May 25 03:08:20 tux named[8839]: couldn't open pid file '/var/run/named/
named.pid': File exists

Kill /var/run/named/named.pid

May 25 03:08:23 tux named[8916]: couldn't open pid file '/var/run/named/
named.pid': Permission denied

Watch at broken permissions of /var/run/named and see the issue. The problem
was introduced due to package review changes, see http://cvs.fedora.redhat.com/
viewcvs/devel/bind/bind.spec?r1=1.263&r2=1.264

Switched from 

%defattr(0660,named,named,0770)
%dir %{_localstatedir}/run/named

to

%defattr(-,root,named,-)
%dir %{_localstatedir}/run/named

which broke bind server!

Version-Release number of selected component (if applicable):
bind-9.5.0-34.rc1

How reproducible:
Everytime, see above.

Actual results:
Broken bind, can't start named without manual intervention.

Expected results:
Fixing e.g. by switching to as it was before.
Comment 1 Adam Tkac 2008-05-26 08:22:43 EDT
*** Bug 448259 has been marked as a duplicate of this bug. ***
Comment 2 Adam Tkac 2008-05-26 09:42:12 EDT
*** Bug 448394 has been marked as a duplicate of this bug. ***
Comment 3 Adam Tkac 2008-05-26 12:07:40 EDT
fixed in 9.5.0-35.rc1.fc10, thanks for report.

Note You need to log in before you can comment on or make changes to this bug.