This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 44827 - nfs-utils pkg owns rpc.rquotad man page but not binary
nfs-utils pkg owns rpc.rquotad man page but not binary
Status: CLOSED DUPLICATE of bug 39707
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-17 23:33 EDT by Seth Vidal
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-17 23:33:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2001-06-17 23:33:30 EDT
Description of Problem:
two problems really:
1. nfs-utils has the man page from rpc.rquotad - but not the binary - the
binary is in the quota pkg.

2. nfs-utils starts rpc.rquotad from its init scripts but nfs-utils does
not depend on quota to be installed. 



The first problem is easy to fix.

The best situation would be to have the nfs-utils init script modified to
do a simple check for the existence of /usr/sbin/rpc.rquotad - if it
doesn't exist it doesn't try to run it.

this is nitpicky but it will make things more tidy and potentially more sane.
Comment 1 Bob Matthews 2001-06-18 10:13:19 EDT
Seth,

This will be fixed in the next release.

(NB: Dups 39707, 43340.)

*** This bug has been marked as a duplicate of 39707 ***
Comment 2 adrian.lawrence 2001-08-07 05:19:28 EDT
version 0.3.1 -5 is installing a  dangling symbolic link rpc.rquotad which needs
cleaning up?
Comment 3 adrian.lawrence 2001-08-07 05:32:09 EDT
The last comment was a duplicate of 39707 : sorry. 

However, /etc/rc.d/init.d/nfs does not test for the presence of the binary
rpc.rquotad, 
so reports a spurious failure.
Comment 4 Bob Matthews 2001-08-07 10:22:35 EDT
> However, /etc/rc.d/init.d/nfs does not test for the presence of the binary
> rpc.rquotad...

Fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.