Bug 44830 - Kernel 2.4 does NOT BOOT
Kernel 2.4 does NOT BOOT
Status: CLOSED DUPLICATE of bug 39089
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-18 02:29 EDT by Need Real Name
Modified: 2006-02-21 13:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-18 02:29:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; digit_062001)

Description of problem:
Hi,
I recently got the RedHat Linux 7.1 professional edition and installed it. 
The installation went fine. But when I restarted the system, Linux just 
would not start. i.e. After Lilo, I get a few boot up messages and then it 
stops with no activity. the last message is always "Starting Kswapd 1.8" 
and then the macahine just freezes. Even ctrl+alt+del dows not work. The 
cursor just keeps blinking with no further activity. I reinstalled 7.1 
many times but the system would just hang at the point "Starting Kswapd 
1.8" HOWEVER, i could use loadlin (using the image of the kernel of 
RedHat6.2) to load Linux. 7.1 DID START! But none of the moudles ,of 
course, were loaded. I finally installed 2.2.14-12 and the machine works 
but not upto the expectations(like no sound etc). I tried most of the pre 
2.4 kernels (like 2.2.14-12, 2.2.16, 2.2.17)and they all work. Only the 
2.4.x kernels don't start.

How reproducible:
Always

Steps to Reproduce:
1.Just staring linux
2.
3.
	

Actual Results:  Does not boot. The last message displayed is "Starting 
kswapd v1.8"

Expected Results:  The login screen

Additional info:

My systems config might be important to note:
Compaq Presario 2262
96MB RAM
10.5 GB HDD of which 5GB is Linux Native
Diamond stealth 2000 3D pro card
ESS 1869
Comment 1 Arjan van de Ven 2001-06-18 04:03:53 EDT
It would be helpful to see the output of lspci and dmesg of the latest kernel
that does actually boot. That way, I get more info about the hardware and
hopefully the problem.
Comment 2 Andre Robatino 2001-06-28 17:09:09 EDT
  Also see bug 39191, which I am experiencing, and bug 39089.  I did a capture
of the boot messages via the serial console that shows that the problem with bug
39191 is a kswapd failure (there is a huge number of call trace numbers after
this so you can't tell just by looking at the monitor).
Comment 3 Need Real Name 2001-07-06 11:27:36 EDT
The following is waht dmesg shows up
__________________________________________________________________

Linux version 2.2.14-12 (root@monster.exocore.com) (gcc version egcs-2.91.66
19990314/Linux (egcs-1.1.2 release)) #1 Sun Apr 30 14:36:09 IST 2000
Detected 233863489 Hz processor.
ide_setup: hdb=ide-scsi
Console: colour VGA+ 80x25
Calibrating delay loop... 233.47 BogoMIPS
Memory: 91292k/94208k available (1048k kernel code, 416k reserved, 1388k data,
64k init, 0k bigmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Dentry hash table entries: 262144 (order 9, 2048k)
Buffer cache hash table entries: 131072 (order 7, 512k)
Page cache hash table entries: 32768 (order 5, 128k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Cyrix M II 3.5x Core/Bus Clock stepping 08
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.35a (19990819) Richard Gooch (rgooch@atnf.csiro.au)
PCI: PCI BIOS revision 2.10 entry at 0xfd9d4
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 131072 bhash 65536)
Initializing RT netlink socket
Starting kswapd v 1.5
Detected PS/2 Mouse Port.
Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
pty: 256 Unix98 ptys configured
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.9)
Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
SIS5513: IDE controller on PCI bus 00 dev 09
SIS5513: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xfcf0-0xfcf7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xfcf8-0xfcff, BIOS settings: hdc:DMA, hdd:pio
hda: ST32111A, ATA DISK drive
hdb: SAMSUNG CDRW/DVD SM-308B, ATAPI CDROM drive
hdc: WDC WD84AA, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: ST32111A, 2014MB w/128kB Cache, CHS=1023/64/63
hdc: WDC WD84AA, 8063MB w/2048kB Cache, CHS=16383/16/63
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
raid5: MMX detected, trying high-speed MMX checksum routines
   pII_mmx   :   354.330 MB/sec
   p5_mmx    :   408.813 MB/sec
   8regs     :   351.282 MB/sec
   32regs    :   123.063 MB/sec
using fastest function: p5_mmx (408.813 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
 hda: hda1
 hdc: [PTBL] [1092/240/63] hdc1 hdc2 hdc3 < hdc5 hdc6 >
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 64k freed
Adding Swap: 204080k swap-space (priority -1)
Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
SB 3.01 detected OK (220)
ESS chip ES1869 detected
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
scsi : 1 host.
  Vendor: SAMSUNG   Model: CDRW/DVD SM-308B  Rev: BS02
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 0x/32x writer cd/rw xa/form2 cdda tray
Uniform CDROM driver Revision: 2.56
parport0: PC-style at 0x378 [SPP,PS2]
parport0: PC-style at 0x378 [SPP,PS2]
parport0: no IEEE-1284 device present.
lp0: using parport0 (polling).


lspci gives the following
__________________________________

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 5597 [SiS5582] (rev 10)
00:01.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513 (rev 01)
00:01.1 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:01.2 USB Controller: Silicon Integrated Systems [SiS] 7001 (rev 10)
00:14.0 VGA compatible controller: Silicon Integrated Systems [SiS] 5597/5598
VGA (rev 68)


Comment 4 Alan Cox 2003-06-06 09:48:15 EDT

*** This bug has been marked as a duplicate of 39089 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:48:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.