Bug 448326 - Add-ins in monodevelop could not start
Add-ins in monodevelop could not start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-25 18:03 EDT by Joseph Smidt
Modified: 2008-10-08 01:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 04:43:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of problem (131.09 KB, image/png)
2008-05-25 18:03 EDT, Joseph Smidt
no flags Details
monodevelop startup log showing add-in errors (5.77 KB, text/plain)
2008-05-27 20:28 EDT, Ben Liblit
no flags Details

  None (edit)
Description Joseph Smidt 2008-05-25 18:03:58 EDT
Description of problem:  When monodevelop is started, an error screen pops up
saying "The following add-ins could not be started."  It doesn't list and
add-ins, just a bunch of null exceptions.

I have attached screenshot to show the error gui.


Version-Release number of selected component (if applicable):
monodevelop-0.19-6.fc6

How reproducible:


Steps to Reproduce:
1.install monodevelop
2.start monodevelop
3.
  
Actual results:
See attached screenshot. 

Expected results:
monodevelop to start with no errors.

Additional info: uname -a:
Linux localhost.localdomain 2.6.25.3-18.fc9.i686 #1 SMP Tue May 13 05:38:53 EDT
2008 i686 i686 i386 GNU/Linux
Comment 1 Joseph Smidt 2008-05-25 18:03:58 EDT
Created attachment 306631 [details]
Screenshot of problem
Comment 2 Paul F. Johnson 2008-05-27 11:32:13 EDT
Which version of mono-addins are you using?
Comment 3 Joseph Smidt 2008-05-27 11:41:29 EDT
I am using mono-addins-0.3-5.fc9 (i386)
Comment 4 Ben Liblit 2008-05-27 20:28:26 EDT
Created attachment 306862 [details]
monodevelop startup log showing add-in errors

I'm seeing the same problem, also with monodevelop-0.19-6.fc9.i386 and
mono-addins-0.3-5.fc9.i386.  The error dialog that eventually appears
duplicates a stream of error messages printed during startup.  I'm attaching a
complete log of those error messages in case they are more useful than a screen
shot.
Comment 5 Ben Liblit 2008-05-27 20:31:34 EDT
Incidentally, the first line of that log, which mentions libgtkembedmoz.so, is
believed to be unrelated to this problem.  I described that warning message in
bug #448174 and Paul F. Johnson says it can be ignored.  Furthermore, even if I
set if I set MOZILLA_FIVE_HOME to work around bug #448174, the add-in startup
problems described here still arise.
Comment 6 James Boulton 2008-06-05 16:39:35 EDT
In monodevelop on my development machine (Fedora 9 X86_64) I can't use the
visual designer or change the project properties (it is greyed out). This maybe
because this functionality is provided by the missing Addins. Is this consistent
with others experience or should I file a new bug?
Comment 7 Paul F. Johnson 2008-06-05 17:58:29 EDT
Mono-addins in F9 should be 0.3.1-x. I'm just trying a rebuild now (as well as
rebuilding monodevelop-1.0)

New mono-addins should hit the F9 updates tomorrow. I'd recommend hosing
~/.config/MonoDevelop

For some reason, MD is failing to build for x86_64
Comment 8 Ben Liblit 2008-06-05 18:02:45 EDT
Regarding comment #6, I'm not sure where to find something called a "visual
designer", but Project -> Options is definitely disabled (greyed out) for me too.
Comment 9 Ben Liblit 2008-06-26 19:01:52 EDT
This is definitely still broken.  I've got mono-addins-0.3-5.fc9.i386, which is
the latest available update.  What happened to the 0.3.1 rebuild promised in
comment #7?
Comment 10 Paul F. Johnson 2008-06-26 19:13:11 EDT
updates-testing?
Comment 11 Ben Liblit 2008-06-26 19:31:22 EDT
I see no mono-related packages in
<http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/9/i386/> at
this time.  Zero.
Comment 12 James Boulton 2008-06-26 20:13:05 EDT
I have updated to mono-addins 0.3.1-2.fc10 (along with 130MB) of dependencies.
This fixes the startup errors, I am able to bring up the project options. But
stetic the GUI builder is still not working.

Comment 13 James Boulton 2008-06-26 20:25:33 EDT
Updating my last comment. The GUI builder works for new Projects but not for my
existing projects. Not sure why yet.
Comment 14 Fabian Deutsch 2008-07-28 07:00:17 EDT
I'm also running into these problems and wonder when thos fixes get pushed into
fedora-updates. Currently I can just find them in rawhide.
Comment 15 Paul F. Johnson 2008-09-12 04:43:40 EDT
can you file the rawhide (if they're still there) into a different bug? I'm closing this one as mono-addins-0.3.1 is now in f9-update-candidates.
Comment 16 Ben Liblit 2008-09-13 11:37:13 EDT
Forgive my ignorance, but where do I find packages that are "now in f9-update-candidates"?

I see mono-addins-0.3.1-2.2.fc10 in rawhide, but comment #15 makes me think that's something different.  I don't see any mono-addins-0.3.1 packages in the regular Fedora 9 updates or updates-testing repositories.
Comment 17 Paul F. Johnson 2008-09-13 12:25:35 EDT
fedora-updates-testing repo?
Comment 18 Ben Liblit 2008-09-13 19:04:07 EDT
As I said in comment #16, there is no mono-addins-0.3.1 package in Fedora 9 updates-testing.  Visit <http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/9/i386/> yourself and look.  It's not there.  Likewise for <http://download.fedoraproject.org/pub/fedora/linux/updates/testing/9/i386/>.  It's just not there; I don't know what else I can tell you.
Comment 19 Christian Krause 2008-09-14 17:38:21 EDT
(In reply to comment #17)
> fedora-updates-testing repo?

Not yet. ;-)
According to https://admin.fedoraproject.org/updates/mono-addins-0.3.1-2.2.fc9 the status is still "pending" and so it is not in updates-testing yet. 

(In reply to comment #18)
> As I said in comment #16, there is no mono-addins-0.3.1 package in Fedora 9
> updates-testing.  Visit
> <http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/9/i386/>
> yourself and look.  It's not there.  Likewise for
> <http://download.fedoraproject.org/pub/fedora/linux/updates/testing/9/i386/>. 
> It's just not there; I don't know what else I can tell you.

The packages are already built and they can be downloaded via koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=62786
Comment 20 Christian Krause 2008-09-15 16:45:12 EDT
I've tried out mono-addins-0.3.1-2.2.fc9 and I'd like to confirm that the problem is gone:
- no error messages regarding the add-ins
- Project -> Options seems usable again

Paul, please can you make sure that the package will appear in the official updates directory soon? ;-)
Comment 21 Paul F. Johnson 2008-09-15 17:00:21 EDT
It's waiting for approval.... I can't move any quicker than that.
Comment 22 Ben Liblit 2008-10-08 01:08:29 EDT
Looks like mono-addins-0.3.1-2.2.fc9 finally made it through to the released-updates repository.  I confirm that the problem is gone.  Yay!

Note You need to log in before you can comment on or make changes to this bug.