This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 448414 - Enabling Flyspell mode gave an error
Enabling Flyspell mode gave an error
Status: CLOSED DUPLICATE of bug 443549
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 12:32 EDT by xunilarodef
Modified: 2010-08-19 17:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 09:20:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description xunilarodef 2008-05-26 12:32:55 EDT
Description of problem:
Cannot successfully enable on-the-fly spell checking mode.

Version-Release number of selected component (if applicable):
emacs-22.2-4.fc9.i386

How reproducible:
Every time.

Steps to Reproduce:
1. Start emacs, visit a .txt file.
2. M-x flyspell-mode
or
1. Start emacs, visit a .txt file, with lines in your .emacs file such as:

(add-hook 'text-mode-hook
          '(lambda () (flyspell-mode t)))
(add-hook 'prog-mode-hook
          '(lambda () (flyspell-prog-mode t)))

Actual results:
Status line shows "Enabling Flyspell mode gave an error", and
spell checking is not active.

Expected results:
Enter flyspell mode, with normally functional spell checking.

Additional info:
One circumvention is to (also) add to your .emacs file the following:

  ;; for Fedora 9 where ispell dictionaries are gone ...
  (setq ispell-program-name "hunspell")

Thank you for making so that (at a glance) ispell works out of the
box.  I have not explored to see exactly how that was accomplished,
but it would be reasonable to use a similar or identical strategy for
transparently allowing flyspell mode to be enabled with the
consolidated dictionaries.

In attempting to understand this problem, I downloaded

  http://www-sop.inria.fr/mimosa/Manuel.Serrano/flyspell/flyspell-1.7n.el

copied it to /usr/share/emacs/22.2/lisp/textmodes/flyspell.el and
renamed the fedora original flyspell.elc.  In a new emacs session,
when flyspell-mode attempts to autoload, the status line displays:

File mode specification error: (file-error "Searching for program" "no such file
or directory" "ispell")

and the *Messages* buffer contains:

Local Ispell dictionary set to nil
Starting new Ispell process [default] ...
File mode specification error: (file-error "Searching for program" "no such file
or directory" "ispell")
Comment 2 Caolan McNamara 2008-11-12 09:20:25 EST

*** This bug has been marked as a duplicate of bug 443549 ***
Comment 3 Barry Nichols 2010-08-19 17:12:41 EDT
I have come across this issue on openSUSE and I resolved it by installing 'aspell-ispell' rather than 'ispell'. This may be worth a try.

Note You need to log in before you can comment on or make changes to this bug.