Bug 443549 - spell-buffer, flyspell-mode do not work
spell-buffer, flyspell-mode do not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
: Reopened
: 448414 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 02:30 EDT by Pawel Salek
Modified: 2009-12-02 14:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 04:28:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2008-04-22 02:30:08 EDT
Description of problem:
Attempt to execute spell-buffer fails with message "Searching for program: no
such file or directory, spell". Attempt to enable flyspell-mode fails silently.

Version-Release number of selected component (if applicable):
emacs-23.0.60-2.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Type M-x spell-bufffer
  
Actual results:
Message as above is produced.

Expected results:
Spell checking process should start

Additional info:
I have hoped that setting ispell-program-name variable to hunspell would fix the
problem but no go...
Comment 1 Pawel Salek 2008-04-22 02:34:18 EDT
I have just noticed that installing aspell manually fixes the problem. I think
though that adapting emacs interface so that it can use hunspell would be optimal...
Comment 2 Chip Coldwell 2008-04-22 13:12:13 EDT

*** This bug has been marked as a duplicate of 443639 ***
Comment 3 Pawel Salek 2008-11-03 02:40:48 EST
Bug present in emacs-22.2-5.fc9.x86_64 with slightly different symptoms.
1. M-x flyspell-mode produces a message: "Enabling Flyspell mode gave an error".
2. M-x ispell-buffer produces: "apply: Searching for program: no such file or directory, ispell".

Installing aspell works around the problem. I believe the proper fix is simple: spell packages should nowadays try to execute hunspell instead of ispell program.
Comment 5 Caolan McNamara 2008-11-12 09:20:25 EST
*** Bug 448414 has been marked as a duplicate of this bug. ***
Comment 6 Bug Zapper 2008-11-25 21:13:15 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Kevin Cahill 2009-02-07 01:34:21 EST
6 Feb. 2009

I am running FC10.  The latest emacs freezes when I turn on Flyspell. 

When I updated to the very latest emacs a day or so ago, I got this Delphic message:
/usr/bin/etags.emacs has not been configured as an alternative for etags 
What does that mean?  What should I do?


This is a serious problem for a person writing a book because running the speller on the whole book takes time and brings up all sorts of correctly spelled words that the speller hangs on.
Comment 8 Kevin Cahill 2009-02-07 23:01:25 EST
6 Feb. 2009

I am running FC10.  The latest emacs freezes when I turn on Flyspell. 

When I updated to the very latest emacs a day or so ago, I got this Delphic message:
/usr/bin/etags.emacs has not been configured as an alternative for etags 
What does that mean?  What should I do?


This is a serious problem for a person writing a book because running the speller on the whole book takes time and brings up all sorts of correctly spelled words that the speller hangs on.
Comment 9 Daniel Novotny 2009-02-09 05:59:08 EST
Kevin, the etags thing is a bug. I am working on it, it's bug #484309
Comment 10 Gustavo Maciel Dias Vieira 2009-04-09 07:45:43 EDT
Same problem is still present in F11 beta. The symptons are exactly like comment #3. The emacs version is: emacs-22.3-10.fc11.x86_64

The workaround is to set ispell-program-name to hunspell. It seems that setting this as the default for Emacs would solve the problem.
Comment 11 Daniel Novotny 2009-04-10 08:08:36 EDT
OK, hunspell is now the default
also adding hunspell to "Requires", to make sure it's installed
fixed in emacs-22.3-11.fc11
Comment 12 Thomas Moschny 2009-04-30 09:39:48 EDT
Problem is still there with emacs-22.3-11.fc11
(or maybe it's a different problem?):

(1) Start emacs.
(2) Open a file.
(3) M-x ispell-change-dictionary, american
(4) M-x flyspell-mode

-> two different outcomes:

(a) Emacs hangs and uses 100% cpu.
(b) Message: Enabling Flyspell mode gave an error


At least case (b) can be repdrocuced (7 out of 10 times) like this:

$ echo "(ispell-change-dictionary \"american\")(flyspell-mode)(message (symbol-value 'ispell-program-name))" | emacs -q --batch -l /usr/share/emacs/site-lisp/default.el -l /dev/stdin

Output:
Loading /usr/share/emacs/site-lisp/site-start.d/auctex.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/focus-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/git-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/igrep-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/lilypond-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/php-mode-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/po-mode-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/preview-latex.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/rpm-spec-mode-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/rpmdev-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/ruby-mode-init.el (source)...
Loading /usr/share/emacs/site-lisp/site-start.d/w3m-init.el (source)...
Local Ispell dictionary set to american
Starting new Ispell process [american] ...
Enabling Flyspell mode gave an error
hunspell
Comment 13 Gustavo Maciel Dias Vieira 2009-05-01 14:15:23 EDT
(In reply to comment #12)
> Problem is still there with emacs-22.3-11.fc11
> (or maybe it's a different problem?):

It's a different, but related, issue. The problem you describe is caused by changing the dictionary. See Bug #495047
Comment 14 Daniel Novotny 2009-05-04 04:28:24 EDT
since the problem in comment #12 is caused by changing the dictionary, closing again.
Comment 15 Gustavo Maciel Dias Vieira 2009-07-27 11:19:17 EDT
This bug has reappeared. I've created a clean installation of F11, with all updates, and got the following error:

ispell-init-process: Error: No word lists can be found for the language "pt_BR".

This means that the alternative fix for this bug, proposed in bug# 508033 , does not work out of the box.

The explanation is simple. Aspell isn't the default word checker for Fedora. As such, it isn't installed and more importantly its dictionaries are not installed for the default language. As a result, adding a dependency for aspell solves nothing, as it is necessary to add appropriate dictionaries for it to work.

I would like to ask the owner to reopen this bug.
Comment 16 Lane 2009-12-02 14:49:25 EST
FYI,

I found flyspell mode was failing for me in F11. After searching around I finally found that I had to 

yum install aspell-en 

to get it to work again.

Note You need to log in before you can comment on or make changes to this bug.