Bug 448421 - Encrypted swap triggers bug #439371
Encrypted swap triggers bug #439371
Status: CLOSED DUPLICATE of bug 447841
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.2
i686 Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Jones
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-26 14:03 EDT by Ian Pilcher
Modified: 2008-06-03 13:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 13:53:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2008-05-26 14:03:03 EDT
Description of problem:
See bug #439371 and below.

Version-Release number of selected component (if applicable):
mkinitrd-5.1.19.6-28

How reproducible:
100%

Steps to Reproduce:
1. Create logical volume for encrypted swap.
2. Configure /etc/crypttab and /etc/fstab to use encrypted swap. 
3. Install new kernel package.
  
Actual results:
/sbin/mkinitrd: line 368: cd: slaves: No such file or directory
mkinitrd hangs

Expected results:
initrd created, grub.conf updates, etc.

Additional info:
Here is my /etc/crypttab:

crypt   /dev/ipilcher_vg/crypt_lv       none
swap    /dev/ipilcher_vg/swap_lv        /dev/urandom    \
                        cipher=aes-cbc-essiv:sha256,swap

(I.e. /dev/mapper/swap is the encrypted device, on top of
/dev/ipilcher_vg/swap_lv.)

This gives me the following:

/sys/block/dm-9
/sys/block/dm-9/dev
/sys/block/dm-9/holders
/sys/block/dm-9/range
/sys/block/dm-9/removable
/sys/block/dm-9/size
/sys/block/dm-9/stat
/sys/block/dm-9/subsystem -> ../../block
/sys/block/dm-9/uevent
/sys/block/dm-9/slaves
/sys/block/dm-9/slaves/dm-1 -> ../../../block/dm-1
/sys/block/dm-9/slaves/dm-1/dev
/sys/block/dm-9/slaves/dm-1/holders
/sys/block/dm-9/slaves/dm-1/range
/sys/block/dm-9/slaves/dm-1/removable
/sys/block/dm-9/slaves/dm-1/size
/sys/block/dm-9/slaves/dm-1/stat
/sys/block/dm-9/slaves/dm-1/subsystem -> ../../block
/sys/block/dm-9/slaves/dm-1/uevent
/sys/block/dm-9/slaves/dm-1/slaves
/sys/block/dm-9/slaves/dm-1/slaves/sda3 ../../../block/sda/sda3
/sys/block/dm-9/slaves/dm-1/slaves/sda3/dev
/sys/block/dm-9/slaves/dm-1/slaves/sda3/holders
/sys/block/dm-9/slaves/dm-1/slaves/sda3/size
/sys/block/dm-9/slaves/dm-1/slaves/sda3/start
/sys/block/dm-9/slaves/dm-1/slaves/sda3/stat
/sys/block/dm-9/slaves/dm-1/slaves/sda3/subsystem -> ../../../block
/sys/block/dm-9/slaves/dm-1/slaves/sda3/uevent

When parsing this tree, mkinitrd tries to cd to
/sys/block/dm-9/slaves/dm-1/slaves/sda3/slaves, which doesn't exist.
Comment 2 Ian Pilcher 2008-06-03 13:53:18 EDT

*** This bug has been marked as a duplicate of 447841 ***

Note You need to log in before you can comment on or make changes to this bug.